Overheating WJ limited 4.7 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 11-09-2013, 09:22 AM Thread Starter
wrorrer
Registered User
2002 WJ 
 
Join Date: Apr 2009
Location: Cerntreville, VA
Posts: 17
Overheating WJ limited 4.7

Hey guys,

Trying to troubleshoot overheating WJ. Problem first noticed on highway drive cabin heat suddenly stopped and engine started to over heat.

Made it home without hitting red mark, and now trying to narrow down the cause.

In garage I can turn on from cold, allow to come up to operating temp, then will immediately start creeping up higher. Reservoir is full of coolent.

After turning engine off when overheating is beginning, for 10-15 minutes afterwards, I can hear what sounds like a tiny leak of pressure escaping. I can affect the sound of the leak by squeezing upper radiator hose. Upper radiator hose does get hot when engine is at and above operating temp so appears the tstat is opening as it should. Do not see any sign of coolent leaking.

Waiting for engine to cool down to make sure coolent is full via radiator cap and bleeder valve.

Figure I will start with the obvious of making sure coolent system is full. Beyond that, water pump?? If pump was problem would upper radiator hose get hot?

And why no cabin heat?


Thoughts?

wrorrer is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-09-2013, 11:07 AM Thread Starter
wrorrer
Registered User
2002 WJ 
 
Join Date: Apr 2009
Location: Cerntreville, VA
Posts: 17
Took about 3/4 gallon coolent and them burped a bunch and then another top off. Runs cool with cabin heat back to normal. Love the easy ones!!
wrorrer is offline  
post #3 of 4 Old 11-09-2013, 12:41 PM
Bandit84
Registered User
2004 WJ 
 
Join Date: May 2008
Location: MN
Posts: 239
Glad it was an easy fix!

85' CJ7
Bandit84 is offline  
post #4 of 4 Old 11-10-2013, 07:43 AM
gold01wj
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Toadlena,
Posts: 314
Are you sure it's that easy? 3/4 of gallon of coolant had to go somewhere....

2000 wj limited quadradrive 4.7 family vehicle-was stock, then lifted 4",now stock again
gold01wj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome