Open circuit showing in the evic - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Open circuit showing in the evic

*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*Stainless Steel Door Hinge PinsPoly Door Hinge Bushings

Reply
Unread 06-11-2013, 07:20 PM   #1
wheelhead
Member
 
wheelhead's Avatar
1999 XJ Cherokee 
 
Join Date: May 2012
Location: Nashua, NH
Posts: 112
Open circuit showing in the evic

Just like the title says. Wife just came back from the store an told me this. Any idea guys in girls. It has been pouring rain for the hole day if that helps. No dummy lights on dash or anything like that.

__________________
1999 Cherokee
D30 HP front "open"
Chrysler 8.25 rear "open"
Its a work in progress
wheelhead is offline   Reply With Quote
Unread 06-11-2013, 10:33 PM   #2
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego, California
Posts: 713
it literally says open circuit on the overhead display ? new to me... someone will know though
__________________
2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline   Reply With Quote
Unread 06-12-2013, 03:43 PM   #3
wheelhead
Member
 
wheelhead's Avatar
1999 XJ Cherokee 
 
Join Date: May 2012
Location: Nashua, NH
Posts: 112
Yea that's what it said. But it's all good now. So I don't know.
__________________
1999 Cherokee
D30 HP front "open"
Chrysler 8.25 rear "open"
Its a work in progress
wheelhead is offline   Reply With Quote
Unread 06-12-2013, 04:46 PM   #4
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,179
Open circuit means that your temperature sensor in the grill is disconnected.
__________________
~Aaron

narnwv is offline   Reply With Quote
Unread 06-12-2013, 04:59 PM   #5
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego, California
Posts: 713
huh, well see there ya have it. most likely the sensor is failing then, decided it wanted to keep working for a bit haha
__________________
2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline   Reply With Quote
Unread 06-12-2013, 06:53 PM   #6
wheelhead
Member
 
wheelhead's Avatar
1999 XJ Cherokee 
 
Join Date: May 2012
Location: Nashua, NH
Posts: 112
Quote:
Originally Posted by narnwv View Post
Open circuit means that your temperature sensor in the grill is disconnected.
Ok thanks it must have gotten wet with all the rain the last few days. It's reading fine now.
__________________
1999 Cherokee
D30 HP front "open"
Chrysler 8.25 rear "open"
Its a work in progress
wheelhead is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.