Not blend doors - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Not blend doors

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 06-02-2014, 09:57 PM   #1
NVJEEPWJ
Registered User
2002 WJ 
 
Join Date: May 2014
Location: Spring Creek, Nevada
Posts: 11
Not blend doors

Ok so it's not my blend doors. Everything I have read says the temp will be different on the two side of the vehicle. Well mine will only blow air thru the defroster or the floor vents. I turned it to ac on my drive home (3 miles) to blow on my face. It just blows thru the defroster randomly switching off to blow by my feet generally when accelerating.
Cruise control works so not a vacuum leak.

NVJEEPWJ is offline   Reply With Quote
Unread 06-03-2014, 08:54 AM   #2
NVJEEPWJ
Registered User
2002 WJ 
 
Join Date: May 2014
Location: Spring Creek, Nevada
Posts: 11
anyone have any ideas?
NVJEEPWJ is offline   Reply With Quote
Unread 06-03-2014, 09:16 AM   #3
jeepfvr
Registered User
 
Join Date: Feb 2009
Posts: 70
Following. Have similar issue. I replaced my blend doors but I cannot get heat at the floor, heat will come out at the vent and heat will come out at the defrost
jeepfvr is offline   Reply With Quote
Unread 06-06-2014, 04:49 PM   #4
Shaggs2Dope
Registered User
1999 WJ 
 
Join Date: Sep 2012
Location: Toledo, Ohio
Posts: 583
I think there's a vacuum line that can cause this but I'm not sure. Check to see if you have any broken lines.
__________________
juggalo
Shaggs2Dope is offline   Reply With Quote
Unread 06-06-2014, 09:40 PM   #5
jspidle
Junior Member
2003 WJ 
 
Join Date: Mar 2014
Location: montgomery, IL
Posts: 43
in my Limited with AZC there are powered 'MODE' doors that do the deflection of air to the appropriate selection, floor, vent, defrost etc. I can see them if I look through the center dash vents.

jeff
__________________
'03 WJ Limited, 4.7, NP247, QD, power everything
jspidle is offline   Reply With Quote
Unread 06-06-2014, 10:13 PM   #6
NVJEEPWJ
Registered User
2002 WJ 
 
Join Date: May 2014
Location: Spring Creek, Nevada
Posts: 11
I will look but i dont have AZC
NVJEEPWJ is offline   Reply With Quote
Unread 06-07-2014, 04:29 PM   #7
Trav1s
Registered User
2004 WJ 
 
Join Date: May 2012
Location: Cedar Rapids, IA
Posts: 235
Two thoughts:

1)What model do you have? If you have a Laredo, Special Edition, Columbia, Rocky Mountain, or Freedom Edition you have the single zone climate control. It sounds like the recirc door is broken. Try searching for recirc door and see what you find. The recirc doors from that time were notorious for breaking.

2) Vacuum leak - I have a vacuum leak on my WJ and the cruise works fine but the climate control will shift to defrost under load. Likely a check valve that I have not hunted down and replaced.
__________________
2004 WJ Columbia Edition - Stone White/4.7 HO/QT II/Moog ssd107 SS/Bilstein socks/Factory Tow Hooks/Mopar RB4/Moabs with Cooper Discoverer AT3's/PML Trans pan/Mopar hitch
Trav1s is offline   Reply With Quote
Unread 06-07-2014, 06:30 PM   #8
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,071
Definitely vacuum leak. Check the lines from throttle body to the vacuum reservoir that is under the battery, behind the passenger headlight.

Sent from my iPad using Electrons
rdkendrick is offline   Reply With Quote
Unread 06-08-2014, 02:43 AM   #9
ncflyer06
Registered User
2004 WJ 
 
Join Date: May 2014
Location: Everett, WA
Posts: 9
Had the same issue, turned out to be a cracked vacuum line under the battery tray. It was the short tube that went from the plunger to a tee, only about 5 inches long. However, look along the whole run of lines that feed from there to the rear of the engine, leading to the intake manifold. It did affect my cruise, once i got the line replaced, air out of all vents and a working cruise control
ncflyer06 is offline   Reply With Quote
Unread 06-09-2014, 09:49 PM   #10
NVJEEPWJ
Registered User
2002 WJ 
 
Join Date: May 2014
Location: Spring Creek, Nevada
Posts: 11
2002 Laredo single zone sorry i screwed up not adding that part. ok looks like vacum leak first then recirc doors is the way to go. i have a couple days off coming up finally so i will let you know what i find.
NVJEEPWJ is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.