No speedo or tach after brake job? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > No speedo or tach after brake job?

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4wG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ Ch

Reply
Unread 03-16-2010, 03:10 PM   #1
PsyJeep
Registered User
1999 WJ 
 
Join Date: Mar 2010
Location: Southern Maine
Posts: 4
No speedo or tach after brake job?

Hey guys I did a front brake job with my buddys the other day on my 99' JGC Limited with a 4.7 in it. We finished up and I fired it up and I have no speedo or tach. No sensors were bumped that im aware of.

Any idea what this could be?

PsyJeep is offline   Reply With Quote Quick reply to this message
Unread 03-17-2010, 10:31 AM   #2
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,794
well the tach is odd but the speedo gets info from the abs computer.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote Quick reply to this message
Unread 03-17-2010, 01:13 PM   #3
TrevorJeepin
Registered User
1997 ZJ 
 
Join Date: Mar 2010
Location: Brighton,Michigan
Posts: 94
you damaged abs senosrs check the wire
TrevorJeepin is offline   Reply With Quote Quick reply to this message
Unread 03-22-2010, 11:41 AM   #4
PsyJeep
Registered User
1999 WJ 
 
Join Date: Mar 2010
Location: Southern Maine
Posts: 4
Where is the wire located?
__________________
1999 WJ Limited 4.7 Quadradrive
A few goodies
PsyJeep is offline   Reply With Quote Quick reply to this message
Unread 03-22-2010, 02:26 PM   #5
TrevorJeepin
Registered User
1997 ZJ 
 
Join Date: Mar 2010
Location: Brighton,Michigan
Posts: 94
its located on the back of the front steering knuckle next to the hub assembly bolts. the wire runs under the upper ball joints then attaches to the frame where the brake lines attach check this stretch of cable for nics cuts and what ever else you might see on both sides of the jeep
TrevorJeepin is offline   Reply With Quote Quick reply to this message
Unread 03-22-2010, 02:28 PM   #6
TrevorJeepin
Registered User
1997 ZJ 
 
Join Date: Mar 2010
Location: Brighton,Michigan
Posts: 94
also try resetting your computer (take the negative off the battery for 15 minutes)
TrevorJeepin is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.