No RPMs while driving. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > No RPMs while driving.

~Artec JK 1 TON SWAP~Engo winches available at www.rockridge4wd.com! Free shippMagnaflow SS Cat Back Exhaust System, Street, High Clearan

Reply
Unread 05-21-2013, 07:22 PM   #1
madslynge87
Registered User
2000 WJ 
 
Join Date: Mar 2010
Location: Nuuk
Posts: 160
Wj No RPMs while driving.

Hi guys.

First of all, WJ, 2000, Limited, 4,7, 122000 miles.

A strange problem accured to me today.

I was out driving, and i came to a stop, where i shut the engine off. It was turned off for about 1 hour. When i wanted to start it again nothing happned. The gauge light went on, but thats it. Klik klik klik. I jump started it and it died right away again. Tried again and this time i aplied the gas and i could keep the engine running. Kept it like that for a little while, and barely got it into gear and started driving. What i then noticed was that the engine was running fine, put i had no RPM readings what so ever. I drove it for 1 hour, and it felt just fine, maybe a little sputter from the exhaust but nothing unusual.

What could this be ?? A sensor of some kind. Any advice or sugestions will be highly appreciated !

Thanks !

madslynge87 is offline   Reply With Quote
Unread 05-22-2013, 01:06 AM   #2
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor, West Sussex. England. Great Britain
Posts: 2,947
Dead or dying battery almost guaranteed. But could be bad battery terminal connections. Clean them and tighten them up good and tight. Very common problem ....if you search you will find lots of similar posts and it usually turns out to be one or the other.
__________________
Before you judge a man, walk a mile in his shoes; after that, who cares?! He's a mile away and you've got his shoes!
alfaitalia is offline   Reply With Quote
Unread 05-22-2013, 04:49 AM   #3
madslynge87
Registered User
2000 WJ 
 
Join Date: Mar 2010
Location: Nuuk
Posts: 160
My logic sense just told me, that it was something else then the batteries or the terminals. But i see your point, and that might be the most straight forward place to start. Atleast with the terminals
madslynge87 is offline   Reply With Quote
Unread 05-22-2013, 04:49 AM   #4
madslynge87
Registered User
2000 WJ 
 
Join Date: Mar 2010
Location: Nuuk
Posts: 160
+ it started up just fine, after sitting over night.... Still no RPM readings.
madslynge87 is offline   Reply With Quote
Unread 05-22-2013, 04:59 AM   #5
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,385
Bad conection somewhere,,,
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote
Unread 05-22-2013, 10:46 AM   #6
madslynge87
Registered User
2000 WJ 
 
Join Date: Mar 2010
Location: Nuuk
Posts: 160
Think i found the problem. The RPM needle is on the wrong side of the little pin that holds it.. What the hell... How did that happen ! :-P
madslynge87 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.