no defrost - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 09-29-2010, 01:21 PM Thread Starter
1999_GC
Registered User
1999 WJ 
 
Join Date: Mar 2006
Location: Massachusetts
Posts: 9
Wj no defrost

I have a 1999 Grand Cherokee Laredo with the 4.7 V8. When I put the defrost on, air only comes out of the vents near the floor. All of the other vents work fine. Has anyone else seen this problem? Does anyone have any suggestions on how to fix this? Winter is coming and I need the defroster.

Thanks.

1999_GC is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-01-2010, 07:56 AM Thread Starter
1999_GC
Registered User
1999 WJ 
 
Join Date: Mar 2006
Location: Massachusetts
Posts: 9
No one has ever had this problem? Anyone??? Come on guys.... help me out here.
1999_GC is offline  
post #3 of 7 Old 10-01-2010, 12:21 PM
seu83
Registered User
2002 WJ 
 
Join Date: Sep 2010
Location: Erie
Posts: 322
Not sure if this is similar or if will even help but my friend has an xj with what sounds like the same issue. He has no defrost but the other vents work fine. But if he's going down the road and punches it enough to where it down shifts and he's running at a higher rpm the defrost kicks right on. Turns out it was a vacume leak.
seu83 is offline  
post #4 of 7 Old 10-01-2010, 01:21 PM
Blue04WJ
Registered User
2004 WJ 
 
Join Date: Jul 2010
Location: NoVA
Posts: 233
check the vacuum hoses. Also the servo under the battery. there's quite bit of info on here about that problem is ya search.
Blue04WJ is offline  
post #5 of 7 Old 10-04-2010, 05:04 PM Thread Starter
1999_GC
Registered User
1999 WJ 
 
Join Date: Mar 2006
Location: Massachusetts
Posts: 9
The attached diagram shows the vacuum for the manual a/c controls. If I am reading this right, the defrost mode is normally open The other vents work properly,

I checked the vacuum readings at the controls and had a vacuum reading of 8 Hg at every setting which leads me to believe I do not have a vacuum issue.

Could the actuator be jammed?
Attached Thumbnails
defrost vacuum.jpg  
1999_GC is offline  
post #6 of 7 Old 10-04-2010, 07:47 PM
kadetklapp
Registered User
1997 XJ Cherokee 
 
Join Date: May 2008
Location: Indiana
Posts: 1,355
You say only the floor vents work and then you say all the other vents work fine. Which is it? If it will not "switch" from floor to another setting (ie defrost, panel, etc) then it's likely to be a disconnected vacuum line. Easy fix. Check the intake for disconnected lines. Mine did this last winter. Cruise control wouldn't work either.

**1997 Jeep Cherokee SE**
Former Police Car assigned to 54-26, RIP.
kadetklapp is offline  
post #7 of 7 Old 10-08-2010, 11:18 AM Thread Starter
1999_GC
Registered User
1999 WJ 
 
Join Date: Mar 2006
Location: Massachusetts
Posts: 9
Well I solved the problem. The actuator for the defrost door was broken. Here is a photo of the new part that I got from a junk yard today. Pretty easy fix.
Attached Thumbnails
Jeep actuator.JPG  
1999_GC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
HVAC: a/c works only on defrost JeeplessInGB WJ Grand Cherokee Forum 6 07-24-2011 01:53 PM
AC/Heat/Defrost Issues Sintini WJ Grand Cherokee Forum 3 09-16-2010 11:44 PM
no air in defrost modes jeep n00b WJ Grand Cherokee Forum 1 09-16-2010 01:10 PM
Air Conditioning only works on defrost mode... Lsportline43 WJ Grand Cherokee Forum 6 08-08-2007 07:23 PM
AC blowing out defrost only??? 10achik WJ Grand Cherokee Forum 2 05-27-2004 03:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome