New GC owner with question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > New GC owner with question

Coil Spring Options from Ruffstuff!Flush Mount LED Bumper Lights, CREEThe Original 3/8" Ruffstuff Diff Cover!

Reply
Unread 04-26-2013, 08:09 PM   #1
jreask
Registered User
2004 WJ 
 
Join Date: Apr 2013
Location: saint mary, mo
Posts: 4
New GC owner with question

I just purchased a used 2004 GC Laredo with 127K. It's in decent shape and seems to run good. It has the 4.0 with auto tranny. I have a couple of questions that a search did not find an answer. First, the tachometer shows an idle of 750 RPMs after warm. It seems higher but I will trust it. When I put it in gear, the tach does not drop at all. All other vehicles I have owned the tach drops when I put the truck in gear. Can anyone explain this?

Also, when I pull in the garage after driving home, I hear a loud vibration and roaring sound from the front of the truck. I can't hear it outside the truck, only in the cabin. It almost sounds like the blower is on high speed but the HVAC is off. If anyone could help?

TIA

JR

jreask is offline   Reply With Quote Quick reply to this message
Unread 04-26-2013, 09:20 PM   #2
lazyWJ
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: halifax, ns
Posts: 813
My 02/4.7 has no perceptible change in rpm going in and out of gear, but I never gave it much thought. I assume this is just something that jeep managed to get right when they built these things. No idea on the noise though, is it your rad fan?
__________________
1993 FZR600RR
2002 Subaru WRX Sedan WRB (314k miles and counting)
2002 GC Overland (90k miles and fingers crossed)
"Bought, Not Built"
lazyWJ is offline   Reply With Quote Quick reply to this message
Unread 04-26-2013, 09:49 PM   #3
lvngtheJEEPlife
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Plainfield, Illinois
Posts: 948
It may be idling a little high, mine idles at 600, 4.7 non HO. If you suspect high idle clean the TB and IAC, may need to replace IAC. cheap and easy.
__________________
2001 WJ Limited 4.7 Powertech, Quadradrive, 2" BDS lift.
"If you can't get there in a Jeep, You should reconsider going there."
lvngtheJEEPlife is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.