New GC owner with question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > New GC owner with question

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitClayton Off Road - Come see us at these events!

Reply
Unread 04-26-2013, 07:09 PM   #1
jreask
Registered User
2004 WJ 
 
Join Date: Apr 2013
Location: saint mary, mo
Posts: 4
New GC owner with question

I just purchased a used 2004 GC Laredo with 127K. It's in decent shape and seems to run good. It has the 4.0 with auto tranny. I have a couple of questions that a search did not find an answer. First, the tachometer shows an idle of 750 RPMs after warm. It seems higher but I will trust it. When I put it in gear, the tach does not drop at all. All other vehicles I have owned the tach drops when I put the truck in gear. Can anyone explain this?

Also, when I pull in the garage after driving home, I hear a loud vibration and roaring sound from the front of the truck. I can't hear it outside the truck, only in the cabin. It almost sounds like the blower is on high speed but the HVAC is off. If anyone could help?

TIA

JR

jreask is offline   Reply With Quote
Unread 04-26-2013, 08:20 PM   #2
lazyWJ
Registered User
2002 WJ 
 
Join Date: Feb 2013
Location: halifax, ns
Posts: 813
My 02/4.7 has no perceptible change in rpm going in and out of gear, but I never gave it much thought. I assume this is just something that jeep managed to get right when they built these things. No idea on the noise though, is it your rad fan?
__________________
1993 FZR600RR
2002 Subaru WRX Sedan WRB (314k miles and counting)
2002 GC Overland (90k miles and fingers crossed)
"Bought, Not Built"
lazyWJ is offline   Reply With Quote
Unread 04-26-2013, 08:49 PM   #3
lvngtheJEEPlife
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Plainfield, Illinois
Posts: 928
It may be idling a little high, mine idles at 600, 4.7 non HO. If you suspect high idle clean the TB and IAC, may need to replace IAC. cheap and easy.
__________________
2001 WJ Limited 4.7 Powertech, Quadradrive, 2" BDS lift.
"If you can't get there in a Jeep, You should reconsider going there."
lvngtheJEEPlife is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.