New Engine- Sluggish Starting- Emission Codes and More - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > New Engine- Sluggish Starting- Emission Codes and More

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 01-18-2014, 01:52 PM   #16
casauall002
Registered User
 
Join Date: May 2010
Location: MO
Posts: 80
Quote:
Originally Posted by MadderThanMax View Post
I'd make sure all your earths are cleaned and tight, things like starter earth, block earth and of course the battery terminals..I've had this on another car whereby the earth cable had rusted through and was only connected by a thread.. it resulted in heat on the cable but would also cause the car to be a sluggish starter, just saying seeing as the Jeep is so temperamental...
I had AAA come out and they checked everything. Battery cranking, starter, alternator, etc...and was fine.

casauall002 is offline   Reply With Quote
Unread 01-18-2014, 02:03 PM   #17
MadderThanMax
Registered User
2001  
 
Join Date: Oct 2011
Location: Glasgow, Scotland
Posts: 1,654
Not being funny, its up to you.. but check and double check as they are often overlooked.. again I had this on another vehicle...the starter wires are a strong contender to be slack/loose...but its up to you..
MadderThanMax is offline   Reply With Quote
Unread 01-18-2014, 02:07 PM   #18
casauall002
Registered User
 
Join Date: May 2010
Location: MO
Posts: 80
Quote:
Originally Posted by MadderThanMax View Post
Not being funny, its up to you.. but check and double check as they are often overlooked.. again I had this on another vehicle...the starter wires are a strong contender to be slack/loose...but its up to you..
No, I understand and will triple check. I have double checked those items and I'm trying to go through eliminating items that are cheap to fix. I'm going to get under there and look some more for cracked lines since the jeep sat for so long before getting the new engine.
casauall002 is offline   Reply With Quote
Unread 01-28-2014, 07:31 PM   #19
casauall002
Registered User
 
Join Date: May 2010
Location: MO
Posts: 80
ugh...I was HOPING it was simply the purge valve and that it was also what was throwing the codes. We took the purge valve off and tried blowing through it. I was hoping I could meaning it was stuck open but no. So, I've looked around a bit and found a bit of dry rotting which may or may not be the reason for the codes but to be honest, I'm more concerned with the sluggish starting. Any thoughts where to go from here on the sluggish starting???
casauall002 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.