Need Trans help please!!! - Page 2 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #16 of 26 Old 05-23-2011, 08:11 PM
sixmikey9
Registered User
2003 WJ 
 
Join Date: Jan 2011
Location: Lafayette
Posts: 73
I'm having about the same exact problem with my 42re. I also did the governor sensor and solenoid replacing and band adjusting. Nothing seems to work. I really don't want to pull the transmission. I'll post back here if I come up with something.

Sent from my HTC Evo 4g using the JeepForum ap.

sixmikey9 is offline  
Sponsored Links
Advertisement
 
post #17 of 26 Old 05-24-2011, 09:35 AM
DICESARE
Registered User
1999 WJ 
 
Join Date: May 2011
Location: PHILADELPHIA
Posts: 35
I saw on ebay there was a kit of all the sensors and solenoid, I think it was four. I'm going to buy them and throw them in and see what it will do... I guess this is my last step before I am forced to put it in the show and get rebuilt... :-(
DICESARE is offline  
post #18 of 26 Old 05-24-2011, 08:42 PM
CarlJH
Registered User
2003 WJ 
 
Join Date: Feb 2010
Location: United Kingdom
Posts: 577
Have looked at the haynes book and it says there is a throttle cable going to the transmission from the throttle body on the engine that syncs the two so one doesn't lag behind the other it is adjusted at the engine end if yours has this see if there's any slack in the cables
CarlJH is offline  
 
post #19 of 26 Old 06-01-2011, 07:51 AM
DICESARE
Registered User
1999 WJ 
 
Join Date: May 2011
Location: PHILADELPHIA
Posts: 35
I checked the cable and it was perfect no play at all... I am just going to change all 4 sensors new wik filter (since I have the 42re or rh there is only the one filter right?) and attempt to adjust the bands. Can anyone give advise on adjusting the bands. I have never had to do it before and the Haynes book says tighten to 72 in-lbs then back off 3 5/8th turn... I know what it's saying but is it correct?
DICESARE is offline  
post #20 of 26 Old 06-01-2011, 10:26 AM Thread Starter
RyanMcholan
Registered User
1998 ZJ 
 
Join Date: Apr 2011
Location: Cochran
Posts: 31
Ok fellas, I just found out after chagning all sensors, adj bands, and making sure kick down cable is adj right. Then if the tranny is still acting up then you need a new transmission. These can't even be rebuilt, SO I'V BEEN TOLD. Once the case gets too much whear it will not hold fluid pressure, which in turn will cause the trans to stick in gear and not shift. Like i said, i was told this by a local transmission shop. The case is alumnium and after so many miles something in the case wears down which in turn causing loss of internal fluid pressure. This sucks!!
RyanMcholan is offline  
post #21 of 26 Old 06-01-2011, 10:31 AM
Thomahawk
Registered User
2006 XK Commander 
 
Join Date: Mar 2011
Location: Oslo
Posts: 8,131
Quote:
Originally Posted by RyanMcholan
Ok fellas, I just found out after chagning all sensors, adj bands, and making sure kick down cable is adj right. Then if the tranny is still acting up then you need a new transmission. These can't even be rebuilt, SO I'V BEEN TOLD. Once the case gets too much whear it will not hold fluid pressure, which in turn will cause the trans to stick in gear and not shift. Like i said, i was told this by a local transmission shop. The case is alumnium and after so many miles something in the case wears down which in turn causing loss of internal fluid pressure. This sucks!!
Sorry to hear That. How many miles?

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline  
post #22 of 26 Old 06-02-2011, 12:16 PM Thread Starter
RyanMcholan
Registered User
1998 ZJ 
 
Join Date: Apr 2011
Location: Cochran
Posts: 31
This on has 152K on it. guess thats not bad for an automatic. Although i'v got a friend who has a 97 ZJ with 324K still pulling.
RyanMcholan is offline  
post #23 of 26 Old 06-02-2011, 12:28 PM
Coolhand20th
Registered User
1999 WJ 
 
Join Date: Apr 2011
Location: Coleman
Posts: 410
umm which trans is it again? If it's a 42RE it can easily be rebuilt.
Coolhand20th is offline  
post #24 of 26 Old 06-03-2011, 01:07 AM
DICESARE
Registered User
1999 WJ 
 
Join Date: May 2011
Location: PHILADELPHIA
Posts: 35
Quote:
Originally Posted by RyanMcholan
This on has 152K on it. guess thats not bad for an automatic. Although i'v got a friend who has a 97 ZJ with 324K still pulling.
I have a ZJ sitting out back with roughly 250k original trans and shifts perfect. I just got the WJ 2 months ago with 133k and its acting stupid. Go figure...
DICESARE is offline  
post #25 of 26 Old 03-20-2012, 10:41 AM
NOLAwj
Registered User
2000 WJ 
 
Join Date: Mar 2012
Location: New Orleans
Posts: 1
Wj Same problem

I am having the same problem with my wj 42re, I keep hearing about these bands that need to be adjusted. Have you done it and did it work?
NOLAwj is offline  
post #26 of 26 Old 03-20-2012, 12:58 PM
jeepster250
Registered User
1999 WJ 
 
Join Date: Feb 2012
Location: charlotte
Posts: 503
TSB for 99 to 04 shifting problem rough or hard shift between 2 to 3 or 3 to 4 or 4 to 3.
jeepster250 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Trans fluid? Thomahawk WJ Grand Cherokee Forum 26 04-18-2011 04:34 PM
New WJ. Trans issues? HELP! surfTJsnow WJ Grand Cherokee Forum 5 11-23-2010 08:02 PM
wj trans cooler TheBoss WJ Grand Cherokee Forum 14 07-16-2010 09:45 AM
WJ trans problems rugermack WJ Grand Cherokee Forum 4 06-14-2010 12:50 PM
01 WJ Trans not shifting compcrasher86 WJ Grand Cherokee Forum 10 06-11-2010 07:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome