my wj 4.0 litre will not rev past 3500rpm HELP !! - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 19 Old 08-19-2013, 06:47 AM Thread Starter
muirtons1
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: blairgowrie
Posts: 12
when i got the car there was an engine check light on which was cleared by the garage and it hasn,t come back on since , it was an o2 sensor , replaced and no issues till now , there was at the time a stored code which was a coil pack , it has never surfaced since and the gargae assures me there is no codes being thrown up and the engine light has not been on for over 40000 miles ,nor is it now , i kinda wish it was , pressure test tommorow though

muirtons1 is offline  
Sponsored Links
Advertisement
 
post #17 of 19 Old 08-20-2013, 09:53 AM Thread Starter
muirtons1
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: blairgowrie
Posts: 12
Wj

Hi, all , the fuel pump is shot , the garage tracked it down and it has been replaced, all good , thanks a lot and the help i got was tremendous , i have replaced the sensors that would have been needed shortly and have ordered a new cat , this baby should last another 5-10 years easy, i am fitting a nudge bar anyone any ides on spotlamps , it has fitments for two so i am looking for a decent pair , make and stockist , brilliant forum!!!!
muirtons1 is offline  
post #18 of 19 Old 08-21-2013, 04:41 PM
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,807
Glad you got it figured out. Fuel pressure problems are hard to track down sometimes. As for lights, I just put a pair of KC Daylighters on my JKU and used them last night. All I can say is awesome lights.

Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline  
post #19 of 19 Old 08-24-2013, 04:06 PM Thread Starter
muirtons1
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: blairgowrie
Posts: 12
Yes it was hard to track down but thanks to all who helped me on the way to sorting it out ,I have taken all the advice on board and have taken preventative action to eliminate any future problems including an inexpensive cat from eBay which had good reviews , the truck now smooth as it should be and I have ordered the spots as recommended ,anyone coming to Scotland feel free to let me know and as I am freshly divorced therfore I have plenty time to show anyone round haha ,thanks again ,appreciated
muirtons1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome