melted o2 sensor connectors - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > melted o2 sensor connectors

The RuffStuff "I can't go to EJS" Sale!Offset Tie Rod Kit From RuffStuff!Check out our NEW Steering Stuff!

Reply
Unread 06-25-2013, 06:12 PM   #1
coopdc78
Registered User
2004 WJ 
 
Join Date: Sep 2008
Location: Buffalo
Posts: 586
melted o2 sensor connectors

I just noticed my pass side o2 sensors are melted pretty good. And I drove through a pretty big puddle last week and it started running crappy but no code. Would this cause my car to run like this even without a code comming up? Seems to be running rich and going through more fuel and a little bit of back fire when I just touch the gas in neutral.. It used to kind of backfire when I gave it a lot of gas but I expect that cause I have a aftermarket muffler

__________________
1995 ZJ, limited, 5.2, 242 t-case.3in skyjacket..2inbb.. sold
2000 camaro ss/slp in garage
2004 overland stock
How I do anything is how I do everything
coopdc78 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.