Map sensor bad, but lights flickered? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 1 Old 08-07-2011, 11:29 AM Thread Starter
circa27
Registered User
2000 WJ 
 
Join Date: Jun 2011
Location: edmonton
Posts: 52
Wj Map sensor bad, but lights flickered?

So the other day my jeep just instantly started acting strange while I was driving, acceleration was delaying, black smoke from the exhaust.. I knew it couldnt be spark plugs or anything so being that there is no MAF sensor in the 4.0 I changed the MAP sensor and all was good again.

I just dont get why would the lights have flickered because of that? I mean headlights, the interior and deck and everything was fine. It was at low RPM, but the battery is in top shape so does anyone know how that could have happened? Just curious

circa27 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Transmission Input Shaft Speed Sensor, Output Shaft Speed Sensor CaRJoE0220 WJ Grand Cherokee Forum 12 10-29-2014 05:47 PM
99 laredo no tail lights or brake lights, suggestions? sonic13slayer WJ Grand Cherokee Forum 4 03-12-2011 12:46 PM
Replaced the Gov Sensor & Solenoid...lights gone not the problem crflugga WJ Grand Cherokee Forum 9 02-07-2011 09:09 PM
Transmission selector lights flickered off, no drive Steve_Block WJ Grand Cherokee Forum 1 10-27-2010 08:05 PM
Need HELP!!! with head lights,Fog lights and tail lights JVL19 WJ Grand Cherokee Forum 9 08-16-2010 09:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome