Map sensor bad, but lights flickered? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Map sensor bad, but lights flickered?

15 x 8 Black D-Window Steel Wheels Set of 4Magnaflow SS Cat Back Exhaust System, Street, High ClearanRCV Heavy Duty Axle Shafts Now Shipping at Baseline4x4.com

Reply
Unread 08-07-2011, 11:29 AM   #1
circa27
Registered User
2000 WJ 
 
Join Date: Jun 2011
Location: edmonton, alberta
Posts: 52
Wj Map sensor bad, but lights flickered?

So the other day my jeep just instantly started acting strange while I was driving, acceleration was delaying, black smoke from the exhaust.. I knew it couldnt be spark plugs or anything so being that there is no MAF sensor in the 4.0 I changed the MAP sensor and all was good again.

I just dont get why would the lights have flickered because of that? I mean headlights, the interior and deck and everything was fine. It was at low RPM, but the battery is in top shape so does anyone know how that could have happened? Just curious

circa27 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.