Major Issues With 99 WJ Limited - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 34 Old 04-03-2013, 06:10 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
Wj Major Issues With 99 WJ Limited

Good morning everyone.

I need some major help! Im new to the forum to start and as of last night my WJ's cel came on. I stopped at advance auto parts this morning to have the pull the codes and was given ten different ones that all showed. The major issue I am having is my trans. Which started all of a sudden. The trans started acting funny two nights ago but didn't pitch the cel till last night when I started the car. it had a lack of power up to 1500 rpm and then would drive fine as long as I gave it little gas when starting to move from a dead stop. If I gave it a lot of gas to push past the 1500 rpm's it felt like it was neutral dropping. then this morning it continued to do that and added gear slipping. This is my only vehicle and need to buy the parts and fix it ASAP. Any help would be greatly appreciated.

The codes it pulled are as follows:

Trans:
P1793 Loss of Torque Management Signal
P1728 2-G Hydraulic Pressure Switch Circuit (pitching the code twice)
P1724 Line Pressure High
P1725 4-C Hydraulic Pressure Switch

ABS:
#2 Left front wheel speed signal malfunction
#4 right front wheel speed signal malfunction
#11 electronic control unit malfunction
#12 G-Switch malfunction

Unknown:
P1727 No DTC Found



Please Please Please help! lol

99WJLimited is offline  
Sponsored Links
Advertisement
 
post #2 of 34 Old 04-03-2013, 07:20 AM
alfaitalia
CRD Pilot!
 
alfaitalia's Avatar
2004 WJ 
 
Join Date: Feb 2011
Location: Bognor
Posts: 5,818
P1727 is hydraulic pressure switch circuit......if that helps at all!

Sent from my HTC Wildfire using JeepForum

If you can't fix it with a hammer, you've got yourself an electrical problem!
alfaitalia is online now  
post #3 of 34 Old 04-03-2013, 07:41 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
Quote:
Originally Posted by alfaitalia View Post
P1727 is hydraulic pressure switch circuit......if that helps at all!

Sent from my HTC Wildfire using JeepForum

Yes it does thank you! Now to figure out why it all went on the same day lol.

Last edited by 99WJLimited; 04-04-2013 at 09:33 AM.
99WJLimited is offline  
post #4 of 34 Old 04-03-2013, 07:49 AM
car5car
Registered User
2002 M-38 
 
Join Date: Apr 2007
Location: Florida
Posts: 735
I had bunch of ABS codes (3 of them like yours), replaced ABS module and only one was left, left rear sensor. I replaced it, no problem from ABS.
Your last 3 transmission codes are most likely from the same problem. I would connect oil pressure gauge (tool) to transmission and check pressure.

01 XJ 2wd 4.0
car5car is offline  
post #5 of 34 Old 04-04-2013, 08:29 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
So it's still running and seems to be fairly ok if I manually shift through the gears. I'm also wondering if the PCU could be throwing these codes and dummy codes due to it going bad itself. Any help with this would be greatly appreciated!
99WJLimited is offline  
post #6 of 34 Old 04-04-2013, 09:12 AM
drrm123
Registered User
1994 ZJ 
 
Join Date: Dec 2006
Location: Red Bluff, CA
Posts: 193
Sounds like the trans is going in limp mode, try shifting it from 1 to 2 manually. If ok that way you may need to replace trans line pressure sensor. Should be about $60 to $100 depending on where you buy from. Is it a v8 or 6 cylinder? Guessing a v8 since it's a limited and the codes you posted. 45RFE....................just saw your previous post about going through gears. Was working while typing this. There is a solenoid pack in trans also, but i'd try changing the 2 filters first. What does fluid condition look like?

2001 Jeep Grand Cherokee Laredo 6 cylinder Selectrac
$2400 installed new radiator 1 window regulator 2 oxygen sensors
drrm123 is offline  
post #7 of 34 Old 04-04-2013, 09:20 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
yes it is the 4.7 however manually going from first to second to drive does help it still is lacking power in first just not as bad if I start in D. It also has the Quadra-trac II
99WJLimited is offline  
post #8 of 34 Old 04-04-2013, 09:39 AM
Schlotzky
Registered User
2007 XK Commander 
 
Join Date: Aug 2012
Location: Auburn
Posts: 961
The 545RFE had a tsb on the external pressure switch and it's a common failure point. If you pick up the sensor, you should be able to swap it out in 10 minutes in a parking lot without jacking the rig up. The fact that you have so many transmission pressure codes makes me think it's at least one of the issues.
Schlotzky is offline  
post #9 of 34 Old 04-04-2013, 09:45 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
The confusing part is the WJ drove a little off but not of any concern for a night.When I started it the next night to go to work the CEL was on and it was running rough. After work I went straight to the auto parts store and had them pull the codes and all ten listed. It doesn't make sense to me that all ten would pitch at one time and include ABS codes also. By the way my ABS light on my dash is not on lol.

99 Grand Cherokee Limited 4.7 45RFE Quadra-Trac II Dana 30 Dana 35 Firestone Destination A/T 245/70R/16
“If I had no sense of humor, I would long ago have committed suicide.” ― Mahatma Gandhi

Last edited by 99WJLimited; 04-04-2013 at 09:46 AM. Reason: forgot to add info
99WJLimited is offline  
post #10 of 34 Old 04-04-2013, 09:52 AM
Schlotzky
Registered User
2007 XK Commander 
 
Join Date: Aug 2012
Location: Auburn
Posts: 961
Clean up your battery terminals and connectors really good and look around for broken wires. Take a look under the Jeep for a ground strap that goes from the transmission mount to the floorpan and to the exhaust pipe and make sure it's not broken. It's not a bad idea to reseat and clean up connectors in the engine bay, too.
Schlotzky is offline  
post #11 of 34 Old 04-04-2013, 09:58 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
I did get into some muddy water about a week or two ago and had a little fun and now this! I was romping on it kinda hard.


99 Grand Cherokee Limited 4.7 45RFE Quadra-Trac II Dana 30 Dana 35 Firestone Destination A/T 245/70R/16
“If I had no sense of humor, I would long ago have committed suicide.” ― Mahatma Gandhi
99WJLimited is offline  
post #12 of 34 Old 04-04-2013, 10:49 AM
shockracer
Registered User
2001 WJ 
 
Join Date: Oct 2010
Location: Northern
Posts: 1,639
Have you done a thorough cleaning on the undercarriage after that?

2001 WJ 60th anniversary edition 4.7 quadra-drive
5" hybrid lift, 265/70/17 Guard Dogs load E, bilsteins 5100's, addco sway bars, JKS front quick disco's, JKS adjustable track bar, KOR durometer track bar bushings, IRO crucial path front L.A.s, 1.25" Spidertrax spacers

Colorado Jeep Club Member #262
shockracer is offline  
post #13 of 34 Old 04-04-2013, 10:55 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
Quote:
Originally Posted by shockracer View Post
Have you done a thorough cleaning on the undercarriage after that?
I did spray it down after. There doesn't appear to be any build up or clumps on the under carriage but there is sill a small amount there. I also live of a dirt alley. Not sure if what I see under there is left over from that day or just from my alley since my last spray down.

I'm curious to see where your thoughts are going from this however.

99 Grand Cherokee Limited 4.7 45RFE Quadra-Trac II Dana 30 Dana 35 Firestone Destination A/T 245/70R/16
“If I had no sense of humor, I would long ago have committed suicide.” ― Mahatma Gandhi
99WJLimited is offline  
post #14 of 34 Old 04-04-2013, 10:56 AM Thread Starter
99WJLimited
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Saint Petersburg
Posts: 76
Could this be from a broken ground strap?

99 Grand Cherokee Limited 4.7 45RFE Quadra-Trac II Dana 30 Dana 35 Firestone Destination A/T 245/70R/16
“If I had no sense of humor, I would long ago have committed suicide.” ― Mahatma Gandhi
99WJLimited is offline  
post #15 of 34 Old 04-04-2013, 12:22 PM
shockracer
Registered User
2001 WJ 
 
Join Date: Oct 2010
Location: Northern
Posts: 1,639
Quote:
Originally Posted by 99WJLimited View Post
Could this be from a broken ground strap?
Highly possible.

2001 WJ 60th anniversary edition 4.7 quadra-drive
5" hybrid lift, 265/70/17 Guard Dogs load E, bilsteins 5100's, addco sway bars, JKS front quick disco's, JKS adjustable track bar, KOR durometer track bar bushings, IRO crucial path front L.A.s, 1.25" Spidertrax spacers

Colorado Jeep Club Member #262
shockracer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome