Left Turn Signal stopped working.... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Left Turn Signal stopped working....

ZONE 4.25" combo lift for TJ available at Rockridge4wJeep Wrangler Bushwacker Flat Fender Flare Sale at BaselinRIGID LED Light Blowout Sale - All Sizes, All Series, all

Reply
Unread 03-24-2011, 04:38 PM   #1
HondaPeople
Registered User
2001 WJ 
 
Join Date: Feb 2010
Location: , Utah
Posts: 238
Left Turn Signal stopped working....

I know there has been some resent write up's regarding the turn signals not working and such and I think I recall seeing something awhile back about this but haven't been able to find it. My hazard lights and right turn signal work just fine, but the left won't. The only way I can get the left one to work is if I briefly turn on the hazard lights--then it will work for a blink or two than stop.

Is the fix removing the combination relay and replacing it/re-soldering it? Or is this a problem in the turn signal stalk itself?

Thanks in advance!

__________________
2011 Dodge RAM 1500-HEMI, 2001 WJ Laredo-V8
2008 Honda Recon ES 4x4, 2006 Honda Lawn Mower, 2001 Honda VFR800
HondaPeople is offline   Reply With Quote Quick reply to this message
Unread 03-24-2011, 05:48 PM   #2
jemrey81
Registered User
 
Join Date: Nov 2010
Location: Roseville, CA
Posts: 351
http://www.jeepforum.com/forum/f310/...e-help-986447/
jemrey81 is offline   Reply With Quote Quick reply to this message
Unread 03-24-2011, 05:49 PM   #3
jemrey81
Registered User
 
Join Date: Nov 2010
Location: Roseville, CA
Posts: 351
forgot to mention.... you can either repair the relay or replace it....... that link gives you all the info.
jemrey81 is offline   Reply With Quote Quick reply to this message
Unread 03-24-2011, 05:58 PM   #4
HondaPeople
Registered User
2001 WJ 
 
Join Date: Feb 2010
Location: , Utah
Posts: 238
Thank you!!
__________________
2011 Dodge RAM 1500-HEMI, 2001 WJ Laredo-V8
2008 Honda Recon ES 4x4, 2006 Honda Lawn Mower, 2001 Honda VFR800
HondaPeople is offline   Reply With Quote Quick reply to this message
Unread 03-24-2011, 07:37 PM   #5
jemrey81
Registered User
 
Join Date: Nov 2010
Location: Roseville, CA
Posts: 351
happy to help
jemrey81 is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 08:54 PM   #6
HondaPeople
Registered User
2001 WJ 
 
Join Date: Feb 2010
Location: , Utah
Posts: 238
I have to be honest.... I took the thing apart and don't see ANY cracks in the solder. I even have a magnifying glass and don't see any. Where would the cracks be? Thanks in advanced!
__________________
2011 Dodge RAM 1500-HEMI, 2001 WJ Laredo-V8
2008 Honda Recon ES 4x4, 2006 Honda Lawn Mower, 2001 Honda VFR800
HondaPeople is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 09:01 PM   #7
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,223
it's along the straight row of contacts on the end. That's where the external contacts connect to the PCB. There's a picture on wjjeeps.com showing it, but I can't find it....
__________________
~Aaron

narnwv is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 09:47 PM   #8
HondaPeople
Registered User
2001 WJ 
 
Join Date: Feb 2010
Location: , Utah
Posts: 238
Thank you for your input narnwv. But I'm just not seeing it. I've included a picture of what I am looking at.
relay.jpg  
__________________
2011 Dodge RAM 1500-HEMI, 2001 WJ Laredo-V8
2008 Honda Recon ES 4x4, 2006 Honda Lawn Mower, 2001 Honda VFR800
HondaPeople is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 09:48 PM   #9
iluvtruenos
Registered User
2000 WJ 
 
Join Date: Dec 2006
Location: Chicago
Posts: 1,345
1996-2000 Dodge Grand Caravan/Plymouth/Chrysler uses the same part.

At my junkyard they either sell relays (any) at $0.99 apiece or free with a reasonable purchase. For me it was easier to just swap it out rather than trying to fix the damn thing.
__________________
My Jeep is a chick magnet with reverse polarity.

Rampant Pack of Retards group president.
2000 WJ, 4.5l, AX15, 242 D60/14b, 5.5" lift front, 7.5" rear. Ford Expedition rear coils, Ram 350 shocks, JKS, IRO Long Arms, cool Badlands flag thingy.
1987 XJ - Gone but not forgotten
iluvtruenos is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 09:50 PM   #10
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,223
Yes, the 9 pins straight across the top. Horrible picture, but I can setill see that the second one from the left has a "lighter, more porous" tint to it--betcha a dollar if that was heated with a $8 soldering iron from Radio Shack it'd be good as new.

Mine completely quit working and I had to do the left most 3.


There is a picture/write up on wjjeeps.com I swear.

You know what.....the FAQ!

http://www.jeepforum.com/forum/f310/...29/index5.html
__________________
~Aaron

narnwv is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 09:52 PM   #11
HondaPeople
Registered User
2001 WJ 
 
Join Date: Feb 2010
Location: , Utah
Posts: 238
Thank you narnwv. I appreciate your help and insight.
__________________
2011 Dodge RAM 1500-HEMI, 2001 WJ Laredo-V8
2008 Honda Recon ES 4x4, 2006 Honda Lawn Mower, 2001 Honda VFR800
HondaPeople is offline   Reply With Quote Quick reply to this message
Unread 03-26-2011, 09:54 PM   #12
narnwv
Moderator
 
narnwv's Avatar
2000 WJ 
 
Join Date: Sep 2009
Location: Cross Lanes, WV
Posts: 6,223
np.

I've done it to mine + 3 other people's WJs.
__________________
~Aaron

narnwv is offline   Reply With Quote Quick reply to this message
Unread 09-02-2012, 02:58 PM   #13
cbailey_21
Registered User
1999 WJ 
 
Join Date: Nov 2011
Location: carthage, illinois
Posts: 318
I just replaced the relay and my turn signals still won't work
__________________
[QUOTE=smuggler;13038059]Ah yes that is a common Jeep thing, weird noises after wheelin'. This is how you fix it. You have to go wheelin' again, but in reverse. Once you get done the clunk should be gone.[/QUOTE]

MODS: BDS 2" coils, Bilstein 5100 struts, 17"Moab takeoffs, 245/65/17 Hankook Dynapro ATMs, Addco 1" Rear Swaybar, Energy Suspension greasable swaybar bushings, westin tail light guards, Rancho HD Steering stabilizer, Freedom Edition running boards, Spyder Halo Foglights, Rola Vortex roof rack.
cbailey_21 is offline   Reply With Quote Quick reply to this message
Unread 09-02-2012, 09:46 PM   #14
AndyL
Registered User
2000 WJ 
 
Join Date: Nov 2011
Location: Running Springs, ca
Posts: 77
Quote:
Originally Posted by cbailey_21 View Post
I just replaced the relay and my turn signals still won't work
do your hazards work?

Sometimes i cycle the hazard switch and then the turn signals work or smacking the top of the dash on the left.
AndyL is offline   Reply With Quote Quick reply to this message
Unread 09-03-2012, 07:37 AM   #15
cbailey_21
Registered User
1999 WJ 
 
Join Date: Nov 2011
Location: carthage, illinois
Posts: 318
Yes my hazards work fine, I Ordered a new turn signal/ head light switch in hopes that it cures my problem
__________________
[QUOTE=smuggler;13038059]Ah yes that is a common Jeep thing, weird noises after wheelin'. This is how you fix it. You have to go wheelin' again, but in reverse. Once you get done the clunk should be gone.[/QUOTE]

MODS: BDS 2" coils, Bilstein 5100 struts, 17"Moab takeoffs, 245/65/17 Hankook Dynapro ATMs, Addco 1" Rear Swaybar, Energy Suspension greasable swaybar bushings, westin tail light guards, Rancho HD Steering stabilizer, Freedom Edition running boards, Spyder Halo Foglights, Rola Vortex roof rack.
cbailey_21 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.