Left turn signal not working on my 99 WJ - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Left turn signal not working on my 99 WJ

XJ Rail Sale!The Ruffstuff NOT Universal 4 Link Kit!Vanco Big Brake Kit Promotion!

Reply
Unread 03-30-2010, 07:00 PM   #1
jtsjeep99
Registered User
1999 WJ 
 
Join Date: Dec 2007
Location: Ohio
Posts: 372
Left turn signal not working on my 99 WJ

Went to use the left turn signal today while driving and it blinked 2 times then stopped. Each time I would turn it on for about 8 times it blinked twice and then stopped. Then it quite all together. The right side works fine and I can hear the relay clicking. When I turn on the flashers only the right side works and not the left. I have replaced all the bulbs front and rear on the left side and no luck. The brake and parking lights work fine, its just the left turn signal. Is it possible for a bad relay to only affect one side? Or do I have a wiring problem?

__________________
JTsJeep99
jtsjeep99 is offline   Reply With Quote Quick reply to this message
Unread 03-30-2010, 07:06 PM   #2
straty1987
Registered User
 
Join Date: Aug 2008
Posts: 2,522
take the bulb socket out and check the connection point in the housing and on the socket. might have to just scrap then a bit and lift up the tabs a bit in the housing for the turn signal bulb on the left side. worked for mine and a few other people i know only other thing might be a bad wire or bad housing
straty1987 is offline   Reply With Quote Quick reply to this message
Unread 03-30-2010, 08:08 PM   #3
jtsjeep99
Registered User
1999 WJ 
 
Join Date: Dec 2007
Location: Ohio
Posts: 372
I'll try that tomorrow.
__________________
JTsJeep99
jtsjeep99 is offline   Reply With Quote Quick reply to this message
Unread 03-30-2010, 09:32 PM   #4
jtsjeep99
Registered User
1999 WJ 
 
Join Date: Dec 2007
Location: Ohio
Posts: 372
Got bored and decided to swap out the relay from one WJ to the other. That was the problem. Thank God! I was dreading tracking down a bad wire. Now I have to order one from the stealership cause I hear that's the only place to get one.
__________________
JTsJeep99
jtsjeep99 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.