Kenwood radio not working - JeepForum.com

 
LinkBack Thread Tools
post #1 of 15 Old 02-05-2014, 05:38 PM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
Kenwood radio not working

After my dead battery ordeal my Kenwood radio stopped working. I know this really isn't Jeep related, but I thought I'd give it a shot. I pulled the radio out, checked wires even unplugged them and plugged them back I'm, replaced the fuse on the radio and nothing. I still have my stock radio so I plugged that in and it works fine.


-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 02-05-2014, 07:12 PM
Timbo24
Registered User
2000 WJ 
 
Join Date: Jul 2010
Location: Boise
Posts: 2,093
Try the fuse that actually powers the radio.
Timbo24 is offline  
post #3 of 15 Old 02-05-2014, 07:14 PM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
Quote:
Originally Posted by Timbo24
Try the fuse that actually powers the radio.
Why would my stock one work though?

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
post #4 of 15 Old 02-05-2014, 07:17 PM
Timbo24
Registered User
2000 WJ 
 
Join Date: Jul 2010
Location: Boise
Posts: 2,093
I'm not sure but check fuse #30.
Timbo24 is offline  
post #5 of 15 Old 02-05-2014, 07:41 PM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
I'm going to take it into my auto class so I can do it in the warmth tomorrow

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
post #6 of 15 Old 02-05-2014, 10:37 PM
braddf
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: clinton
Posts: 854
Shouldn't there be a fuse on the head unit itself? Not on the jeep, but on the head unit. Have you tried that one?

Build thread: http://bit.ly/1puFzZm
Stock rims for sale: http://bit.ly/1kMw7k5
braddf is offline  
post #7 of 15 Old 02-05-2014, 11:09 PM
Kalel
Registered User
2015 JK Wrangler 
 
Join Date: Jan 2014
Location: Acworth
Posts: 151
Does the Kenwood light up at all, and just not play? What model is it? Some had an anti theft feature that required a type of code be used to re-activate it.

2015 Jeep Wrangler Unlimited Rubicon
Kalel is offline  
post #8 of 15 Old 02-06-2014, 05:51 AM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
Quote:
Originally Posted by braddf
Shouldn't there be a fuse on the head unit itself? Not on the jeep, but on the head unit. Have you tried that one?
Yeah already tried changing that

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
post #9 of 15 Old 02-06-2014, 05:52 AM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
Quote:
Originally Posted by Kalel
Does the Kenwood light up at all, and just not play? What model is it? Some had an anti theft feature that required a type of code be used to re-activate it.
It is not even lighting up. I tried taking the faceplate off and on a few times also no luck

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
post #10 of 15 Old 02-06-2014, 08:09 AM
Kalel
Registered User
2015 JK Wrangler 
 
Join Date: Jan 2014
Location: Acworth
Posts: 151
Some have an internal fuse, if not then you might have shorted it out. Good luck and keep us updated just incase we run into the same problem.

2015 Jeep Wrangler Unlimited Rubicon
Kalel is offline  
post #11 of 15 Old 02-06-2014, 08:23 AM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
Will do, taking a look at it today in shop so we will see

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
post #12 of 15 Old 02-06-2014, 11:08 AM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
Still could not get it to work. Checked fuse #30, wasn't blown but I replaced it anyway still nothing. I think I shorted it when I jump started my car..

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
post #13 of 15 Old 02-06-2014, 12:57 PM
Timbo24
Registered User
2000 WJ 
 
Join Date: Jul 2010
Location: Boise
Posts: 2,093
Check all your wiring again.
Timbo24 is offline  
post #14 of 15 Old 02-06-2014, 01:19 PM
Thomahawk
Web Wheeler
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo
Posts: 8,055
Kenwood doesnt Work, they Are kitchen tools to me, lol

2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline  
post #15 of 15 Old 02-06-2014, 02:59 PM Thread Starter
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia
Posts: 358
All wiring is soldered, everything is connected

-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome