Kenwood radio not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Kenwood radio not working

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 02-05-2014, 04:38 PM   #1
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
Kenwood radio not working

After my dead battery ordeal my Kenwood radio stopped working. I know this really isn't Jeep related, but I thought I'd give it a shot. I pulled the radio out, checked wires even unplugged them and plugged them back I'm, replaced the fuse on the radio and nothing. I still have my stock radio so I plugged that in and it works fine.

__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-05-2014, 06:12 PM   #2
Timbo24
Registered User
2000 WJ 
 
Join Date: Jul 2010
Location: Boise, Idaho
Posts: 2,020
Try the fuse that actually powers the radio.
Timbo24 is offline   Reply With Quote
Unread 02-05-2014, 06:14 PM   #3
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
Quote:
Originally Posted by Timbo24
Try the fuse that actually powers the radio.
Why would my stock one work though?
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-05-2014, 06:17 PM   #4
Timbo24
Registered User
2000 WJ 
 
Join Date: Jul 2010
Location: Boise, Idaho
Posts: 2,020
I'm not sure but check fuse #30.
Timbo24 is offline   Reply With Quote
Unread 02-05-2014, 06:41 PM   #5
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
I'm going to take it into my auto class so I can do it in the warmth tomorrow
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-05-2014, 09:37 PM   #6
braddf
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: clinton, NC
Posts: 575
Shouldn't there be a fuse on the head unit itself? Not on the jeep, but on the head unit. Have you tried that one?
__________________
Lots of ideas, very little money build thread:
http://www.jeepforum.com/forum/f310/2001-laredo-build-braddf-1520783/
Leaking Coolant? Check this out:
http://www.jeepforum.com/forum/f310/disappearing-coolant-fix-thread-2103993/#post20305169
braddf is offline   Reply With Quote
Unread 02-05-2014, 10:09 PM   #7
Kalel
Registered User
2004 WJ 
 
Join Date: Jan 2014
Location: Acworth, Georgia
Posts: 104
Does the Kenwood light up at all, and just not play? What model is it? Some had an anti theft feature that required a type of code be used to re-activate it.
__________________
2004 Jeep Grand Cherokee Limited 4.7 QD, 2" lift, 245/75/16 Destiny Mts, 12,000lbs Badlands Winch, Cobra 29 LX CB
Kalel is offline   Reply With Quote
Unread 02-06-2014, 04:51 AM   #8
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
Quote:
Originally Posted by braddf
Shouldn't there be a fuse on the head unit itself? Not on the jeep, but on the head unit. Have you tried that one?
Yeah already tried changing that
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-06-2014, 04:52 AM   #9
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
Quote:
Originally Posted by Kalel
Does the Kenwood light up at all, and just not play? What model is it? Some had an anti theft feature that required a type of code be used to re-activate it.
It is not even lighting up. I tried taking the faceplate off and on a few times also no luck
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-06-2014, 07:09 AM   #10
Kalel
Registered User
2004 WJ 
 
Join Date: Jan 2014
Location: Acworth, Georgia
Posts: 104
Some have an internal fuse, if not then you might have shorted it out. Good luck and keep us updated just incase we run into the same problem.
__________________
2004 Jeep Grand Cherokee Limited 4.7 QD, 2" lift, 245/75/16 Destiny Mts, 12,000lbs Badlands Winch, Cobra 29 LX CB
Kalel is offline   Reply With Quote
Unread 02-06-2014, 07:23 AM   #11
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
Will do, taking a look at it today in shop so we will see
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-06-2014, 10:08 AM   #12
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
Still could not get it to work. Checked fuse #30, wasn't blown but I replaced it anyway still nothing. I think I shorted it when I jump started my car..
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote
Unread 02-06-2014, 11:57 AM   #13
Timbo24
Registered User
2000 WJ 
 
Join Date: Jul 2010
Location: Boise, Idaho
Posts: 2,020
Check all your wiring again.
Timbo24 is offline   Reply With Quote
Unread 02-06-2014, 12:19 PM   #14
Thomahawk
JEEP ADDICTED
 
Thomahawk's Avatar
2004 WJ 
 
Join Date: Mar 2011
Location: Oslo, Norway
Posts: 7,115
Kenwood doesnt Work, they Are kitchen tools to me, lol
__________________
2004 Grand Cherokee Overland 4.7 HO Quadradrive
95 ZJ Limited 5.2 Winter Project
Sold 94 ZJ Laredo 4.0 Winter Beater
R.I.P. 2000 Grand Cherokee Limited, 4.7 V8, Quadradrive, Shale Green Metallic, Agate/Carbon interior, Well modded and highly missed :(

Buildthread http://www.jeepforum.com/forum/f197/...grade-1813490/

MONEY WILL CONTINUE TO BE THROWN INTO THE RIG UNTIL CONDITION AND SATISFACTION IMPROVES!!!
Thomahawk is offline   Reply With Quote
Unread 02-06-2014, 01:59 PM   #15
bessyboy
Registered User
2001 WJ 
 
Join Date: Apr 2013
Location: livonia, mi
Posts: 217
All wiring is soldered, everything is connected
__________________
-2001 WJ Limited, 4.7L V8, Thrush Glasspack muffler dumped before axle(no tailpipe), Spectra CAI,
Rusty's 2" BB
bessyboy is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.