Jeep Starting Issues - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 12-15-2010, 02:17 PM Thread Starter
mrddye
Registered User
2003 WJ 
 
Join Date: Dec 2010
Location: Fort Worth
Posts: 1
Jeep Starting Issues

Gentleman. I have some issues getting the jeep to start.

When I turn the key to start the engine all I get is the clicking sound like the battery is dead.

So far I have:
Replaced the battery
Replaced the terminals
Had the alternator checked (its good)
Had the new battery checked (its good)

So I thought, ok starter, but here is where things get wierd. If I hook jumper cables up to it the thing fires right up? let it run for a while and try to start it on its own and its dead as hell. When i turn the key to the on position all the lights work, windows work, radio works, wipers go fast, everything is fine. Go to crank and its dead.

Please Help...

mrddye is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Issues with starting Sublme437 WJ Grand Cherokee Forum 0 10-01-2010 08:06 PM
Starting issues... ct290 WJ Grand Cherokee Forum 2 09-14-2010 04:39 PM
02 Wj starting and electrical issues Scjeepwj02 WJ Grand Cherokee Forum 4 08-25-2010 10:24 AM
WJ 4.7 AC Compressor/Clutch/Starting Issues ryanwj09 WJ Grand Cherokee Forum 0 04-08-2010 07:37 AM
still starting issues, tried everything, what did i miss?! paroxysym WJ Grand Cherokee Forum 1 03-24-2010 04:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome