Jeep sat for a week. Now it wont stay running. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Jeep sat for a week. Now it wont stay running.

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line~Artec JK 1 TON SWAP~Advance Adapters SYE Kits

Reply
Unread 08-24-2013, 06:48 PM   #1
Lil_Ape
Registered User
2002 WJ 
 
Join Date: May 2009
Location: Houston, TX
Posts: 213
Jeep sat for a week. Now it wont stay running.

It's an '02 with the 4.7. It sat for a week while i was doing suspension work to it. And i go to start it up just now and it will start up, then die immediately after. Wont even run for a second. Only way to keep it running was to stay on the gas, once you let off, it dies. And It sounded weak. All i did was replace all shocks, end links and steering stabilizer. I already tried both of my keys thinking the chip in one key was bad, that didn't help. I removed my tune, that also didn't help. So im stumped. It started and ran just fine a week ago when I parked it.

Ive got half a tank of gas. And the only thing i can really think of is some sensor went out. Or maybe the cam sensor is out. Had one replaced a few years ago when it was doing this same thing. Also i've had a dead battery and idk if when i tried starting it up with a dead battery, if it fried a sensor or what. Also, I had no cel or codes being thrown up. Any one have any ideas? Before i have a mechanic come out to look at it.

__________________
'02 WJ limited / 4.7L H.O. V8 / 2WD
Lil_Ape is offline   Reply With Quote Quick reply to this message
Unread 08-24-2013, 07:55 PM   #2
99SK04GTX
Registered User
2004 WJ 
 
Join Date: Jul 2009
Location: Hampton Roads
Posts: 487
Try another battery in it. They are real funny about having a full voltage battery, they might crank but not run right
99SK04GTX is offline   Reply With Quote Quick reply to this message
Unread 08-24-2013, 08:04 PM   #3
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,129
Yeah, sounds like the PCM is re-learning. I'd replace that battery. Once you do that, drive it around for 15-20 minutes and it should start running better, if not, you also have a different problem. Could need a TB cleaning, too.

Sent from my iPad using my fingers
rdkendrick is offline   Reply With Quote Quick reply to this message
Unread 08-24-2013, 08:25 PM   #4
Lil_Ape
Registered User
2002 WJ 
 
Join Date: May 2009
Location: Houston, TX
Posts: 213
I had cables hooked up from my tahoe. So It was getting enough juice to fire up. But i do have a new battery on one of my trucks i could use by itself. And as far as the tb goes. I put a new bbk tb on about a month ago. cleaned up all the sensors when i put it on. and spark plugs only have maybe 10k miles on them.
__________________
'02 WJ limited / 4.7L H.O. V8 / 2WD
Lil_Ape is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.