jeep grand cherokee stalling problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > jeep grand cherokee stalling problems

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 06-10-2013, 10:28 PM   #1
miguelmarkez
Registered User
1999  
 
Join Date: Jun 2013
Location: westmorland, california
Posts: 1
jeep grand cherokee stalling problems

wats up guys im new to the whole jeep community as ive only owned hondas. i needed a roomy car because well first im a big guy and i have two kids and my bbymomma so i bought a 99 Grand Cherokee 4.0 4x4 with around 133k miles about 3 months ago. i started having this problem about 2 weeks ago with my jeep where it sputtered on occasions then i would be at a stop and try to give it gas and it would sputtered and stall and then the check gauges light turns on and my oil gauge reads all the way down to 0. it starts right up and the all gauges indicate normal readings even the oil gauge ive been pretty frustrated ever since, i changed my spark plugs and my oil level is normal. ive been reading threads around the forum and read that it could be the oil pressure sensor, crank sensor? idk any suggestions?

miguelmarkez is offline   Reply With Quote Quick reply to this message
Unread 06-20-2013, 03:30 PM   #2
KFLECK
Registered User
1999 WJ 
 
Join Date: Jun 2013
Location: Auburn, Indiana
Posts: 8
I have the same problem man. I changed my 02 sensor. Figured that could be a problem since thats why my check engine light was on but it stalled once today
KFLECK is offline   Reply With Quote Quick reply to this message
Unread 06-20-2013, 04:44 PM   #3
99JGCWJ
Registered User
1999 WJ 
 
Join Date: Mar 2010
Location: Nassau County, New York
Posts: 369
The oil pressure would show zero after the car stalls because it's a live gauge and the engine isn't running. Maybe clogged fuel filter or possibly the fuel pump.
__________________
SIX IN A ROW MAKES IT GO!!!
99JGCWJ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.