Issue after IRO install - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Issue after IRO install

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 12-19-2013, 09:00 PM   #16
04WJSEV8
Registered User
 
Join Date: Oct 2013
Location: Clifton park, NY
Posts: 42
Today I was going to disconnect the front sway bar to see if the noise would go away. But I ended working 7 am to 10 pm so I didn't get to it. On my way home tonight there was not a single noise and I tried very hard to get it to do it. Lol. Tomorrow I'll try again to get the noise going and disconnect sway bar and see it goes away. If it does, screw the sway bar. Who needs them? Lol

04WJSEV8 is offline   Reply With Quote
Unread 12-19-2013, 09:49 PM   #17
Notabene
Registered User
2004 WJ 
 
Join Date: Mar 2013
Posts: 72
Mine always squeaks like hell the day after a big wheeling trip.
Notabene is offline   Reply With Quote
Unread 12-20-2013, 08:47 AM   #18
04WJSEV8
Registered User
 
Join Date: Oct 2013
Location: Clifton park, NY
Posts: 42
It started as soon as I touched the entrance to the first trail after the lift was install. Just dirt, no big bumps, no articulation. Nothin
04WJSEV8 is offline   Reply With Quote
Unread 12-22-2013, 07:17 AM   #19
04WJSEV8
Registered User
 
Join Date: Oct 2013
Location: Clifton park, NY
Posts: 42
Finally got a chance to get under the jeep this morning (32 degrees in lovely upstate NY), disconnected sway bar and so far no noises. Body roll is ridiculous so indefinitely going to need some new or longer (depending on research findings) end links. Maybe some quick disconnects
04WJSEV8 is offline   Reply With Quote
Unread 12-22-2013, 07:44 AM   #20
MuddyWJ
Registered User
2004 WJ 
 
Join Date: Feb 2012
Location: San Rafael, Ca
Posts: 2,120
Quote:
Originally Posted by 04WJSEV8 View Post
Finally got a chance to get under the jeep this morning (32 degrees in lovely upstate NY), disconnected sway bar and so far no noises. Body roll is ridiculous so indefinitely going to need some new or longer (depending on research findings) end links. Maybe some quick disconnects
FWIW I am running the stockers on 5" in the front due to indecision. Their definitely maxed but I don't get a single noise. Surprised no one has thought of shock bolts though. My IRO clunked like hell. Between the TB hitting my diff, CAs and shocks mounts. I tightened the heck out of all.
MuddyWJ is online now   Reply With Quote
Unread 12-22-2013, 11:20 AM   #21
04WJSEV8
Registered User
 
Join Date: Oct 2013
Location: Clifton park, NY
Posts: 42
Everything was tight. I've check it over and over again. The only thing questionable as far as that goes is the passenger shock. Not really any way to get anything in there to hold the shock stem. But disconnecting the sway bar, the noise has definitely gone away. I've driven maybe 50 miles today and hasn't happened once.
04WJSEV8 is offline   Reply With Quote
Unread 12-22-2013, 01:31 PM   #22
skain8
Under Construction
 
skain8's Avatar
2002 WJ 
 
Join Date: Oct 2004
Location: Reading, PA
Posts: 3,534
So you've gone from trackbar bolt moving to swaybar disconnects clunking? I don't understand.
__________________
Tom

'02 WJ: 4.7L, 5", HP44/9", 231HD, tall & skinny KM2's
'99 XJ: stock
'99 XJ: stolen
'06 XK: sold
231HD build guide
skain8 is offline   Reply With Quote
Unread 12-23-2013, 08:57 AM   #23
04WJSEV8
Registered User
 
Join Date: Oct 2013
Location: Clifton park, NY
Posts: 42
I've gone from my brother telling me the TB was moving on the bolt to the issue actually being the sway bar. Right now it's disconnected and no issues. So I'll be ordering new bushing on the bar and quick disconnects.
04WJSEV8 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.