HVAC Issues: Blower Motor Wiring Harness/Connector, Blend Door, Recirc Door Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > HVAC Issues: Blower Motor Wiring Harness/Connector, Blend Door, Recirc Door Problems

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 01-29-2011, 02:09 PM   #1
mweb
Registered User
2001 WJ 
 
Join Date: Jan 2011
Location: Durham, NH
Posts: 1
HVAC Issues: Blower Motor Wiring Harness/Connector, Blend Door, Recirc Door Problems

Background: I have a 2001 Jeep Grand Cherokee Limited V8 with Dual Automatic Climate Control. It's got a 155,000 miles on it and up until the last year it has worked flawlessly. Lately I have been having random problems here and there but that's to be expected.


The Problems: I had been having problems with my blower motor wiring harness. The blower would fail intermittently and I found that jiggling the wiring would temporarily fix it. I took the harness off and found that it was melted as pictured at wjjeeps. I ordered a new harness from the dealer but haven't replaced it yet.

Last week we had about 7 days of sub zero degree weather. One evening I noticed that while I had hot air comeing nicely out of the vents I could feel a draft that seemed to be coming from the passenger side floor. The next morning I had the same "no blower" problem. I jiggled the wires and the blower came on, however it was only blowing cold air out of the center dash vents. I could feel heat leaking out the side dash vents but freezing cold air blasting out the center vents. No matter which way I turned the vent control knob (floor, mix, vents, defrost...) it wouldn't change. Also, the Recirculation button did nothing. I ran the ATC/AZT self-diagnostics and it gave me back the following codes: 18, 20, 22, 56. From another google search I found that those mean:

18 - Mode door travel range too large
20 - AI (Recirc) door travel too large
22 - Left temperature door travel too large
56 - Right temperature door travel too large

From various threads on this forum I decided that I was having a Blend Door problem and Recirc door problem. I confirmed this with a friend that works at a Jeep dealership who checked with his service manager. I decided to do the "through the glove box fix" for the Blend doors and to wire the Recirc door to only blow outside air (in 10 years I've never used the recirculation). I ordered some parts and they arrived this morning.

When I got out there to do the work everything was working properly again! Everything worked except the Recirc button didn't seem to do anything, the light would come on then go off again, however, the door and motor seemed to be operating well enough. Looking under the dash through the glove box, I noted that when I turned the heat off it would shift to the back, then when I turned the heat on it would shift forward fully, and like I said I was getting heat out of any vent I wanted it out of.

While I was down under the dash I figured that I'd fix the blower resistor harness but found that I couldn't remove it. It must have melted so much that it had become fused into the resistor housing. I had to unscrew the resistor to see what was going on and no matter what I tried I could not remove it.

This has left me with a few questions on how I should proceed:

Question #1: Why would the blend doors and recirc door be working again? It's about 32 degrees today so I'm wondering if maybe there was some moisture in the system and the blend door and/or recirc door froze shut?

I didn't want to cut through the glove box wall if it was working for fear of making it worse but maybe I should to further diagnose the problem.

Question #2: What should I do about the wiring harness? I was thinking about cutting the whole resistor out and bringing it inside where it was warm and fixing like in this post. Suggestions?

Question #3: Am I missing something? Did I diagnose these problems wrong? Any thoughts would greatly be appreciated.

**Capabilities/Constraints: I am generally pretty resourceful. I'm good at taking things apart and fixing things even when I have no knowledge about them (however I break a lot of stuff too). I have three major resource constraints that may make this fix difficult: 1. very little money 2. no garage (so I have to do everything outside in the cold) 3. little patience (particularly when I'm cold).

mweb is offline   Reply With Quote
Unread 01-30-2011, 10:12 AM   #2
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder, CO
Posts: 23,079
btt
__________________
'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline   Reply With Quote
Unread 01-30-2011, 12:16 PM   #3
vdubracer33
Registered User
2000 WJ 
 
Join Date: Jan 2011
Location: pittsfield, New Hampshire
Posts: 17
i dont know anything about the door problem but i just got done replacing my resistor and harness. it melted at the black clip that fgoes into the resistor. i paid 100 bucks for the new resistor at sanels they usually go for like 150. the harness i bought at the dealer for 25 bucks. i cut the old wires becuase i couldnt get the clip out it was fused on. then just spliced in the new harness and replaced my blower fuse because it was shot too and it works fine now
vdubracer33 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.