Huh?? What is it??? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 05-07-2014, 03:26 PM Thread Starter
DanniK13
Registered User
1999 WJ 
 
Join Date: May 2014
Location: Oakley
Posts: 13
Huh?? What is it???

Hi! I'm new to working on vehicles, but I can fix almost anything when put to it. So can anyone explain this to me?

Name:  image-591547815.jpg
Views: 146
Size:  419.8 KB

The hose is covered in a very clean oil. It doesn't look like engine oil. It drips every so often.

Help?

DanniK13 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 05-07-2014, 03:31 PM
Jeeples
Moderator
 
Jeeples's Avatar
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/
Posts: 6,565
Power steering hose.

His: '00 WJ 4.7 Limited- Some stuff

Hers: '03 WJ 4.7 Laredo- Some more stuff


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
Originally Posted by wjjeep19 View Post
It is what Jeeples has *PARTIALLY* stated.
Jeeples is offline  
post #3 of 8 Old 05-07-2014, 03:41 PM Thread Starter
DanniK13
Registered User
1999 WJ 
 
Join Date: May 2014
Location: Oakley
Posts: 13
That's what I was thinking but the question is, should I just replace the hose? Power steering goes out when I try to park or cuts on and off while driving. Should I think about doing the pump too?
DanniK13 is offline  
 
post #4 of 8 Old 05-07-2014, 03:42 PM
gold01wj
Registered User
2000 WJ 
 
Join Date: Mar 2013
Location: Toadlena,
Posts: 314
Does it have fluid in it??? If it's been run low for a while the pump is probably shot

2000 wj limited quadradrive 4.7 family vehicle-was stock, then lifted 4",now stock again
gold01wj is offline  
post #5 of 8 Old 05-07-2014, 03:46 PM Thread Starter
DanniK13
Registered User
1999 WJ 
 
Join Date: May 2014
Location: Oakley
Posts: 13
It is 100% full, that's why I'm stumped.
DanniK13 is offline  
post #6 of 8 Old 05-08-2014, 08:28 AM
Jeeples
Moderator
 
Jeeples's Avatar
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/
Posts: 6,565
I had a similar experience with an aftermarket A1 Cardone pump, where the power assist would cut out when turning the wheel at low speed (parking lots, turning from a stop light, etc). It took a couple of tries to get a pump that was quiet like the OE pump or wouldn't randomly cut out. If I were to do it again I would go with a reman'd Mopar pump.

His: '00 WJ 4.7 Limited- Some stuff

Hers: '03 WJ 4.7 Laredo- Some more stuff


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
Originally Posted by wjjeep19 View Post
It is what Jeeples has *PARTIALLY* stated.
Jeeples is offline  
post #7 of 8 Old 05-08-2014, 09:09 AM
Double E
Web Wheeler
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 4,980
Common replacement item.
You're losing pressure and air goes in & out, reducing assistance. Do not overfill that reservoir.

Take great care in putting the new hose in. It's easy to cross thread. Carefully examine the part the dealer provides you as a replacement too as some have reported getting a part that was not right.

'04 Freedom Edition HO & '04 Overland HO (previous '00 Laredo 4.7)
Double E is offline  
post #8 of 8 Old 05-08-2014, 11:04 AM Thread Starter
DanniK13
Registered User
1999 WJ 
 
Join Date: May 2014
Location: Oakley
Posts: 13
Thanks so much for the help! I really appreciate it!
DanniK13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome