How much noise does your PS pump make? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > How much noise does your PS pump make?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineDan's Old as Dirt Birthday Sale!GEARSHADE Pocket Tops in stock and available at ROCKRIDGE

Reply
Unread 11-21-2012, 10:52 PM   #1
Galaxie500LTD
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: South River, Ontario
Posts: 213
Wj How much noise does your PS pump make?

I've got a 2001 JGC Limited 4.7 V8 with Quadradrive. I have the hydraulic cooling fan which is powered by the PS pump.

I can always hear PS pump... it's not really loud necessarily, but it does whine...

I've read that these pumps just make noise, that it's normal?

When it's below zero outside, on start up, it howls for a second or two.

I have sucked out the old fluid + refilled the reservoir with Mopar MS-5931 4 times. I raised the wheels off the ground and did 20 full stop to stop turns while doing this.

So, how much noise does your pump make? Does it squeal/howl when it's freezing?

Galaxie500LTD is offline   Reply With Quote
Unread 11-21-2012, 11:28 PM   #2
ZeJokee
Registered User
1993 ZJ 
 
Join Date: Nov 2008
Location: Kansas City, Missouri
Posts: 1,492
I actually just noticed my PS pump making noise today. Sitting at a stop light holding the wheel was hearing a whinning/spinning air noise. let off the wheel it disappeared. I was hearing it over my radio and exhaust. I afraid a new pump is in my future.
__________________
99 WJ Ltd, Blacked out, 4.7L, 242j Swap, 2'' BB, 245/75/16 Kuhmo Venture AT KL78, Flow Master Super 40, MagnaFlow high flow Cat, Akebono caliper upgrade, Addco rear swaybar, Westin brush guard, Moog Super Trail Boss, Rancho RS5000, Rola roof rack with dual kayak J hooks, PAC-AOEM-CHR, Sony Xplod 1200w amp, 2 Sony Xplod 12'' subs, 118,XXX miles (SOLD)
93 ZJ Ltd, Blacked out, 5.2L, Reman 46RH, Reman 242 Swap, 3.5'' IRO + 2" BB, 33x12.50r15 Mud Claw MTX radials, Bushwacker Flares, 216,XXX miles (Still parked in NC)
04 F-350 SD Crew Cab FX4 Lariat, 6.0 PSD SRW, Head studs, AFE Stage 2 SI Pro Guard 7 intake, Blue Spring mod, 150,XXX Miles

ZeJokee is offline   Reply With Quote
Unread 11-22-2012, 12:14 AM   #3
pinky2252s
Registered User
2001 WJ 
 
Join Date: Oct 2011
Location: Broomfield, Colorado
Posts: 1,825
My 01' feels much tougher to turn than the 04'. I think that my power steering pump has weakened.

It groans when its at full lock. No leaks, full fluid. Seems like its gonna die soon, I suspect that it is stock.
__________________
Is it broken?

Colorado Jeep Club Member #2252
2001 Laredo, 2004 Special Edition
pinky2252s is offline   Reply With Quote
Unread 11-22-2012, 05:05 AM   #4
Rooster71
Registered User
2002 WJ 
 
Join Date: Feb 2011
Location: California, Pennsylvania
Posts: 25
My "02 whines all the time. It is a new one, too. When it is cold, it really makes some noise. I have kept an eye on it, and it is working. I think it is common.
Rooster71 is offline   Reply With Quote
Unread 11-22-2012, 05:55 AM   #5
coopdc78
Registered User
2004 WJ 
 
Join Date: Sep 2008
Location: Buffalo
Posts: 623
I just replaced mine and it still makes a little noise..nothing to worry about IMO
__________________
2004 overland 3 inch lift bilsteins 5100.. Addco sway bar. 265/70/17 nitro Terra grapplers
coopdc78 is offline   Reply With Quote
Unread 11-22-2012, 07:34 AM   #6
jeep4venturing
Registered User
1993 XJ Cherokee 
 
Join Date: Jun 2012
Location: Cape Girardeau, Mo
Posts: 18
Mine is new also and whines, I have a hose leaking off the pump so I have using transmission fluid and that makes it worse so now I waste only power steering fluid and a little Lucas fluid and that stops it. I need to replace that hose since it will not seal but just cant get the time to do it. I might take it apart today and mess with it .
__________________
JAMES MARTIN BAIL BONDS AND PRIVATE INVESTIGATION
jeep4venturing is offline   Reply With Quote
Unread 11-22-2012, 07:47 AM   #7
coopdc78
Registered User
2004 WJ 
 
Join Date: Sep 2008
Location: Buffalo
Posts: 623
Ur using tranny fluid..? Hope full u flush it after u fix it..are u sure its a hose leaking..I found once I replace my pump that my o ring to the resiviour was actually leaking. I also thought it was a hose
__________________
2004 overland 3 inch lift bilsteins 5100.. Addco sway bar. 265/70/17 nitro Terra grapplers
coopdc78 is offline   Reply With Quote
Unread 11-22-2012, 08:00 AM   #8
EFoxwell
Registered User
2004 WJ 
 
Join Date: Jul 2012
Location: Bethany Beach, Delaware
Posts: 85
Quote:
Originally Posted by coopdc78
I just replaced mine and it still makes a little noise..nothing to worry about IMO
This is my situation too. Replaced 2 months ago.
EFoxwell is offline   Reply With Quote
Unread 11-22-2012, 08:19 AM   #9
jeep4venturing
Registered User
1993 XJ Cherokee 
 
Join Date: Jun 2012
Location: Cape Girardeau, Mo
Posts: 18
I can see it coming out of the joint and threads on the top hose. I looked at the hose fitting and dont see how it can seal. It is coming out around the threads too. Its a reman. pump so I hope there isnt a problem with the pump threads.
Tranny fluid is a common replacement to use, It is not ideal but will work. it tends to get air bubbles in it real easy, looks like foam, this is why it squeals with it. The others here might try adding an anti squeal treatment if they have a foamly looking fluid if you have no leaks to waste it.
__________________
JAMES MARTIN BAIL BONDS AND PRIVATE INVESTIGATION
jeep4venturing is offline   Reply With Quote
Unread 11-22-2012, 08:31 AM   #10
shepd
Registered User
2000 WJ 
 
Join Date: Jan 2011
Location: Kitchener, ON
Posts: 476
If you have leaks at that top hose, remove it, replace the O-Ring, put it back in and put a "just right" amount of torque on it. The O-Ring damages easily and once it is damaged, it will leak all over.
shepd is offline   Reply With Quote
Unread 11-22-2012, 08:31 AM   #11
coopdc78
Registered User
2004 WJ 
 
Join Date: Sep 2008
Location: Buffalo
Posts: 623
Well just saying cause our jeeps with the hydraulic fan require certain fluid cause obviously it runs the fsn and ps
__________________
2004 overland 3 inch lift bilsteins 5100.. Addco sway bar. 265/70/17 nitro Terra grapplers
coopdc78 is offline   Reply With Quote
Unread 11-25-2012, 03:32 PM   #12
Galaxie500LTD
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: South River, Ontario
Posts: 213
Great input thanks all!

I'm just going to assume my power steering pump is fine for now. Normal stuff for the Jeep apparently!

Galaxie500LTD is offline   Reply With Quote
Unread 03-08-2013, 08:59 AM   #13
jchearon
Registered User
2001 WJ 
 
Join Date: Nov 2012
Location: Boston, MA
Posts: 45
I have a 01 WJ V8 4.7L and my power steering intermittently makes this god awful moan. It usually happens if they A/C/defrost is on when idling. My pump is working fine, power steering has no damage or wear (I keep up on it), and I change the fluid to keep it fresh (yes, using the exact recommended fluid) but it still moans sometimes and the past several years the moaning is getting worse. Since it is an '01, I'm thinking it wouldn't hurt to replace components. My power steering high line does have slight evidence of leaking, however, I have never had a problem with low power steering fluid before. I do feel the lines may be the culprit making the noise and I am thinking of replacing them. And yes, I understand it is a Jeep and Jeeps just decide to make weird noises for no reason and then go away.

Since this is a vital part, I don't want to buy aftermarket and go with MOPAR. Are there any concerns I should consider with a new hose with a 12 year old power steering pump? Should I order any other parts while I am at it? On justforjeeps.com, I only see the "hydraulic power steering hose" (part # 5019708AE) which I am assuming it is the high hose? Does anyone know the part # for the low pressure (to gear from hydraulic fan motor I believe)?
jchearon is offline   Reply With Quote
Unread 03-08-2013, 10:09 AM   #14
Robertc2012
Registered User
2001 WJ 
 
Join Date: May 2012
Location: Hluhluwe, KZN South Africa
Posts: 227
The 'moan' of the pump is usually cavitation at the impeller. Microscopic bubbles which form due to fluid friction.
Any pump would prefer to suck air than fluid.
Best to check:
1. filter(If there is one for clogging which will restrict flow.
2. Suction lines for cracks, or restricted flow in the lines. Bear in mind a small suction line leak will not easily be detectable by oil leaking out.
The last check is a worn Pump impeller, which will cause poor steering response and cavitation.
The steering fluid should be changed regularly for a start.
The full lock sound is the pump by pass valve doing its job.
Robertc2012 is offline   Reply With Quote
Unread 03-08-2013, 11:01 AM   #15
jchearon
Registered User
2001 WJ 
 
Join Date: Nov 2012
Location: Boston, MA
Posts: 45
Wow, thank you for an excellent response!
jchearon is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.