Help!, No turn signals or heater controls - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Help!, No turn signals or heater controls

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 06-11-2013, 12:24 PM   #1
Delmega
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2013
Location: Bozeman, MT
Posts: 3
Lightbulb Help!, No turn signals or heater controls

We managed to hotwire our trailer lights into our 2001 Jeep Grand Cherokee to pull our boat to the lake. When we did this we lost both turn signals and the control panel for the heat, blower, and A/C. We have changed out all of the relays under the steering column and the control panel for the heater. We still do not have turn signals or control panel. We have tested the blower motor and it is working fine. If anyone can help with any additional things to try please let us know.

Thanks

Delmega is offline   Reply With Quote Quick reply to this message
Unread 06-11-2013, 12:28 PM   #2
Delmega
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2013
Location: Bozeman, MT
Posts: 3
Also I forgot to mention that the flashers, brake, running and headlights all still work.
Delmega is offline   Reply With Quote Quick reply to this message
Unread 06-11-2013, 04:55 PM   #3
oldfamilyguy
Registered User
 
Join Date: Dec 2008
Location: oakville, canada
Posts: 814
Did you check for any blown fuse? That would be my guess, you caused a short.
oldfamilyguy is offline   Reply With Quote Quick reply to this message
Unread 06-11-2013, 10:12 PM   #4
Delmega
Registered User
2001 XJ Cherokee 
 
Join Date: Jun 2013
Location: Bozeman, MT
Posts: 3
We had checked all of the relevant fuses when this first happened and all checked out fine. We rechecked everything and I downloaded a complete copy of the fuse schematics. In our Haynes manual it should fuse 23 as the heated seats but once we got the complete schematics we discovered that fuse 23 also runs the heater controls and the blinkers. Once we switched out the fuse everything is working great.
Delmega is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.