Help me please. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Help me please.

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 11-24-2013, 04:29 AM   #1
Spartan680
Registered User
 
Join Date: Nov 2013
Location: salem, or
Posts: 3
Wj Help me please.

OK i have a 2003 WJ and my heat turns on and blows hot air but it wont change from defrost to anything else. and also when i turn the dial from high to low the back light well be off i turn it on and off again and the light comes back on not sure if that's part of the problem or not. at one time i would hammer down on the gas pedal and then let off and it would start to blow air out of the vents so im thinking its a vacuum problem not to sure. also it started doing it after i took it to jeep dealership to get a cam job done so im not to sure if they did something to it or not. its starting to get cold so i need to figure this out. i hope someone can help me thanks..

Spartan680 is offline   Reply With Quote
Unread 11-24-2013, 04:44 AM   #2
michiganmaveric
Got Beer?
 
michiganmaveric's Avatar
2011 JK Wrangler 
 
Join Date: Aug 2004
Location: Southeast Michigan
Posts: 2,720
What engine do you have? I had the 4.0 and this happened to me once. It is probably a vacuum hose off of the eng. On the 4.0 look on the drivers side of the eng at the intake manifold about the middle of the eng (around the 3 or 4 cylinder area). That is where I found my problem. You might be able start it up and hear a sucking sound. If not there then check all around and even under the dash for a vacuum line that is either off or broke/cracked.
__________________
Previous Jeeps: 84 CJ7 (A True Jeep), 2000 XJ (163,000 Miles/Totaled (Pictures of wrecked Jeep in gallery)), 2004 WJ (parting out die to major electrical issues)

If you don't have time to do it right the first time, how do you have time to do it over.

Lifetime member #13

www.militaryjeepers.com lifetime member/airforce26yrs

2011 Tango/Mango JKU
michiganmaveric is offline   Reply With Quote
Unread 11-24-2013, 05:39 AM   #3
Spartan680
Registered User
 
Join Date: Nov 2013
Location: salem, or
Posts: 3
i have a 4.0. and thanks for the help i will check it in the morning!
Spartan680 is offline   Reply With Quote
Unread 11-24-2013, 11:26 AM   #4
ezflip
Theme Park Dinosaur Head
 
ezflip's Avatar
2002 WJ 
 
Join Date: Oct 2008
Location: Michigan
Posts: 4,865
Definitely a vacuum leak. The lighting is a separate issue.
__________________
~James

2002 Overland - 4.7 HO, "Select-Drive", 4" RC long arms, TAG front winch bumper, 32" BFG KM's, Kolak 3" exhaust, Flowmaster 50 series


Build Thread

KCCO
ezflip is offline   Reply With Quote
Unread 11-24-2013, 09:08 PM   #5
Spartan680
Registered User
 
Join Date: Nov 2013
Location: salem, or
Posts: 3
so i checked around the eng and didnt see anything that looked out of place. gonna have a buddy help me look into it more tomorrow i dont know to much about cars
Spartan680 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.