Heater Problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Heater Problem

The Original 3/8" Ruffstuff Diff Cover!Safety Thimble FairleadsEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 10-22-2003, 12:53 AM   #1
SarelN
Registered User
 
Join Date: Oct 2003
Posts: 1
Question Heater Problem

Hi,
I have a problem with my 2001 Jeep Grand Cherokee LTD in the sense that the blower only blows cold air, no matter if I turn the temperature all the way to "Hi". The A/C works fine and the cooling process seems to work ok. I have contacted Jeep and they have said that it appears to be a "very expensive" fault. Since I am not very mechanically inclinded, I wonder if there is anybody that can shed some light as to what this problem could be.

I have checked the previous threads, I have done the diagnistic check ("done") and I have performed the core heater check (No mist or smell present).

Any advise would be greatly appreciated.
Thanks
Cheers

SarelN is offline   Reply With Quote Quick reply to this message
Unread 10-22-2003, 11:00 AM   #2
Red Menace
Registered User
 
Join Date: Oct 2003
Posts: 79
Quote:
Originally Posted by SarelN
Hi,
I have a problem with my 2001 Jeep Grand Cherokee LTD in the sense that the blower only blows cold air, no matter if I turn the temperature all the way to "Hi". The A/C works fine and the cooling process seems to work ok. I have contacted Jeep and they have said that it appears to be a "very expensive" fault. Since I am not very mechanically inclinded, I wonder if there is anybody that can shed some light as to what this problem could be.

I have checked the previous threads, I have done the diagnistic check ("done") and I have performed the core heater check (No mist or smell present).

Any advise would be greatly appreciated.
Thanks
Cheers
Hey SarelN, I have this problem too. The drivers side only blows cold air, but the passenger side seems to be working fine. The dealer said that they have to take upart the dash to get to all the goodies inside. They gave me an outragous price too. Maybe check the sensor if you have the dual climate control. Other than that, I have no idea. Just letting you know that your not the only one.
Red Menace is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.