post #46 of Old 02-19-2013, 06:28 PM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Probably by the firewall thermostat looks untouched? Help me out, how does that matter? Thanks


Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
post #47 of Old 02-19-2013, 06:37 PM
adavis39
Registered User
2002 WJ 
 
Join Date: Nov 2011
Location: Nashville
Posts: 2,808
Quote:
Originally Posted by TheSiltSurfer View Post
Probably by the firewall thermostat looks untouched? Help me out, how does that matter? Thanks
i dont think it would make a difference as far as your problem goes...i was just wondering how he did it since I may do it this week.....are you sure there is no leak right where you upper hose meets the rad?

2002 WJ Limited 4.7: 6" Clayton REALLY long arms....yep, they are longer than yours SOLD : (
1998 Platinum 5.9 DD
2007 WK Overland 5.7 wifes DD
TNJEEPS.COM

BUILD: http://www.jeepforum.com/forum/f197/...-crap-1399123/

"In a world that he did not create, but he will go through it as if it is his own creation. Half man, half beast, whatever it is it is weird, it is ticked off and it calls itself Slash"
adavis39 is offline  
post #48 of Old 02-19-2013, 06:43 PM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Quote:
Originally Posted by adavis39

i dont think it would make a difference as far as your problem goes...i was just wondering how he did it since I may do it this week.....are you sure there is no leak right where you upper hose meets the rad?
Going to double check that hose later keep it running and watch for a leak. I just crawled down there & I'm started to thinking maybe it was just the overflow from bottom of radiator? Hopefully nothing major I cleaned off the steering box drove to the gym and just the overflow and gotten fluid onto axle ect on drivers side
Attached Thumbnails
image-3963386990.jpg  

Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
post #49 of Old 02-19-2013, 06:45 PM
gkbid
Registered User
2004 WJ 
 
Join Date: Dec 2005
Location: Kansas
Posts: 93
Could be a pinhole leak in hose or radiator that isn't apparent unless under pressure with engine up to running temp.

2004 WJ Limited Overland
4.7L HO, Black, 4X4 QuadraDrive w/Vari-Loks

Past Jeeps: 2001 WJ 4.7 Ltd / 1999 WJ 4.7 Ltd / 1993 ZJ 5.2 GW, 1988 XJ 4.0 Ltd
gkbid is offline  
post #50 of Old 02-19-2013, 06:48 PM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Quote:
Originally Posted by gkbid
Could be a pinhole leak in hose or radiator that isn't apparent unless under pressure with engine up to running temp.
I thought the same thing & tried something very stupid, squeeze the hose with my bare hands! Lol But that could still be my issue, ill look into it more later

Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
post #51 of Old 02-19-2013, 08:07 PM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Okay after more reassessment the leak appears to be coming from the front of radiator near the top in front of where the hose meets the radiator? What could this be now whole radiator replacement? Dammit lol wj woes

Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
post #52 of Old 02-19-2013, 09:49 PM
04RockyMountain
Registered User
2004 WJ 
 
Join Date: Apr 2011
Location: North
Posts: 73
Hey siltsurfer free bump for you since i just noticed the same damn problem with my 04 WJ. do me a favor and try to put your ear next to that clip when the car is hot! you will probably hear the pin hole/slit on your hose. I can hear my damn hose leaking its a very slow leak once colder but leaks like hell when it runs and hot! I am going to change that hose to see what happens and keep you updated if I replace it before you. let me know with your process as well!
P.s. that is what happens when you drive your WJ 4 times a year i am gonna get that thing out more often lol

Jeepin' Since I Know Myself!!!
04RockyMountain is offline  
post #53 of Old 02-19-2013, 10:08 PM
rickcricket
Registered User
2002 WJ 
 
Join Date: Nov 2010
Location: saint louis
Posts: 614
Just get a pressure test fellas. Problem solved quickly. If its the rad it will show, if its something else it will show as well.
rickcricket is offline  
post #54 of Old 02-20-2013, 10:31 AM
adavis39
Registered User
2002 WJ 
 
Join Date: Nov 2011
Location: Nashville
Posts: 2,808
so for anyone that has replaced th heater core.....looks like ill be doing this on Friday. 1st question....do I have to emtpy the cooling system first. My AC lines are already flushed from where I did the condensor last month and never re-charged the lines. 2nd question......how does the HVAC system come out? I have obviosuly found plenty of write ups on the dash removal but cant seem to find how the HVAC actually mounts.....is it just bolted on?

2002 WJ Limited 4.7: 6" Clayton REALLY long arms....yep, they are longer than yours SOLD : (
1998 Platinum 5.9 DD
2007 WK Overland 5.7 wifes DD
TNJEEPS.COM

BUILD: http://www.jeepforum.com/forum/f197/...-crap-1399123/

"In a world that he did not create, but he will go through it as if it is his own creation. Half man, half beast, whatever it is it is weird, it is ticked off and it calls itself Slash"
adavis39 is offline  
post #55 of Old 02-23-2013, 08:12 PM
gkbid
Registered User
2004 WJ 
 
Join Date: Dec 2005
Location: Kansas
Posts: 93
It just bolts to the firewall wall in several places. It'll be obvious once you get to that point.

image-3751642730.jpg

2004 WJ Limited Overland
4.7L HO, Black, 4X4 QuadraDrive w/Vari-Loks

Past Jeeps: 2001 WJ 4.7 Ltd / 1999 WJ 4.7 Ltd / 1993 ZJ 5.2 GW, 1988 XJ 4.0 Ltd
gkbid is offline  
post #56 of Old 10-11-2013, 03:35 PM
Karlinwa
Registered User
1989 FSJ Cherokee 
 
Join Date: Dec 2012
Location: vancouver
Posts: 48
I had that same radiator leak onto the steering box it was a plug in the radiator
Attached Images
 
Karlinwa is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome