The good and the bad - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 09-18-2010, 03:53 AM Thread Starter
99JeepGC47
Registered User
2008 KK Liberty 
 
Join Date: Jul 2010
Location: Sumter
Posts: 204
Wj The good and the bad

Well. I got my new 4.7 engine running, and I fixed the problem I had with the leaking transmission cooler. I will get pictures when I can find my camera. I havfe 2 codes, P10123, and P0113, both i think happened when I was taking the plug off the sensor whole it was running but I am not sure.

My biggest problem though is I start it up and it shuts right off it will run if I keep my foot on the accelerator. I don't have the first clue were to look. I have check every conection, those are the only codes, I also put on a new fuel filter. I will start looking and playing around with it in a few hours.

99JeepGC47 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-18-2010, 05:33 AM
creepingdeath94
Registered User
2000 WJ 
 
Join Date: Sep 2010
Location: port saint lucie
Posts: 147
How much have you run it so far? Maybe it needs a bit more time to run and set itself up/learn IAC counts? Is the IAC new/cleaned? Any vacuum leaks...all it might take is one small hose off or broken somewhere for this to happen.

Last edited by creepingdeath94; 09-18-2010 at 05:51 AM.
creepingdeath94 is offline  
post #3 of 6 Old 09-18-2010, 08:22 AM
Mr_Grumpy
Registered User
1999 WJ 
 
Join Date: Apr 2008
Location: Inverness
Posts: 468
Id disco the battery and clear the codes so you know for sure.

When the gas pedal is floored its, afaik, opening the butterfly and letting more air in. So maybe theres a problem there.Someone a lot better than i at these things will be along soon
Mr_Grumpy is offline  
 
post #4 of 6 Old 09-18-2010, 09:07 AM Thread Starter
99JeepGC47
Registered User
2008 KK Liberty 
 
Join Date: Jul 2010
Location: Sumter
Posts: 204
I am getting ready to go out and check all the vacum lines again. The IAC is the same one that has always be on the it, I did clean it though. I had had it running the day before it started doing this. I ran it for about 10-15 minutes, but I had a leak at the transmission cooler. I got some fresh gas, and some Heet to take out any water that may be in the tank. I will see what I find.
99JeepGC47 is offline  
post #5 of 6 Old 09-18-2010, 10:25 AM Thread Starter
99JeepGC47
Registered User
2008 KK Liberty 
 
Join Date: Jul 2010
Location: Sumter
Posts: 204
It is alive!!!!!!!!!!!!!! I don't know what I hit or did. I put in some Heet, and a little gas. I didn't even paly with the vacume lines. It is running now, I am going to take it around the block to see how everything feels. Thanks everyone for your help!
99JeepGC47 is offline  
post #6 of 6 Old 09-18-2010, 10:34 AM
compcrasher86
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2008
Location: Marblehead, MA
Posts: 6,276
It may have just figured out the IAC combinations but do not go too far until you deem it reliable. It is probably was or may still be the IAC. Nevertheless, good luck and enjoy the 4.7!

98 XJ Sport | i6 | AW4 | 231 | Stone White | Agate Leather

SOLD 01 WJ Ltd | i6 | QT2 | Moog HD steering | Tow Package | Boston Acoustics Audio | RB1 | Lou's Catback | Stone White |

Matt
compcrasher86 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Fedex was good to me today White2000WJ WJ Grand Cherokee Forum 7 09-09-2010 10:10 PM
Hello! it is good to be back and HELP! Beetlescott WJ Grand Cherokee Forum 9 04-05-2010 08:32 AM
Removed carpet for good QuadraTokn WJ Grand Cherokee Forum 20 03-21-2010 11:30 PM
Good Deal for an 02 GC Limited? rsteps WJ Grand Cherokee Forum 5 08-10-2007 10:23 AM
Good place for CB? froggo27 WJ Grand Cherokee Forum 29 07-26-2007 05:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome