GCL - "lift gate open" on display...not open though.... wheres the switch? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > GCL - "lift gate open" on display...not open though.... wheres the switch?

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 08-23-2010, 10:39 AM   #1
JOSHMAN00
Registered User
2007 XK Commander 
 
Join Date: Jan 2009
Location: Alberta
Posts: 145
Wj GCL - "lift gate open" on display...not open though.... wheres the switch?

So weird problem just started on the jeep yesterday in the city. 99 GC limited and I have had it for about four years now. It has the overhead console that displays the temp, compass...etc etc and also shows when a door or lift gate is open when the vehicle is running. Well anyway I just got into the city yesterday and all of a sudden at the lights the truck is beeping away and I look up to the overhead console and it reads "liftgate open". I figure no biggie just not latched proper so I get out close it tight and drive on. About two blocks later its coming off and on every few seconds...liftgate open... then ok....then open again. Did this about 10-15 times randomly an then on the drive home it was fine?

Never did it on the highway only once we hit the stop and go traffic of the city. Anyways this has never happened and I triple checked the lift gate and the glass hatch and everything was fine. Now I assume there is a door jamb switch somewhere that senses when the hatch is actually open right? Problem Is I cannot find one anywhere so I am wondering if it is internal in the hatch maybe by the handle? Called the local dealer and the parts dept couldn't tell me if there was one or where it was located. Any help would be much appreciated it is not biggie to see the message but the annoying triple beep beep beep that comes along with the message is enough to drive a man to drinking ecspecially when it comes on five times a block in rush hour! Thanks in advance for any help

JOSHMAN00 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2010, 12:00 PM   #2
myjeeplovesmud
Registered User
2004 WJ 
 
Join Date: Mar 2009
Location: Madison, WI
Posts: 3,242
lube the latches, should cure it... if not you need to adjust it
myjeeplovesmud is offline   Reply With Quote Quick reply to this message
Unread 08-24-2010, 09:33 PM   #3
JOSHMAN00
Registered User
2007 XK Commander 
 
Join Date: Jan 2009
Location: Alberta
Posts: 145
Thanks lubed already.... but where and what needs to be adjusted?
JOSHMAN00 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.