Engine stalls when reaching running temp - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Engine stalls when reaching running temp

Savvy/Currie Aluminum Control ArmsROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO December Specials at Jeephut.com

Reply
Unread 01-24-2013, 10:31 AM   #16
2001WJv8
Registered User
1983 CJ7 
 
Join Date: Nov 2008
Location: Deming, NM
Posts: 550
did you check fuel pressure?

Quote:
Originally Posted by 2001WJv8 View Post
get, borrow, rent a fuel pressure gauge - i had a similar issue, though with mine it would start cold fine and ran fine until I shut it down - then it would not start again until the engine was cold again (crank strong but still wouldn't start)

once I checked leakdown and determined there was zero fuel psi right after shutting it down, and only 30psi while running, I figured out my fuel filter/regulator (mopar) had crapped out .... changed the fuel filter and problem solved - correct psi while running, and holds steady long after turning it off


__________________
'83 CJ7 w/ 350 crate / carb'd / 4spd
'12 F150SC 4x4 v8
(sold = 2001 WJ)
2001WJv8 is offline   Reply With Quote Quick reply to this message
Unread 01-25-2013, 03:36 PM   #17
djdan
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: canvey island, essex / England
Posts: 11
The crank sensor was from jeep main dealers

I am looking at fuel pressure this weekend so will keep you posted
djdan is offline   Reply With Quote Quick reply to this message
Unread 01-29-2013, 04:19 AM   #18
djdan
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: canvey island, essex / England
Posts: 11
Ok done fuel pressure test and reading 51 psi constant not jumping.
djdan is offline   Reply With Quote Quick reply to this message
Unread 01-29-2013, 08:21 AM   #19
2001WJv8
Registered User
1983 CJ7 
 
Join Date: Nov 2008
Location: Deming, NM
Posts: 550
and it holds pressure after shutting the engine down? (leakdown)
2001WJv8 is offline   Reply With Quote Quick reply to this message
Unread 01-30-2013, 09:11 AM   #20
djdan
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: canvey island, essex / England
Posts: 11
Ok fuel pressure drops down to 48 when ignition turned off then slowley drops to 42 when i restarted car it stayed at 42 did not go up to 51.

Last edited by djdan; 01-30-2013 at 09:24 AM..
djdan is offline   Reply With Quote Quick reply to this message
Unread 05-11-2013, 02:33 PM   #21
cw05
Registered User
1984 CJ7 
 
Join Date: Jun 2004
Location: Augusta, GA
Posts: 46
Did you ever figure out what the problem was? I have the same model with 4.7L V8 having the same stalling symptom when reaches running temp.
cw05 is offline   Reply With Quote Quick reply to this message
Unread 05-27-2013, 12:19 PM   #22
djdan
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: canvey island, essex / England
Posts: 11
Changed fuel pump and filter but still have the same problem...... Car maybe going to scrap yard if I don't get it sorted soon its been over a year now
djdan is offline   Reply With Quote Quick reply to this message
Unread 05-27-2013, 04:10 PM   #23
cw05
Registered User
1984 CJ7 
 
Join Date: Jun 2004
Location: Augusta, GA
Posts: 46
I have replaced the battery, fuel filter, verified all my grounds are good and done the hose clamp trick that others have posted about on the PCM to apply more pressure to the 3 PCM inputs. My Jeep WJ (02 Limited 4.7L) has proven itself to be poorly made between the faulty window cable units (3 replaced so far), the air conditioner blower module (replaced this spring), the heater coil that I had to pull the whole dash to replace, blown speakers, broken seat warmers and now this stall problem for a modern vehicle with ~105K miles on it. I'll keep my 84 CJ-7 that has largely been bulletproof but wont be buying anymore Jeep products again. Mine will be likely replaced with a Honda Pilot this week. I'm tired of the stalling putting myself and my family in danger out on the road.
cw05 is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 07:17 PM   #24
djdan
Registered User
1999 WJ 
 
Join Date: Dec 2012
Location: canvey island, essex / England
Posts: 11
Still need help

Ok so now I have replaced the fuel pump all the relays including the asd one and still stalls when it warms up.
djdan is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.