Electrical system/computer goes haywire - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 05-15-2002, 08:06 PM Thread Starter
Registered User
Join Date: May 2002
Location: Alexandria, LA/College Station, TX
Posts: 4
Post Electrical system/computer goes haywire

I joined this forum last week with a sound system issue, and now my electrical system is having serious problems. Prior symptoms: None. Got in this afternoon, turned the key, no starter noise just one click. Then all my guages began to spin back and forth, accompanied by a clicking/gear grinding sound; accessories and clock didn't function.

This continued after the key was removed. So I had to pop the hood to get at the battery; the underhood light was dim and pulsating, like it was still sending power to the starter, trying to get it to crank. I thought it might be a computer glitch so I disconnected and reconnected the battery only to have the problem continue.

Of course this happens when the car is only 7000 miles outside the warranty period. Has anyone experienced anything like this? I'll be calling the tow truck in the morning. Any help is greatly appreciated!


1999 Grand Cherokee Laredo
4.7L V8 Quadra-Drive
Bridgestone Dueler AT's
K&N FIPK Gen II Intake
SRT99WJ is offline  
Sponsored Links
post #2 of 2 Old 05-17-2002, 06:48 PM
Registered User
moabster's Avatar
2011 WK 
Join Date: Apr 2002
Location: Orem, Utah
Posts: 402

Check the battery. When my battery went bad on my 93 Grand Cherokee it acted about the same. Next check starter to see if it is shorted. Did you recently install a stereo system? If so, check wiring to make sure you don't have something draining the battery when the jeep if off.

2000 Jeep Grand Cherokee V8 Stock
93 YJ I6 hard top (really belongs to SPEED)
RE 4.5" Extreme Duty Lift, Advanced Adapters SYE, Tom Woods CV Drive Shaft, EA589 10" rims with 33" x 12.5" MT/Rs
Bullet Proof Front and Rear Bumpers and Tow bar
moabster is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Service Electrical Brake System light? beeneeb WK Grand Cherokee & XK Commander Forum 14 06-23-2015 02:02 PM
Electrical System is PO'd xa310165 WK Grand Cherokee & XK Commander Forum 11 10-22-2009 03:13 PM
Possible electrical/charging system issue. GCherokee2001 ZJ Grand Cherokee Forum 0 11-08-2007 01:25 PM
Electrical System Problem MWLThe1st ZJ Grand Cherokee Forum 3 01-22-2007 02:19 PM
Electrical system? rpeAMP ZJ Grand Cherokee Forum 1 10-20-2002 11:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome