Cooling Question? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 07-21-2014, 10:31 PM Thread Starter
mr312712
Registered User
2004 WJ 
 
Join Date: Jul 2014
Posts: 2,907
Wj Cooling Question?

Today It was 90 degrees and It rain fine but when I turned It off and came back I noticed the temp gauge was a little high red line on pic but as soon as I started It Up It went a little under 210 like normal anti-freeze at full new air filter.

Name:  Grand-Cherokee-Temperature-Gauge.jpg
Views: 63
Size:  19.3 KB

mr312712 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-22-2014, 12:43 AM
JPugh
Registered User
1999 TJ Wrangler 
 
Join Date: Oct 2011
Location: Raleigh
Posts: 77
That sounds to me like it was just heat soak, very normal. The engine is still very hot when you shut it down and when the water stops flowing it just sits there and warms up.
JPugh is offline  
post #3 of 5 Old 07-22-2014, 07:47 AM
ChrisHager
Custom User Title
 
ChrisHager's Avatar
2004 WJ 
 
Join Date: Jan 2011
Location: Springfield
Posts: 8,347
Garage
Clearly it's too early because I was staring that that picture thinking, what it the world is up with your temperature gauge - a black needle AND a red one?!

I'm an idiot.

Do you have any issues with the cooling system while the engine is running?

~Chris
His: 2004 WJ - OME HD 'Kolak' Lift - Build Thread
His: 1979 J-10 - 3" on 33s - Build Thread
His: 2009 Expedition
Hers: 2000 TJ
Hers: 2010 Jetta

ChrisHager's 'Grilled' Thread

Quote:
Originally Posted by Matt
"You can't recycle tartar sauce."
ChrisHager is online now  
post #4 of 5 Old 07-22-2014, 08:45 AM
skain8
Registered User
 
skain8's Avatar
2002 WJ 
 
Join Date: Oct 2004
Posts: 3,829
Quote:
Originally Posted by JPugh View Post
That sounds to me like it was just heat soak, very normal. The engine is still very hot when you shut it down and when the water stops flowing it just sits there and warms up.
This. Normal.

'02 WJ: 4.7L, 5", HP44/9", 231HD, tall & skinny KM2's
Half-Ton axle swap guide
231HD build info

skain8 is offline  
post #5 of 5 Old 07-22-2014, 02:10 PM Thread Starter
mr312712
Registered User
2004 WJ 
 
Join Date: Jul 2014
Posts: 2,907
Yah I thought It was normal just making sure.
mr312712 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome