Cherokee No Start - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 07-17-2013, 10:50 PM Thread Starter
TeenBeach
Registered User
2003 FSJ Cherokee 
 
Join Date: Jul 2013
Location: Greenfield
Posts: 2
Cherokee No Start

Hi, I have a 2003 jeep grand Cherokee with the 4.0L. I have been having problems with it stalling very randomly (no warning before either). The anti-drain fuel valve is bad because I have to prime it twice before I can start it. Any who... my girlfriends sister was driving the car tonight and it stalled on her. She couldn't get it to start at all so I went to the jeep and I couldn't get it to start either, even priming it. The engine tries to turn over so the starter is good, the battery also reads 12.4 volts on the gauge before starting. Also, the tank was full of gas so its not out of gas. Any ideas on where I can start? I do all my own work... like to get my hands dirty so I want to fix it myself. Hopefully you all can help me out, willing to try anything.

TeenBeach is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-17-2013, 10:58 PM
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville
Posts: 2,841
Are you getting fuel to the rail?

The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline  
post #3 of 4 Old 07-18-2013, 09:48 AM Thread Starter
TeenBeach
Registered User
2003 FSJ Cherokee 
 
Join Date: Jul 2013
Location: Greenfield
Posts: 2
Just checked the fuel rail and no fuel is coming out, even when priming the fuel pump. I did try starting it with starter fluid and it did start but I had to keep jumping on the gas to keep in running. Once I stopped jumping on the gas it would die though. So I am guessing clogged injectors, clogged fuel filter, bad fuel pump? Whats next? Thxs for all the replies and help in advanced!
TeenBeach is offline  
post #4 of 4 Old 07-18-2013, 10:23 AM
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville
Posts: 2,841
Fuel to the rail won`t necessarily mean there`s something wrong with the injectors. Could be filter, could be pump. When you turn the key to on and pause, do you hear the pump prime? If so, would look at fuel filter as possible cause. If no, check fuse/relay for the pump first. If they're good, could be to do with harness to the pump, or the pump itself.

The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome