Check Engine Light P0108? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 06-30-2011, 02:52 PM Thread Starter
source69er
Registered User
 
Join Date: Jun 2011
Location: Calgary
Posts: 10
Check Engine Light P0108?

Hey, Ive got a 2000 Jeep Grand Cherokee Limited V8, and recently the check engine light came on. I turned the key on/off 3x and the code P0108 came up. I googled around a touch and its a MAP sensor? What should I do to fix this? Am I allowed to drive with this?
Thanks.

source69er is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 06-30-2011, 03:39 PM Thread Starter
source69er
Registered User
 
Join Date: Jun 2011
Location: Calgary
Posts: 10
Also, I just drove her around for about 10 minutes, because I read that with this code rough idle is common. Nothing that I noticed, steady idleing, no hiccups, no mass loss of power..
source69er is offline  
post #3 of 11 Old 06-30-2011, 05:24 PM
Buddha_Kip
Registered User
 
Buddha_Kip's Avatar
2000 WJ 
 
Join Date: Aug 2003
Location: N'awlins
Posts: 1,098
I'm late for class, but I have the testing procedure for this. when i get out of class, 9:30-ish CST, I gotta come back here anyway, so I'll screen shot it and post it. you'll need a multimeter.

2000 WJ Limited - 2.5" Rusty's springs WAAG 1-piece front brush guard custom built WAAG nerf bars PIAA 580 lighting Custom Paint One-off Aluminum Treadplate Door Entry Guards & Rear Bumper Step
1986.5 Porsche 928S - 18" Moda MD1 Autothority Chips Rear Muffler Bypass Short-Shift Kit
Grease Monkey & HNIC @ Clasik Auto
Buddha_Kip is offline  
post #4 of 11 Old 06-30-2011, 09:21 PM
Buddha_Kip
Registered User
 
Buddha_Kip's Avatar
2000 WJ 
 
Join Date: Aug 2003
Location: N'awlins
Posts: 1,098
alrighty. here ya go.

MAP Location on Engine




Pin Diagram for Plug



Diagnostic Procedure -







Good luck

2000 WJ Limited - 2.5" Rusty's springs WAAG 1-piece front brush guard custom built WAAG nerf bars PIAA 580 lighting Custom Paint One-off Aluminum Treadplate Door Entry Guards & Rear Bumper Step
1986.5 Porsche 928S - 18" Moda MD1 Autothority Chips Rear Muffler Bypass Short-Shift Kit
Grease Monkey & HNIC @ Clasik Auto
Buddha_Kip is offline  
post #5 of 11 Old 07-01-2011, 01:56 PM Thread Starter
source69er
Registered User
 
Join Date: Jun 2011
Location: Calgary
Posts: 10
And would this MAP sensor be under the big POWER TECH box?
source69er is offline  
post #6 of 11 Old 07-01-2011, 04:38 PM
Buddha_Kip
Registered User
 
Buddha_Kip's Avatar
2000 WJ 
 
Join Date: Aug 2003
Location: N'awlins
Posts: 1,098
check your PM's.

It kinda is.

2000 WJ Limited - 2.5" Rusty's springs WAAG 1-piece front brush guard custom built WAAG nerf bars PIAA 580 lighting Custom Paint One-off Aluminum Treadplate Door Entry Guards & Rear Bumper Step
1986.5 Porsche 928S - 18" Moda MD1 Autothority Chips Rear Muffler Bypass Short-Shift Kit
Grease Monkey & HNIC @ Clasik Auto
Buddha_Kip is offline  
post #7 of 11 Old 07-06-2011, 04:14 PM
reeldagg
Registered User
 
Join Date: Jul 2011
Location: Auckland
Posts: 4
P0108 - Map sensor

Hello - I posted this on another thread related to the same problem. I've over the last eight months had similar P0108 issues, here is the info I posted on the other thread...

I've had the same issue(s) with my 99 Jeep Grand Cherokee 4.7L. I had the wiring redone for the MAP sensor, the problem returned, replaced the sensor - still no joy. I suspect my problems are/were not related to the sensor, but the catalytic converter being blocked - so I've just replaced the cat. So far I have driven about 500km without any of the issues returning (will let you know if they do). I reckon if I get to about 1500km driving without this P0108 happening I can say the problem is solved.

This is what I was experiencing
- Stalls while driving (just stopping dead - this was happening once or twice every 500km)
- Slight surging at idle between 500rpm and 1000 rpm
- Sudden shudder on open road while driving at 100kmph occasionally
- Regular P0108 (happening 3-4 times every 500km)

What made me think it was a blocked cat ?
- Stalling is one of the symptoms
- I'd fixed the MAP sensor and I didn't/don't want to believe it was the PCM.
- Surging.
- Fuel economy had gone from 12.8 - 13.0L per 100km to 13.4 - 13.8L (i do a bit of straight line travelling)
- Slight loss of power. It was kind of hard to to say whether it was real or imagined, but I have noticed the difference now when driving up hills in cruise control.
- The car has done 200,000 km and cats do wear out over time apparently.
- When starting up cold you could hear a bit of a hiss from the exhaust under the car that wasn't there when the car was warm, cats apparently warm up and expand to allow the gas to pass through. If your cat is getting blocked you might notice this sort of noise.

Anyway that is my story - hopefully I have solved my problem and maybe helped with yours, otherwise I am steering down the barrel of a new PCM which I am not very excited about.

Last edited by reeldagg; 07-06-2011 at 04:56 PM.
reeldagg is offline  
post #8 of 11 Old 07-06-2011, 06:07 PM
rm2001wj
Registered User
 
rm2001wj's Avatar
2001 WJ 
 
Join Date: Aug 2005
Location: Memphis, TN
Posts: 3,228
Thanks Buddha_Kip. Those test procedures are very useful.
rm2001wj is offline  
post #9 of 11 Old 07-08-2011, 06:07 AM
reeldagg
Registered User
 
Join Date: Jul 2011
Location: Auckland
Posts: 4
Yeah got to 586.4 km and the cursed $#%^ P0108 returned. Disregard all the rubbish I have spouted earlier. Looks Like I'm headed for a new PCM. Next time I'm buying Japanese. I've had no end of issues with this F$%#@ Jeep I've had enough.
reeldagg is offline  
post #10 of 11 Old 07-08-2011, 12:24 PM
Buddha_Kip
Registered User
 
Buddha_Kip's Avatar
2000 WJ 
 
Join Date: Aug 2003
Location: N'awlins
Posts: 1,098
Welcome to the world of Chrysler vehicles! Excellent vehicles as long as you don't mind rewiring the vehicle from time to time and swapping out all of the modules.

2000 WJ Limited - 2.5" Rusty's springs WAAG 1-piece front brush guard custom built WAAG nerf bars PIAA 580 lighting Custom Paint One-off Aluminum Treadplate Door Entry Guards & Rear Bumper Step
1986.5 Porsche 928S - 18" Moda MD1 Autothority Chips Rear Muffler Bypass Short-Shift Kit
Grease Monkey & HNIC @ Clasik Auto
Buddha_Kip is offline  
post #11 of 11 Old 01-30-2014, 04:27 PM
Floridajeepcher
Registered User
1998 WJ 
 
Join Date: Jan 2014
Location: Tallahassee
Posts: 17
Ever find the problem?
Floridajeepcher is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Check engine light cor-32 WJ Grand Cherokee Forum 22 05-02-2011 05:11 PM
Check engine light comes on....then goes off after a day. robertwhall WJ Grand Cherokee Forum 9 02-16-2011 08:46 PM
oil randomly low and check engine light. kingplay334 WJ Grand Cherokee Forum 11 12-20-2010 06:14 PM
check engine light fscott4 WJ Grand Cherokee Forum 2 09-13-2010 09:40 AM
Check Engine Light Flashing ClayTompkins WJ Grand Cherokee Forum 1 03-11-2004 02:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome