A/C Vents change to defrost when..... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > A/C Vents change to defrost when.....

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 07-29-2013, 10:54 PM   #1
grussell
Registered User
2001 WJ 
 
Join Date: May 2013
Location: Longmont, CO
Posts: 362
A/C Vents change to defrost when.....

I accelerate. Changes back to vents cruising at a steady speed or at idol. Push the pedal down for fairly quick acceleration and the vents stop and defroster blows. Probably a vacuum leak somewhere, but has anyone had this issue?

__________________
2001 GC Laredo 4x4 Black
New 4.0 @ 149
grussell is offline   Reply With Quote
Unread 07-30-2013, 02:52 AM   #2
js12278
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Springfield, Illinois
Posts: 434
many have had the issue. Vacuum leak somewhere.
js12278 is offline   Reply With Quote
Unread 08-01-2013, 06:54 PM   #3
mycreativename
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Amherst, NY
Posts: 1,944
Have the same issue, just learned to live with it cause I don't feel like chasing down a possible leak.
__________________
99' WJ, 2.5" Rusty's, Bilstein 5100's, JKS TrackBar, Moog SuperTrailBoss
"With enough fabbing, time & $, it's certainly possible.
That being said, it's like boinkin' your sister...just because you can, doesn't mean you should." - Double E
mycreativename is offline   Reply With Quote
Unread 08-01-2013, 08:04 PM   #4
doityourselfMM
Senior Member
 
doityourselfMM's Avatar
1999 WJ 
 
Join Date: Dec 2010
Location: manassas, va
Posts: 748
Try a 'Search' for vacuum or vacuum leak.
doityourselfMM is offline   Reply With Quote
Unread 08-01-2013, 09:43 PM   #5
joeisalsocool
Registered User
2004 WJ 
 
Join Date: Oct 2012
Location: Mattydale, New York
Posts: 49
Mine was at the check valve, right next to the intake manifold. The valve itself was fine, but the hose connections were slightly loose. Wrapped it in electrical tape, good to go.
joeisalsocool is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.