A/C problems...need Help as search engine doesnt work ....!!! - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > A/C problems...need Help as search engine doesnt work ....!!!

Ruffstuff XJ Unirail Channel Reinforcement....Even Better Heim Pricing! From RuffstuffUSA Standard Chromoly Front Axle Shaft Kits with Dana 30 4

Reply
Unread 06-18-2013, 05:02 PM   #16
338WinMag
Registered User
2001 WJ 
 
Join Date: Nov 2009
Location: Campbellton, New Brunswick
Posts: 84
I called at the '' Stealership '' .... and juste to evac and pressure test was 125$ plus tax and gods know how much it was for the freon...

so now I know why they call them STEALERSHIP ....

shisshh

338WinMag is offline   Reply With Quote Quick reply to this message
Unread 06-21-2013, 09:23 PM   #17
338WinMag
Registered User
2001 WJ 
 
Join Date: Nov 2009
Location: Campbellton, New Brunswick
Posts: 84
here is something thats funny...

when i have AC on at the recycle cycle... when i go over 1800rpm the AC only blow on top of the vent for the windsheild... not at the feet , not at the front and side vents...

anyone had this problem ???
338WinMag is offline   Reply With Quote Quick reply to this message
Unread 06-22-2013, 08:03 AM   #18
js12278
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Springfield, Illinois
Posts: 457
Any trouble with cruise control? Sounds like a possible vacuum leak. Check all lines in engine compartment.
js12278 is offline   Reply With Quote Quick reply to this message
Unread 06-22-2013, 08:15 AM   #19
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,839
I was thinking as well. Two things you can do. Check the vacuum line coming into the HVAC controls is in deed holding vacuum, and make sure the connector that goes to the HVAC controls are seated fully and properly.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote Quick reply to this message
Unread 06-22-2013, 11:13 AM   #20
338WinMag
Registered User
2001 WJ 
 
Join Date: Nov 2009
Location: Campbellton, New Brunswick
Posts: 84
nope cruise work good ... any pictures of which lines i have to check... the ac shop did a test of i had leak is it the same lines he check ?
338WinMag is offline   Reply With Quote Quick reply to this message
Unread 06-22-2013, 08:27 PM   #21
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,839
If you pull off the lower bezel and upper bezel around the radio, you'll be left with the HVAC controls, which are held in by 4 screws. You can take the screws out, and pull the unit out. The settings where it blows is done by way of vacuum lines. Most issues with that are due to if it's taken out and disconnected, and not seated right putting it back on, can give problems. There's one main feed line to it, black I think, which goes to it through the firewall. I've seen on vehicles where that can be an issue if there's a vacuum leak happening. May not be the issue, but good place to start. Then work your way from there.

I'm thinking it sounds like as the motor is creating more of a vacuum at higher RPM's, it's causing to leak somehow, maybe a small hole or crack, which then causes a vacuum loss and then everything goes through the defrost, which is the default, as without vacuum, whatever setting you want will now not work.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote Quick reply to this message
Unread 06-22-2013, 10:49 PM   #22
338WinMag
Registered User
2001 WJ 
 
Join Date: Nov 2009
Location: Campbellton, New Brunswick
Posts: 84
thanks for the détails ... its greatly appreciated

the radio was changed maybe they pull something ... will keep you guys posted
338WinMag is offline   Reply With Quote Quick reply to this message
Unread 06-23-2013, 02:15 AM   #23
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,839
Anythings possible. Just carefully inspect and see if you seen anything obvious or that the connector to the selector switch is off. I had an issue with mine only doing defrost and no cruise when I first got it. Someone had the the little vavle thingy under the hood on backwards so wasn't pulling a vacuum at all.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote Quick reply to this message
Unread 07-06-2013, 07:45 PM   #24
robby65
Registered User
2007 XK Commander 
 
Join Date: Apr 2011
Location: nyc, ny
Posts: 217
Quote:
Originally Posted by 338WinMag View Post
here is something thats funny...

when i have AC on at the recycle cycle... when i go over 1800rpm the AC only blow on top of the vent for the windsheild... not at the feet , not at the front and side vents...

anyone had this problem ???
Mine did the same thing and my cruise control worked.
By the passenger headlight/battery tray there was a dried out cracked vacuum hose, repaired it and all is well.
robby65 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.