A/C Head Units - Intermittent Problem - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 25 Old 05-06-2013, 10:34 AM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
A/C Head Units - Intermittent Problem

My original a/c head unit started suddenly blowing hot air out passenger side at the end of last summer- after everything under the dash and under the good had been replaced.

Jeep dealer suggested it was an error in the head unit so I bought one ($700). Then the heat of summer ended. Last week with temps creeping back up (and a/c being used for cold again) the problem started reoccurin. A repalcement was installed under warrantee. The dealer now


Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
Sponsored Links
Advertisement
 
post #2 of 25 Old 05-06-2013, 10:37 AM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
Edit....


The new unit now also starts occasionally blowing out hot air out passenger side. So they have another replacement on order. Service manager suggests it isn't that uncommon and may take time to find one that works right.

Anyone else had this problem?

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
post #3 of 25 Old 05-06-2013, 06:14 PM
lazyWJ
Registered User
2006 XK Commander 
 
Join Date: Feb 2013
Location: halifax
Posts: 828
Have you checked for fault codes? Even though "everything under the dash is good and has been replaced", I'd suspect a split actuator drive.

2004 Imola BMW ZHP
2006 Commander Limited Hemi QD2
"Bought, Not Built"
lazyWJ is offline  
post #4 of 25 Old 05-06-2013, 07:16 PM
car5car
Registered User
2002 M-38 
 
Join Date: Apr 2007
Location: Florida
Posts: 735
I repaired 2 WJs blend doors, paid 0 for parts.

01 XJ 2wd 4.0
car5car is offline  
post #5 of 25 Old 05-06-2013, 08:33 PM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
I wish all I'd done was the blendorstore new door system . That was the beginning. I have new actuator motors as well. Except for blend doors, its all Jeep OEM updated parts.

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
post #6 of 25 Old 05-06-2013, 09:24 PM
car5car
Registered User
2002 M-38 
 
Join Date: Apr 2007
Location: Florida
Posts: 735
There is no reason to replace front motor. Single door, that is way to go! Who cares about passenger? You are the boss!

01 XJ 2wd 4.0
car5car is offline  
post #7 of 25 Old 05-22-2013, 11:09 AM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
Wow, third new head unit now also is intermittently blowing 125F air out passenger side.

Is there a conversion to single door system out there?

This sucks. Thankfully all done under warrantee.

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
post #8 of 25 Old 05-22-2013, 11:39 AM
Schlotzky
Registered User
2007 XK Commander 
 
Join Date: Aug 2012
Location: Auburn
Posts: 961
Quote:
Originally Posted by leadsled jeep View Post
Is there a conversion to single door system out there?

Dorman 902-320
Schlotzky is offline  
post #9 of 25 Old 05-28-2013, 11:49 AM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
Update- under dash fan connector/wiring burned up. I thought I'd replaced everything under the dash!

LOL I was wrong. Now have a new fan and new wiring. I don't suspect this is related to the hot air out passenger side only ... But with this crazy high tech wiring, who knows.

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
post #10 of 25 Old 07-16-2013, 08:13 PM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
Fourth head unit going in this week need warrantee. Still intermittently blowing hot air out pass side vent. Even with new blend door motors.

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
post #11 of 25 Old 07-16-2013, 08:51 PM
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati
Posts: 3,139
Quote:
Originally Posted by leadsled jeep View Post
Fourth head unit going in this week need warrantee. Still intermittently blowing hot air out pass side vent. Even with new blend door motors.
See next post first. Then come back to this post.

If you have replaced the blend doors, you should be able to take the covers back off of the HVAC box and watch the blend doors recalibrate. If I were you, I would first pull both battery cables, clean them up good and shiny, then re-attach them good and tight. This alone might reset your hot air problem. Check to see if you re getting cold air after you re-connect the battery cables.
If not, then, remove the glove box, remove driver's actuator motor, take off the HVAC (silver) tape and remove outside and inside covers. Turn your key to on and watch both doors. They should both open and close. If not, then you either have a broken actuator or blend door shaft. That's my guess.

Sent from my iPad using Forum Runner
rdkendrick is offline  
post #12 of 25 Old 07-16-2013, 08:58 PM
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati
Posts: 3,139
Quote:
Originally Posted by leadsled jeep View Post
Edit....

The new unit now also starts occasionally blowing out hot air out passenger side. So they have another replacement on order. Service manager suggests it isn't that uncommon and may take time to find one that works right.

Anyone else had this problem?
If it is a dual zone climate control, did you run the run the AZC self diagnostic?
http://www.wjjeeps.com/climate.htm
Run that to pin-point which side it is. Maybe I should have said to run this BEFORE you tear into the HVAC box.

Sent from my iPad using Forum Runner
rdkendrick is offline  
post #13 of 25 Old 07-17-2013, 06:31 AM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
Thanks for your kind suggestions.


I have replaced the HVAC box, recirc box, Blendor store new doors with the dash out version as it was all apart. All actuators replaced.... Everything ac replaced under the dash and good even! She's been in the dealer many times trying to find/ fix this.

Very intermittent problem. I even was able once to bring to dealer while blowing hot and they scoped it to see doors move and hooked up to their computer.

Jeep tech support at factory keeps saying its the head unit. Go figure. So far I've not heard of anyone else having this prob. Only Jeep OEM parts not used are Blendor parts. Now I wish I'd just dropped it off at dealer and had them do all the work with all OEM parts. Oh well...

8-(

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
post #14 of 25 Old 07-17-2013, 10:02 AM
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati
Posts: 3,139
Quote:
Originally Posted by leadsled jeep View Post
Thanks for your kind suggestions.

I have replaced the HVAC box, recirc box, Blendor store new doors with the dash out version as it was all apart. All actuators replaced.... Everything ac replaced under the dash and good even! She's been in the dealer many times trying to find/ fix this.

Very intermittent problem. I even was able once to bring to dealer while blowing hot and they scoped it to see doors move and hooked up to their computer.

Jeep tech support at factory keeps saying its the head unit. Go figure. So far I've not heard of anyone else having this prob. Only Jeep OEM parts not used are Blendor parts. Now I wish I'd just dropped it off at dealer and had them do all the work with all OEM parts. Oh well...

8-(
"Service manager suggests it isn't that uncommon and may take time to find one that works right."

At $700 a piece, I'd be disinclined to believe him. I'd find one at a junk yard and try it. Most every time I have heard of a problem with one side blowing hot when it should be cold, or vice versa, it's always been a blend door, or just mixed up electronics that is fixed by a power reset. If you are mechanically incline, I would say to cut open the HVAC box and take a look at the doors, for yourself. I think the stealership is taking you for a ride, no offense intended to you. If you do cut open the box, be careful to follow instructions, as it is possible to accidentally cut your heater core. Have you watched YouTube videos on how to do it? Should only just have to search for "replace blend doors on Jeep Grand Cherokee" and there will be several videos. It's not hard to do, just a little squirrelly trying to work through the glove box. Even with the hot weather, I'd put it in the shade and work on it. It'll save you lots of $$$.

Sent from my iPad using Forum Runner
rdkendrick is offline  
post #15 of 25 Old 07-17-2013, 01:15 PM Thread Starter
leadsled jeep
Registered User
2002 WJ 
 
Join Date: Sep 2006
Location: TriCities
Posts: 1,524
Thanks again.

I've done a thru the glove compartment Blendor job on my father in laws WJ. I know that's a piece of cake for sure. On mine since I had dash out we did it without cutting.

Thankfully my head units are still covered under the first $700 warrantee.

It's an intermittent issue unfortunately, with no predictability also!

Local service guys also say its not uncommon to have bad head units. But they are saying having three (4 counting original) in a row bad is quite odd. It's nice to get your confirmation from your service manager. I assume you aren't in TN are you?? LOL!

Chris
'02 Overland 176k+ miles. 2.5" lift, EMF Control Arm upgrades
leadsled jeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome