JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   WJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f310/)
-   -   Blue devil head gasket sealer (http://www.jeepforum.com/forum/f310/blue-devil-head-gasket-sealer-1524870/)

javis4x4 05-17-2013 09:30 PM

Blue devil head gasket sealer
 
I blew my head gasket on my 4.7 today cause
I seen coolant coming out my muffler. I read about a product called blue devil and people say it works has anyone ever used this before and work for them.

javis4x4 05-17-2013 09:32 PM

Sorry about the double post.

Idano12 05-17-2013 09:51 PM

To the best of my knowledge, there is no magical fix for a blown head gasket. Unless you had a faulty head gasket,(which would mean you just have to replace said gasket), you probably have a warped or cracked head that caused the blown gasket. Your only course of action is to find out what caused the gasket to fail and fix said problem. Sorry to deliver bad news.

dillonjm 05-17-2013 10:23 PM

^^this

If you really have a blown gasket, you need to pull the heads, replace the gaskets and have the heads checked for cracks/warpage.

Pouring a can of gunk into your cooling system is only going to cause more damage.

javis4x4 05-17-2013 10:49 PM

Funny thing is that my jeep just got some rebuilt head, new head gasket , all the timing chain Guide's, water pump, radiator and seals and now it's failing.

dillonjm 05-18-2013 07:24 AM

You should take it back to who did the work then.

Why are you trying to ghetto patch it if someone just replaced it all?

wvracer821 05-18-2013 07:32 AM

i used it on a 300$ pontiac sunfire that i had a few years ago. I ended up junking the car 2 weeks later. if you plan on keeping your jeep do it the right way.

lazyWJ 05-18-2013 07:36 AM

You sure it wasn't just water coming out of your tailpipe? Can you go into detail what your symptoms are?

javis4x4 05-18-2013 08:28 AM

Well I did the work my self and did everything by the book. And I'm sure it wasn't just water it was coolant cause I was that neon green color.

javis4x4 05-18-2013 08:39 AM

Quote:

Originally Posted by javis4x4
Well I did the work my self and did everything by the book. And I'm sure it wasn't just water it was coolant cause I was that neon green color.

And the only thing it's doing is blowing out a lot of steam and dripping the coolant right where the pipes meet by transmission support.

WJ4x4LIFE 05-18-2013 09:06 AM

How about you do a compression test and cylinder leak-down test before anything else...

javis4x4 05-18-2013 09:16 AM

But that's cause I don't have the tools to do it and I my self don't know how to perform a test like that.

lazyWJ 05-18-2013 09:49 AM

HG on a 4.7 isn't small job. I'm not trying to be a jerk, but if you don't know what those tests are, you may have gotten in over your head doing the job yourself. You really need to be able to perform those tests to fully diagnose the problem, although it sounds like a safe bet that it will need to be done again. Did you check the heads before you changed the gasket? What prompted you to change the gasket the first time (same symptoms or different)?

WJ4x4LIFE 05-18-2013 10:43 AM

Quote:

Originally Posted by javis4x4 (Post 15448846)
But that's cause I don't have the tools to do it and I my self don't know how to perform a test like that.


Agreed, with the statement above as your seemed to be an "immediate" with your mechanical skills.

I will help a little with these tests.

#1 "Compression Test"

* Simplest Test *

http://www.lislecorp.com/divisions/products/?product=75

#2 "Leak-Down Test"

* Simplest Test * = DIY friendly as possible...

http://www.lislecorp.com/divisions/p...s/?product=406

-----------------------------------

Also you seem to be in the DFW! Hope to see you around....

javis4x4 05-18-2013 11:47 AM

ok the motor in my 01 wj came out of my other 00 wj that i rolled, now when the motor was in my other wj the motor was putting some gunk in my
radiator so since i was pulling the moter out i fugure ill go ahead and fix it up so it goes in with no problems. so when i started to rip it apart i found that the heads where in bad condition, so i went and got some rebuilt ones for about 500 buck. when i put the motor back together with all the new parts, the motor was having trouble stabalizing and was blowing my ASD fuse. so i took the jeep to a shop and they could not find the problem(was there for a month) and said it was electical, so i then took it to and electric shop (was there for 3wks) and nothing the guy did not figure it out. By that time it had been 2 months that my jeep was out of sevice and was starting to get fustrated. i then checked my dip stick and there it was ! the water and oil where mixing. the dumb *** mechanic did not check my Jeep right. when i disassemble the motor again i found water in my cylinders. i took the heads back to the head shop and they told me the heads where warped and that it was MY FAULT but the jeep hadent been moved at all plus the motor want staying on the first place for me to over heat it. long story short, so they resurfaced the heads for 20 extra bucks apart that i had already paid 500 buckd for them, i put them back on, finished puthing the motor back to gethere and it had been running fine for a week and not here i am. sorry i wrote so much.


The time now is 01:17 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.