Bad gas mileage - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 10-21-2013, 06:41 PM Thread Starter
Grndcherokeewj
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: St clair shores
Posts: 69
Wj Bad gas mileage

Im am getting 8.3 mpg in my 2000 jeep grand cherokee
No codes or vheck engine light, rotella t5 every 4k miles. Runs great bad gas mileage

Grndcherokeewj is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-21-2013, 09:03 PM
Moochs4x4
Registered User
 
Join Date: Feb 2013
Location: Long island
Posts: 13
New plugs, air filter, diff fluids, belt, thermostat and check/clean/replace sensors, adjust tire pressure. After that I'd say its almost 14 years old and still on the road so good job.
Moochs4x4 is offline  
post #3 of 6 Old 10-21-2013, 09:55 PM Thread Starter
Grndcherokeewj
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: St clair shores
Posts: 69
New plugs are in new filter, has diff fulid in, no codes are on the computer its really wierd but my gas mileage is terrible
Grndcherokeewj is offline  
post #4 of 6 Old 10-21-2013, 09:55 PM Thread Starter
Grndcherokeewj
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: St clair shores
Posts: 69
It really is at like 8 mpg
Grndcherokeewj is offline  
post #5 of 6 Old 10-23-2013, 02:02 PM
rockyrivermark
Registered User
2002 WJ 
 
Join Date: Mar 2012
Location: Fairview
Posts: 100
mine is going through that right now. came out of no where. I hear possible inflow o2 sensor. Even if it doesn't throw a code. other possibilities were coils from what I read. make sure to only put copper plugs in. I guess the 4.0's don't run well on platinum or others.
rockyrivermark is offline  
post #6 of 6 Old 10-25-2013, 09:57 AM Thread Starter
Grndcherokeewj
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: St clair shores
Posts: 69
Okay well i put in double platinums and i have 2 bosch o2 sensors in it could this be the cause of my problem?
Grndcherokeewj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome