Another Bloody Problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Another Bloody Problem

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 03-14-2014, 01:04 PM   #1
bobknott
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Ringwood, Hampshire
Posts: 113
Another Bloody Problem

Okay guys & gals. I have lost my electrics on the drivers door. No electric windows on any door, no courtesy light on the drivers door, no mirror control & the drivers door won't lock on the remote. At the same time the car heater is only blowing cold air regardless of setting. I don't know if door & heater are related but would love to hear some suggestions

bobknott is offline   Reply With Quote
Unread 03-15-2014, 09:09 AM   #2
bobknott
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Ringwood, Hampshire
Posts: 113
So I have disconnected the battery, waited 30mins & reconnected.

Heater now pumps out heat, but now wont adjust down. Courtesy lights working now. All other faults remain.

Have disconnected battery again & I'm cleaning the connections from body to door with contact cleaner. Will reassemble connector before reconnecting battery.

Here's hoping.
bobknott is offline   Reply With Quote
Unread 03-15-2014, 09:51 AM   #3
its-me-B
Registered User
2002 WJ 
 
Join Date: Jul 2012
Location: milwaukee, wi
Posts: 613
check the wiring going into the drivers door, the ground wire tends to break and cause lose of windows/lock ect... pop the boot offone end and peak around the wire to look for any cracks or breaks.
__________________
Do the world a favor, hurt a honda...
Iro 3" lift with pro comp 9000es shocks, adjustable trackbar, led rock lights, all interior lights converted to leds, two 10" kicker comp with Kenwood 600 watt amp
Zombie Outbreak Response Unit #396
its-me-B is offline   Reply With Quote
Unread 03-15-2014, 10:01 AM   #4
bobknott
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Ringwood, Hampshire
Posts: 113
Found a broken black in cable going to the door. About to fix that. Best of all now the aircon now blows cold when set to hi & hot when set to low!!! FFS!!
bobknott is offline   Reply With Quote
Unread 03-15-2014, 11:06 AM   #5
its-me-B
Registered User
2002 WJ 
 
Join Date: Jul 2012
Location: milwaukee, wi
Posts: 613
the black one is the ground to all the drivers door controls. i just fixed mine a few weeks back should be simple and quick. hopefully that will help with some of the issues...
__________________
Do the world a favor, hurt a honda...
Iro 3" lift with pro comp 9000es shocks, adjustable trackbar, led rock lights, all interior lights converted to leds, two 10" kicker comp with Kenwood 600 watt amp
Zombie Outbreak Response Unit #396
its-me-B is offline   Reply With Quote
Unread 03-15-2014, 12:39 PM   #6
bobknott
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Ringwood, Hampshire
Posts: 113
Well I've mended the wire but there is a contact problem in the connector itself. Enough for today. I will carry on tomorrow.

Still can't get my head around the aircon reversing it's settings though
bobknott is offline   Reply With Quote
Unread 03-16-2014, 01:38 PM   #7
bobknott
Registered User
2001 WJ 
 
Join Date: Aug 2011
Location: Ringwood, Hampshire
Posts: 113
So final chapter. I found the orange cable broken as well as the black. So I replaced this too but still windows & door lights refused to work. Before I went any deeper by cutting off the boot around the cables to inspect if further, I decided to disconnect the battery & leave for 30 mins. Low & behold when I reconnected everything booted up & works fine.

Lessons learnt = Orange & black door cables are very vulnerable but more importantly reset the on board electronics by disconnecting the battery for at least 15 mins before going any further into fault finding.
bobknott is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.