Air bag light on. Diagnose? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Air bag light on. Diagnose?

Ledlight bar light locks @ oconee off road 706 534 9955Don't forget the Jeep Forum discount, 10% off!The Original 3/8" Ruffstuff Diff Cover!

Reply
Unread 10-11-2011, 02:54 PM   #1
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
Air bag light on. Diagnose?

Anyway to diagnose this without paying the dealer ? It's ALWAYS on, doesn't matter if you turn the wheel or have the seat belts buckled in or not. Or if anyone knows how to reset it for the time being.

__________________
98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline   Reply With Quote
Unread 10-11-2011, 03:18 PM   #2
orb
Registered User
2003 WJ 
 
Join Date: Dec 2010
Location: Denver, Colorado
Posts: 259
You can reset it by taking off the negative battery connection but it will come back if there is really something wrong.
__________________
2003 4.0L, OME HD Springs, OME Nitro Shocks, Rancho SS, 265/70R16 General Grabber AT2s
orb is offline   Reply With Quote
Unread 10-11-2011, 03:21 PM   #3
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
I just had it off a few days ago when I changed out the pcm. Is there a proper procedure for doing this?
__________________
98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline   Reply With Quote
Unread 10-11-2011, 03:26 PM   #4
orb
Registered User
2003 WJ 
 
Join Date: Dec 2010
Location: Denver, Colorado
Posts: 259
Maybe it's only for CEL lights and not airbag? Does it have a code associated with it? Try this and see what it says:

Quote:
Originally Posted by wjjeeps.com
Retrieving codes:

Turn the ignition key until the digital odometer displays, repeat three times in succession and then back to "On" (On/Off, On/Off, On/Off, On). At the fourth "On" the odometer will be replaced with codes. If no codes are present then "Done" will appear.
I left my neg terminal disconnected for about 20 minutes and that cleared my code after I fixed the issue. I think the proper way would be use an OBDII to clear it but then again, maybe it only for CEL like I mentioned above.
__________________
2003 4.0L, OME HD Springs, OME Nitro Shocks, Rancho SS, 265/70R16 General Grabber AT2s
orb is offline   Reply With Quote
Unread 10-11-2011, 03:43 PM   #5
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
I'm 90% sure the code scanner is only for obd2 codes, I'll plug in my scanner tonight, But I have tried the key method and it says done. No codes are present.
__________________
98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline   Reply With Quote
Unread 10-11-2011, 04:10 PM   #6
GrandAZ
Registered User
 
Join Date: May 2011
Posts: 198
The clockspring is most likely the culprit of this...

http://www.amazon.com/Dorman-525-108-Clock-Spring/dp/B003GAQ2VM/ref=au_pf_pfg_s?ie=UTF8&Model=Grand%20Cherokee|349&n=15684181&s=automotive&Make=Jeep|42&Year=2000|2000&newCar=1&carId=001
GrandAZ is offline   Reply With Quote
Unread 10-11-2011, 08:26 PM   #7
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
Damn it, I'm a dummy. Last week I was looking at the fuses and pulled the one for the airbag (one with the big yellow piece) and didn't put it in all the way. Doh!
__________________
98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline   Reply With Quote
Unread 10-11-2011, 10:27 PM   #8
MeanGreenZJ
Web Wheeler
 
Join Date: Apr 2011
Location: Mean Street in a desperate part of town
Posts: 1,710
You saved yourself some money and work by not throwing a clockspring at it like most people do.
MeanGreenZJ is offline   Reply With Quote
Unread 10-11-2011, 10:31 PM   #9
jomps
Registered User
 
Join Date: Aug 2009
Location: tennessee
Posts: 195
nice catch...i really got something wrong with mine...
jomps is offline   Reply With Quote
Unread 10-11-2011, 10:41 PM   #10
mtb_crzd47
Registered User
2000 WJ 
 
Join Date: Aug 2008
Location: Loveland, CO
Posts: 594
Sorry to hijack but if the light is on but cruise and horn still work is it the clock spring or somethin else? I searched and didn't find a definite answer and didn't want to start a new thread to have 48395 people tell me to search.

Sent by your mother via my Garminfone
__________________
2000 WJ LTD Shale Green metallic, stock for now
2007 Yeti AS-X, Avid Code 5's Rockshox Totem,
SOLD: 91 XJ
mtb_crzd47 is offline   Reply With Quote
Unread 10-11-2011, 10:42 PM   #11
jomps
Registered User
 
Join Date: Aug 2009
Location: tennessee
Posts: 195
id like to know that too
jomps is offline   Reply With Quote
Unread 10-11-2011, 11:08 PM   #12
GrandAZ
Registered User
 
Join Date: May 2011
Posts: 198
My light is on but both cruise and horn still work and I've been told it is still the clock spring ......
GrandAZ is offline   Reply With Quote
Unread 10-12-2011, 11:41 AM   #13
jomps
Registered User
 
Join Date: Aug 2009
Location: tennessee
Posts: 195
thats what im thinking but have problems greater than that right now
jomps is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.