Air bag light on. Diagnose? - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 17 Old 10-11-2011, 02:54 PM Thread Starter
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
Air bag light on. Diagnose?

Anyway to diagnose this without paying the dealer ? It's ALWAYS on, doesn't matter if you turn the wheel or have the seat belts buckled in or not. Or if anyone knows how to reset it for the time being.


98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 10-11-2011, 03:18 PM
orb
Registered User
2003 WJ 
 
Join Date: Dec 2010
Location: Denver
Posts: 259
You can reset it by taking off the negative battery connection but it will come back if there is really something wrong.

2003 4.0L, OME HD Springs, OME Nitro Shocks, Rancho SS, 265/70R16 General Grabber AT2s
orb is offline  
post #3 of 17 Old 10-11-2011, 03:21 PM Thread Starter
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
I just had it off a few days ago when I changed out the pcm. Is there a proper procedure for doing this?

98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline  
post #4 of 17 Old 10-11-2011, 03:26 PM
orb
Registered User
2003 WJ 
 
Join Date: Dec 2010
Location: Denver
Posts: 259
Maybe it's only for CEL lights and not airbag? Does it have a code associated with it? Try this and see what it says:

Quote:
Originally Posted by wjjeeps.com
Retrieving codes:

Turn the ignition key until the digital odometer displays, repeat three times in succession and then back to "On" (On/Off, On/Off, On/Off, On). At the fourth "On" the odometer will be replaced with codes. If no codes are present then "Done" will appear.
I left my neg terminal disconnected for about 20 minutes and that cleared my code after I fixed the issue. I think the proper way would be use an OBDII to clear it but then again, maybe it only for CEL like I mentioned above.

2003 4.0L, OME HD Springs, OME Nitro Shocks, Rancho SS, 265/70R16 General Grabber AT2s
orb is offline  
post #5 of 17 Old 10-11-2011, 03:43 PM Thread Starter
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
I'm 90% sure the code scanner is only for obd2 codes, I'll plug in my scanner tonight, But I have tried the key method and it says done. No codes are present.

98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline  
post #6 of 17 Old 10-11-2011, 04:10 PM
GrandAZ
Registered User
 
Join Date: May 2011
Posts: 198
The clockspring is most likely the culprit of this...

http://www.amazon.com/Dorman-525-108-Clock-Spring/dp/B003GAQ2VM/ref=au_pf_pfg_s?ie=UTF8&Model=Grand%20Cherokee|349&n=15684181&s=automotive&Make=Jeep|42&Year=2000|2000&newCar=1&carId=001
GrandAZ is offline  
post #7 of 17 Old 10-11-2011, 08:26 PM Thread Starter
gamble
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: chicago
Posts: 213
Damn it, I'm a dummy. Last week I was looking at the fuses and pulled the one for the airbag (one with the big yellow piece) and didn't put it in all the way. Doh!

98 ZJ -4.0L
Lots of welders and cnc table
gamble is offline  
post #8 of 17 Old 10-11-2011, 10:27 PM
MeanGreenZJ
Web Wheeler
 
Join Date: Apr 2011
Location: Mean Street in a desperate part of town
Posts: 1,710
You saved yourself some money and work by not throwing a clockspring at it like most people do.
MeanGreenZJ is offline  
post #9 of 17 Old 10-11-2011, 10:31 PM
jomps
Registered User
 
Join Date: Aug 2009
Location: tennessee
Posts: 194
nice catch...i really got something wrong with mine...
jomps is offline  
post #10 of 17 Old 10-11-2011, 10:41 PM
mtb_crzd47
Registered User
2000 WJ 
 
Join Date: Aug 2008
Location: Loveland, CO
Posts: 594
Sorry to hijack but if the light is on but cruise and horn still work is it the clock spring or somethin else? I searched and didn't find a definite answer and didn't want to start a new thread to have 48395 people tell me to search.

Sent by your mother via my Garminfone

2000 WJ LTD Shale Green metallic, stock for now
2007 Yeti AS-X, Avid Code 5's Rockshox Totem,
SOLD: 91 XJ
mtb_crzd47 is offline  
post #11 of 17 Old 10-11-2011, 10:42 PM
jomps
Registered User
 
Join Date: Aug 2009
Location: tennessee
Posts: 194
id like to know that too
jomps is offline  
post #12 of 17 Old 10-11-2011, 11:08 PM
GrandAZ
Registered User
 
Join Date: May 2011
Posts: 198
My light is on but both cruise and horn still work and I've been told it is still the clock spring ......
GrandAZ is offline  
post #13 of 17 Old 10-12-2011, 11:41 AM
jomps
Registered User
 
Join Date: Aug 2009
Location: tennessee
Posts: 194
thats what im thinking but have problems greater than that right now
jomps is offline  
post #14 of 17 Old 06-29-2015, 11:17 PM
Jalandub
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: Orem
Posts: 6
My airbag light is mostly on but with certain turns will turn off for a few seconds before dinging back on. So I figured it was the clock spring. Just switched it out and now it's permanently on. So frustrated! I got the part from a pick-a-part but I couldn't have 2 clock Springs. Universe ain't that mean right? Plus my radio controls are less glitchy now so it's gotta be a better clock spring.
Jalandub is offline  
post #15 of 17 Old 06-30-2015, 12:30 AM
Johnyre
Registered User
2002 WJ 
 
Join Date: Nov 2013
Location: Arvada
Posts: 1,300
Have y'all gotten the recall for the passenger air bag blowing up randomly

As I roll down the trail,I hope my traction will not fail.But if I spin & begin to slide,please dear lord protect my ride
https://www.facebook.com/pages/Cloud-9-Crawlers/129955857071110
http://fortcollinswheelers.com
Johnyre is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
ok i have the typical 4.7 tick, can't diagnose it! 04ovrland WJ Grand Cherokee Forum 17 01-25-2016 12:47 PM
Help Diagnose Problem... jasandalb WJ Grand Cherokee Forum 4 02-25-2011 02:50 PM
Oil pan is off, how to diagnose engine noise? MNWJ WJ Grand Cherokee Forum 9 01-28-2011 08:04 PM
Help me diagnose a rattle/clunk RobertTF WJ Grand Cherokee Forum 3 01-13-2011 11:17 PM
can anyone help me diagnose an ignition problem? woogie WJ Grand Cherokee Forum 7 10-28-2010 11:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome