Air Bag Light -

LinkBack Thread Tools
post #1 of 4 Old 10-28-2013, 09:58 AM Thread Starter
Registered User
1999 WJ 
Join Date: Oct 2013
Location: Point Pleasant Beach
Posts: 24
Wj Air Bag Light

Just bought my 1999 WJ a few weeks ago and now I found out that my Air Bag light has just turned on as well as a check engine light. Figured the engine light was just for an O2 sensor but the Air bag light is worrying me. I am hoping it is a easy fix as my car is due for inspection. The driver seat has a broken mounting bracket and my seat rocks like crazy when Im driving also there is a loose sensor underneath my seat. Could either of these be the cause to the air bag light being on?

jonw8192 is offline  
Sponsored Links
post #2 of 4 Old 10-28-2013, 10:37 AM
Registered User
Join Date: Jul 2012
Posts: 50
Check the fuse(s) under the dash. My air bag light was on because the fuses had massive corrosion on them, but was not blown. The two fuses live in a yellow contraption on the right hand side of the fuse box Cleaned the fuses off, now no air bag light!

Hope this helps!
seymourless is offline  
post #3 of 4 Old 10-28-2013, 11:03 AM
Registered User
2002 WJ 
Join Date: Jun 2008
Location: Sykesville, MD
Posts: 1,950
Can be any of these: Clock Spring, ACM (airbag control module), Front impact sensor.

2002 WJ Ltd. 4.7 V8, QuadraDrive
1973 Mercury Cougar Xr7 convertible 351CJ, C6, 9" rear
1970 Kaiser-Jeep M35A2 W/OW 6x6 Multifuel D-Turbo.

Merc1973 is offline  
post #4 of 4 Old 10-28-2013, 02:48 PM
Registered User
2003 WJ 
Join Date: Jan 2013
Location: Cincinnati
Posts: 3,150
Originally Posted by Merc1973 View Post
Can be any of these: Clock Spring, ACM (airbag control module), Front impact sensor.
Depending upon the version of ACM. The later version negates the front impact sensors.
The problem with mine I found out, AFTER I bought a scanner that reads SRS codes, and already replaced the clock spring, was somewhere in the side impact sensor circuit, there was a short. The short turned out to be in the ACM. I had the latest version (AH), but it must have gone bad. The ACM that I ordered was an ( AG), but still worked and got rid of the airbag light.
Sent from my iPad using my fingers
rdkendrick is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome