Acceleration Issue 4.0L - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Acceleration Issue 4.0L

Light up the holidays with LED lights from JeepHutIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRuffstuff Axle Simple Swap Kit!

Reply
Unread 07-16-2013, 09:33 PM   #1
Rollin
Registered User
2005 WK 
 
Join Date: Feb 2007
Location: NH
Posts: 1,242
Acceleration Issue 4.0L

I purchased this Jeep a month ago. It has 84 k miles. It has never really been a screamer out of the gate, but I feel I'm missing something. Every Jeep I have owned with the 4 liter has been able to at the very least light up the inside tire going around a corner from a stop. This Jeep cannot. It livens up after about 3500 rpm but doesnt have that signature 4.0 grunt below there.

I have adjusted the TV cable, replaced the fuel filter and there are no stored codes. What could be the issue with the vehicle?

__________________
2005 WK Limited 5.7l, QDII


Imported from Detroit
Rollin is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 02:12 PM   #2
Rollin
Registered User
2005 WK 
 
Join Date: Feb 2007
Location: NH
Posts: 1,242
bump
__________________
2005 WK Limited 5.7l, QDII


Imported from Detroit
Rollin is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 02:22 PM   #3
pinky2252s
Registered User
2001 WJ 
 
Join Date: Oct 2011
Location: Broomfield, Colorado
Posts: 1,825
Its in a heavy car.


Seriously, the 4.0 is slow in the WJ. I could never get the tires to spin in my Special Edition. The V8 will though..
__________________
Is it broken?

Colorado Jeep Club Member #2252
2001 Laredo, 2004 Special Edition
pinky2252s is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 04:07 PM   #4
CopperDeer
Registered User
1999 WJ 
 
Join Date: Jul 2013
Location: Cary, NC
Posts: 97
Yeah. My 4.0 had a ton more kick in my XJ with Select-trac (non all time 4WD) than on the heavier WJ with Quadra-Trac. Won't get out of its own way.
CopperDeer is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 05:05 PM   #5
scparrish
Registered User
1999 WJ 
 
Join Date: May 2012
Location: Keller, Texas
Posts: 97
I have the same issue it is so slow that it is almost a hazard merging with traffic
__________________
mine 04 F250 Harley FX4, 90 Bronco EB 4x4
hers 99 WJ Laredo 4x4 I6 4" IRO lift with long arms
http://www.jeepforum.com/forum/f197/scparrish-build-thread-1530728/
scparrish is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 07:52 PM   #6
pinky2252s
Registered User
2001 WJ 
 
Join Date: Oct 2011
Location: Broomfield, Colorado
Posts: 1,825
Quote:
Originally Posted by scparrish View Post
I have the same issue it is so slow that it is almost a hazard merging with traffic
Even thought the 4.0 is slow, its not that slow. You seem to have some sort of a problem.


Im not bashing the 4.0 at all, it can easily merge with the flow of traffic.
__________________
Is it broken?

Colorado Jeep Club Member #2252
2001 Laredo, 2004 Special Edition
pinky2252s is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 08:15 PM   #7
Rollin
Registered User
2005 WK 
 
Join Date: Feb 2007
Location: NH
Posts: 1,242
Mine can as well. But when you floor it from a stop, a fiesta could beat me in a race that's how bad it is
__________________
2005 WK Limited 5.7l, QDII


Imported from Detroit
Rollin is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 08:52 PM   #8
CopperDeer
Registered User
1999 WJ 
 
Join Date: Jul 2013
Location: Cary, NC
Posts: 97
Pretty sure my 70cc 2 stroke scooter is faster to 35 mph than my 4.0L WJ. Mine has old spark plugs and a head gasket leak, though.
CopperDeer is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 09:12 PM   #9
joeisalsocool
Registered User
2004 WJ 
 
Join Date: Oct 2012
Location: Mattydale, New York
Posts: 54
Thats how mine was when I bought it. Some basic maintenance will wake her right up. Diff/TC/transmission fluids, and a thorough TB cleaning. Itll be a whole new ride, I promise.
-Joe
joeisalsocool is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 09:40 PM   #10
Jaspah
Registered User
2002 WJ 
 
Join Date: Oct 2012
Location: Hamilton, NY
Posts: 249
Quote:
Originally Posted by scparrish View Post
I have the same issue it is so slow that it is almost a hazard merging with traffic
You definitely have a problem. I have never felt unsafe merging into traffic with the 4.0.
Jaspah is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 10:46 PM   #11
04dubjay
Registered User
 
Join Date: Dec 2011
Location: Islip, NY
Posts: 286
4.oh fukc this thing is slow!
__________________
2004 Columbia Edition WJ (I6/Selectrac) -{RC/Ironman4x4fab/JKS/KOR/Nitto/Carolina}
04dubjay is offline   Reply With Quote Quick reply to this message
Unread 07-17-2013, 11:04 PM   #12
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,840
Now I do have a TB and FIPK, but if I really floor it from a stop, it will go. I just don't want to spend the $ in gas to do it. Sometimes mine will feel kinda slow, but all in all, it isn't. A lighter car will be different of course. Doesn't take me very long to get to speed, nor any issues merging into traffic. On an incline, a little bit more. If it's really turtle slow from a stop, could be somethings up. One easy thing to check that can effect it, is if your transmission fluid is slow from what I've experienced. As well, using the shell v-power compared to the regular, as well makes the engine much more responsive.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 06:03 PM   #13
scparrish
Registered User
1999 WJ 
 
Join Date: May 2012
Location: Keller, Texas
Posts: 97
maybe I am making sound worse than it is but you have to use all the skinny pedal has to offer to merge it just seems excessive. I am used to driving a high hp truck though so that may be the main issue.
__________________
mine 04 F250 Harley FX4, 90 Bronco EB 4x4
hers 99 WJ Laredo 4x4 I6 4" IRO lift with long arms
http://www.jeepforum.com/forum/f197/scparrish-build-thread-1530728/
scparrish is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 06:08 PM   #14
cykaaro
Registered User
2000 WJ 
 
Join Date: Apr 2012
Location: orangville, ON
Posts: 2,840
Guess it depends on what short of distance you want to accelerate to merge to what speed you need to get up to. Should see how long it takes me to get up to speed. I've never really bothered to time it at all.
__________________
The beatings will continue until attitudes improve!

HID Quad bi-xenon + foglight retrofit
http://www.hidplanet.com/forums/showthread.php?44572-Jeep-2000-Grand-Cherokee-WJ
cykaaro is offline   Reply With Quote Quick reply to this message
Unread 07-18-2013, 06:42 PM   #15
CopperDeer
Registered User
1999 WJ 
 
Join Date: Jul 2013
Location: Cary, NC
Posts: 97
I made the mistake of towing with the 4.0 once. It wasn't horrible I guess but I was WOT just to maintain 55 mph up some of the inclines. Seemed to do OK when I used to live in the mountains, though. I couldn't fly up the hills but I didn't have to push it hard to get up even the steepest peaks at a reasonable speed. It's a great motor for regular demands and I don't notice it around town but anytime you try to push it there's not really much more for it to give.

I would still try to give it a tune up. Throttle body cleaning, spark plugs, new air filter, etc. It needs all the help it can get.
CopperDeer is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.