AC vents only blowing half the air they should - Page 4 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > AC vents only blowing half the air they should

OPTIC ARMOR WINDOWS all sale now !!!!!!!!Spartan Locker Special Forum Prices Dana 30 44 60 Ford 8.850" LED Light Bar with Overhead Mounting Brackets $69

Reply
Unread 08-24-2013, 01:25 PM   #46
scotty94
Registered User
2004 WJ 
 
Join Date: Aug 2013
Location: vansant, VA
Posts: 2
Wj

hello all...I am in a bad way...fan motor blowing hard but hardly no air coming from my 04 overland....air is cold coming out...blows just a little harder on the driver side than the passenger side...I have read a lot of things could be wrong...where should I start?...any help will be grately appreciated....my second jeep also...just got it today!!...loved it so much the first time I regreted getting rid of ol' "bossy"....

scotty94 is offline   Reply With Quote
Unread 08-24-2013, 02:45 PM   #47
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony, TX
Posts: 100
I've been having some issues with the airflow, so I crawled under my glove compartment and found the connector with the infamous reversed wires... It's already got the green wires spliced in, so I assume it had the resistor replaced sometime in the past.

I unplugged it and swapped the wires on each side, then when I plugged it back in it blew the fuse in the PDC. I ran to Autozone and picked up a couple 40A spares, as soon as I plugged the new fuse in it blew the fuse again. I swapped the wires back around, but when I plugged in the second new fuse, it also blew instantly. So now I'm stuck with no air at all.

What am I doing wrong? Little bastards are $5 each so I don't want to blow too many more...
SirCussFreq is offline   Reply With Quote
Unread 08-24-2013, 04:19 PM   #48
scotty94
Registered User
2004 WJ 
 
Join Date: Aug 2013
Location: vansant, VA
Posts: 2
well sircuss freq...I am not sure whats going on with yours...I really hope someone can help us with our problem...I found kolak on facebook and sent him a message...he is the jeep jedi...I sure hope he can use the force and get us some "force" back on our air problem issue
scotty94 is offline   Reply With Quote
Unread 08-24-2013, 06:10 PM   #49
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony, TX
Posts: 100
Bah... turns out I'm a moron and wasn't paying enough attention! I swapped the wires in the 3 wire connector, not the 2 wires that run from the controller to the blower itself. Oops. Guessing I fried the control module, hopefully that's all I messed up.
SirCussFreq is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.