AC vents only blowing half the air they should - Page 4 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #46 of 58 Old 08-24-2013, 01:25 PM
scotty94
Registered User
2004 WJ 
 
Join Date: Aug 2013
Location: vansant
Posts: 2
Wj

hello all...I am in a bad way...fan motor blowing hard but hardly no air coming from my 04 overland....air is cold coming out...blows just a little harder on the driver side than the passenger side...I have read a lot of things could be wrong...where should I start?...any help will be grately appreciated....my second jeep also...just got it today!!...loved it so much the first time I regreted getting rid of ol' "bossy"....

scotty94 is offline  
Sponsored Links
Advertisement
 
post #47 of 58 Old 08-24-2013, 02:45 PM
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony
Posts: 110
I've been having some issues with the airflow, so I crawled under my glove compartment and found the connector with the infamous reversed wires... It's already got the green wires spliced in, so I assume it had the resistor replaced sometime in the past.

I unplugged it and swapped the wires on each side, then when I plugged it back in it blew the fuse in the PDC. I ran to Autozone and picked up a couple 40A spares, as soon as I plugged the new fuse in it blew the fuse again. I swapped the wires back around, but when I plugged in the second new fuse, it also blew instantly. So now I'm stuck with no air at all.

What am I doing wrong? Little bastards are $5 each so I don't want to blow too many more...
SirCussFreq is offline  
post #48 of 58 Old 08-24-2013, 04:19 PM
scotty94
Registered User
2004 WJ 
 
Join Date: Aug 2013
Location: vansant
Posts: 2
well sircuss freq...I am not sure whats going on with yours...I really hope someone can help us with our problem...I found kolak on facebook and sent him a message...he is the jeep jedi...I sure hope he can use the force and get us some "force" back on our air problem issue
scotty94 is offline  
 
post #49 of 58 Old 08-24-2013, 06:10 PM
SirCussFreq
Registered User
1999 WJ 
 
Join Date: Mar 2013
Location: The Colony
Posts: 110
Bah... turns out I'm a moron and wasn't paying enough attention! I swapped the wires in the 3 wire connector, not the 2 wires that run from the controller to the blower itself. Oops. Guessing I fried the control module, hopefully that's all I messed up.
SirCussFreq is offline  
post #50 of 58 Old 07-26-2014, 10:08 PM
DeucesALLin
Registered User
 
Join Date: Nov 2013
Location: Houston
Posts: 35
Tried a 250cfm marine blower...

Jabsco 12v 250cfm flange mount blower lines up easily...dont waste your time. looks like a glovebox mounted turbocharger.

Also taped the ducting and fixed recirc, as well as cut a bigger factory intake. Then went to diffrent blower setups.

Next stop: Rear AC
DeucesALLin is offline  
post #51 of 58 Old 03-16-2015, 04:00 AM
jeffjeep2
Registered User
2000 WJ 
 
Join Date: Mar 2013
Posts: 108
Wj

did the resistor in mine when I replaced the resistor if does blows good,
i wanna clean the evap from the blower location its.

i wanna fix the recirc window i dont want to use air from outside what should be the position?

Thanks

2007 Compass
2000 WJ QD now working
ZJ 4.0 I6 sold ( i miss it)
jeffjeep2 is offline  
post #52 of 58 Old 06-22-2015, 07:32 PM
sdjp
Member
 
sdjp's Avatar
2004 TJ Wrangler 
 
Join Date: Nov 2008
Location: Virginia Beach
Posts: 386
This is a great thread with a lot of useful information; I've replaced my blower motor a couple years ago when it blew with a rock-auto one and it brought me back to the standard crappy performance of an 02' WJ. I'm going to check on all the seals and check on the motor fins to see if I should reverse my wires.

I have small kids that ride in the back and it gets nasty hot back there during summer. I've been using Walmart-type battery powered water spray bottles hanging on the roof handles to help cool things out; cheesy but better then nothing. Hey kids wanna go on an offroad adventure?......(kids)....umm in that sweatbox no thanks dad. If I ever get time and am feeling creative I'd be all about putting in a backseat AC system to really make me proud of owning the WJ.
sdjp is offline  
post #53 of 58 Old 05-03-2017, 12:20 PM
Garandguy
Registered User
2006 KL Cherokee 
 
Join Date: May 2017
Posts: 7
I just purchased a 2006 GC Overland. Noticed the same thing. Bower running wide open but very little air. Pulled glove box and removed blower motor. Looked up in to housing & blend door laying across opening. Gears were broken. Jeep does not sell just the gears. Bought the whole unit and installed just the door and actuator gears($40) Trick was getting the gears synced. Thanks to all on theis thread on how to do this . Saved me a lot of time and headache.
System works fine now. If anyone needs a just a blend door I have one. I might go to a salvage yard and pull the motor and actuator gears as they are plastic and most likely will break again.

Again , thanks to all and the forum and remember " Never own anything that can eat while you sleep"
Garandguy is offline  
post #54 of 58 Old 05-03-2017, 04:22 PM
blueseasons1
Registered User
2000 WJ 
 
Join Date: Jun 2016
Posts: 265
On mine. The left center vent blows hard. The one next to it on the right doesn't blow even half as much. I can't figure this out. Not terminal, but a nuisance.
blueseasons1 is offline  
post #55 of 58 Old 05-03-2017, 05:25 PM
HarryH3
Registered User
2001 WJ 
 
Join Date: Jul 2015
Location: Planet Houston
Posts: 1,525
Quote:
Originally Posted by blueseasons1 View Post
On mine. The left center vent blows hard. The one next to it on the right doesn't blow even half as much. I can't figure this out. Not terminal, but a nuisance.
Have you done any of this stuff? http://www.jeepforum.com/forum/f310/...vents-3544698/

Even after all the resealing, mine is still somewhat weak from the right-center vent. It seems to just be a bad design in the ductwork.
HarryH3 is offline  
post #56 of 58 Old 05-03-2017, 06:37 PM
blueseasons1
Registered User
2000 WJ 
 
Join Date: Jun 2016
Posts: 265
I haven't pulled the dash to fix this if thats what your asking. I am guess the same amounts of air is getting heated and blown into the cab. Its just that most of it is coming out of one side, rather than evenly from the 2. I have bigger issues with mine to deal with and as we all know. Nothing is ever easy.
blueseasons1 is offline  
post #57 of 58 Old 05-03-2017, 07:08 PM
HarryH3
Registered User
2001 WJ 
 
Join Date: Jul 2015
Location: Planet Houston
Posts: 1,525
Somewhere in that thread is a link to the first thing I did when we got the WJ because working a/c is imperative in Houston: http://www.jeepforum.com/forum/f310/...l#post31371505 It helped a bit, but the sealing I did while the dash was out of heater core replacement made a much bigger difference. Jeep didn't use parts that could live in the heat inside a parked rig for very many years.
HarryH3 is offline  
post #58 of 58 Old 05-22-2017, 03:12 PM
carlt828
Registered User
2004 WJ 
 
Join Date: Jan 2014
Location: Live Oak
Posts: 43
I replaced the fan controller last year and ended up with the same thing you guys had - not much air velocity coming out of the vents. If I turned on recirculating it was even worse so I was basically getting just ram air at speed. I found this thread and today looked at the two wires going to the fan motor. If you take a jeweler's common screwdriver to the ends of the connectors, you can push in a little tab on the brass connector terminal and simply pull the wires out the back. Put them back in opposite of the way they came out and once you "snap" them back into the plastic connector you're good to go. No need to cut and solder. Now my fan blows air like it should. Thanks guys.

Now it's time to re-solder the terminals on the flasher relay....
carlt828 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
No Heat blowing from vents, but can feel warm air. JPerksR6 ZJ Grand Cherokee Forum 8 02-06-2010 07:02 AM
problems with air blowing only through my defrost vents joshhuwa ZJ Grand Cherokee Forum 1 07-19-2008 08:45 PM
Air not Blowing from vents? 93' Grand Cherokee stylezprodukz ZJ Grand Cherokee Forum 1 11-22-2007 10:50 AM
Defrost not working, blowing out vents instead mattadams ZJ Grand Cherokee Forum 8 11-27-2006 12:52 PM
A/C Vents Blowing Water? cajunc4 ZJ Grand Cherokee Forum 2 08-06-2003 11:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome