AC/Heat fan only blows on high - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > AC/Heat fan only blows on high

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 08-12-2013, 09:28 AM   #1
fivelstang4
Registered User
2004 WJ 
 
Join Date: Jun 2003
Location: Richmond,VA
Posts: 99
AC/Heat fan only blows on high

I have a 04 WJ Freedom Edition. Recently the fan only works on high. Any ideas?

__________________
2004 WJ Freedom Edition 4.0 selectrac. Magnaflow muffler. 2 inch Fat Bob's Garage with 3/4 spacers in the front. Bilstien 5100 series shocks. Moog steering stabilizer. 245/65-17 Yokohama Geolander AT tires.
fivelstang4 is offline   Reply With Quote Quick reply to this message
Unread 08-12-2013, 09:34 AM   #2
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,844
Most common failure is the blower motor resistor. You may also want to replace the blower motor resistor wiring harness as well, they have a tendency to melt the connector.
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote Quick reply to this message
Unread 08-12-2013, 10:10 AM   #3
fivelstang4
Registered User
2004 WJ 
 
Join Date: Jun 2003
Location: Richmond,VA
Posts: 99
Quote:
Originally Posted by Jeeples View Post
Most common failure is the blower motor resistor. You may also want to replace the blower motor resistor wiring harness as well, they have a tendency to melt the connector.
Thanks

Any link to get replacement parts or will rockauto list them?
__________________
2004 WJ Freedom Edition 4.0 selectrac. Magnaflow muffler. 2 inch Fat Bob's Garage with 3/4 spacers in the front. Bilstien 5100 series shocks. Moog steering stabilizer. 245/65-17 Yokohama Geolander AT tires.
fivelstang4 is offline   Reply With Quote Quick reply to this message
Unread 08-12-2013, 10:19 AM   #4
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 3,134
Quote:
Originally Posted by fivelstang4 View Post

Thanks

Any link to get replacement parts or will rockauto list them?
Actually, Jeep came out with a fix: http://www.wjjeeps.com/blower_motor.htm

Sent from my iPad using my fingers
rdkendrick is offline   Reply With Quote Quick reply to this message
Unread 08-12-2013, 02:27 PM   #5
Jeeples
Registered User
2000 WJ 
 
Join Date: Jul 2006
Location: forum/f310/, UT
Posts: 4,844
Quote:
Originally Posted by rdkendrick View Post
Actually, Jeep came out with a fix: http://www.wjjeeps.com/blower_motor.htm

Sent from my iPad using my fingers
Yeah, this is one of those parts where I would actually purchase from the dealer (assuming you feel like you get a fair price for parts there) or one of the online Mopar wholesalers, like Mopar Supercenter.

Fortunately for me, one of my local dealers is usually within $5-$10 of the more popular online wholesalers, so I usually end up getting that stuff local.
__________________
His: '00 WJ 4.7 Limited- stock

Hers: '03 WJ 4.7 V8- IRO 3", 245/75/16 Duratracs
Jeeples is offline   Reply With Quote Quick reply to this message
Unread 11-15-2013, 02:23 PM   #6
gregrachelle
Registered User
 
Join Date: Aug 2013
Location: corona, ca
Posts: 1
i just fixed mine. Mine is an 02 WJ. would only blow on high. I un-plugged it at the resistor, notice the terminals looked corroded. Plugged and un-plugged several times. All works fine now.

Last edited by gregrachelle; 11-15-2013 at 02:24 PM.. Reason: added
gregrachelle is offline   Reply With Quote Quick reply to this message
Unread 11-15-2013, 02:31 PM   #7
Bangarng
Registered User
 
Join Date: Oct 2013
Location: Arlington, Virginia
Posts: 15
Just did this last week on my XJ and it was straight up the resistor. Got a new one from Advanced and problem solved.
Bangarng is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.