99 wj wont upshift at wot - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 11-26-2013, 11:55 AM Thread Starter
jeepmma2006
Registered User
 
Join Date: Nov 2013
Location: ogden
Posts: 1
99 wj wont upshift at wot

I have a 99 grand cherokee with the 4.7 v8 in it. Its runs and shifts fine all the time. But when you go wot it wont shift into the next gear unless you let off. The rpms slow down when it gets higher and you can hear the engine whine. But its not missing and the tranny isn't slipping. When your on the freeway sometimes you can feel it slow real fast for just a quick second.

Tried a new tps that didnt help. Thinking its either one or both of the speed sensors on the tranny. The cat is clogged or the fuel pump isn't putting out enough psi at higher rpms. I had one place say they didnt think it was the cat now another place says it might be. But even when you free rev it the engine makes that sound and struggles at higher rpms. Thats why im leaning towards clogged cat or fuel pump.

Can someone please help. I keep hearing this is common for this jeep but nobody knows what it is!?

jeepmma2006 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-19-2016, 03:11 PM
tcm_ga
Registered User
 
Join Date: May 2010
Location: augusta, ga
Posts: 13
Did you ever find a solution for this? I have the same issue. I have had techs look all over for the cause - transmission, exhaust, sensors, fuel pump, main computer, shift computer, and more - and they can't find anything. The last best guess was the knock sensor.
tcm_ga is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome