99 WJ stalls out after driving, turning off, then back on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 99 WJ stalls out after driving, turning off, then back on

WJ Tube Doors Now Available!*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*TJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 08-23-2013, 08:16 PM   #1
DakMan96
Registered User
1999 WJ 
 
Join Date: Sep 2012
Posts: 189
Wj 99 WJ stalls out after driving, turning off, then back on

I own a 1999 Jeep Grand Cherokee Laredo and it runs fine when I first start it up. However, after driving it for a while and parking and then coming back maybe 20 or 30 minutes later, when I turn it over my RPMs are low and the engine starts shaking and sputtering and if I give it gas it sometimes will help and bring them up but even at over 1000 RPMs it still sorta shakes and sputters. Sometimes I can floor it and it won't even make a difference , it stays at 300 RPMs until it stalls out. Then when it does stall out and crank it up again, the RPMs jump way high (maybe 1200?) and sit there for 3 or 4 seconds until they go to normal and it drives fine. So does anyone have ANY idea what to do or what it could be? Thanks in advance

DakMan96 is offline   Reply With Quote
Unread 08-24-2013, 09:45 AM   #2
DakMan96
Registered User
1999 WJ 
 
Join Date: Sep 2012
Posts: 189
Anyone??
DakMan96 is offline   Reply With Quote
Unread 08-24-2013, 09:56 AM   #3
McGR
Registered User
2007 XK Commander 
 
Join Date: Aug 2005
Location: McHenry, IL, US/IL
Posts: 264
My front oxygen sensor acted a bit like that on my '99 4.0 when it went out. Check to see if you have any codes.
McGR is offline   Reply With Quote
Unread 08-24-2013, 06:27 PM   #4
DakMan96
Registered User
1999 WJ 
 
Join Date: Sep 2012
Posts: 189
No codes for sensors, just EVAP leaks but I know what they're for and I've had them LONG before these problems
DakMan96 is offline   Reply With Quote
Unread 08-24-2013, 08:06 PM   #5
99SK04GTX
Registered User
2004 WJ 
 
Join Date: Jul 2009
Location: Hampton Roads
Posts: 422
Tps
99SK04GTX is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.