99 Grand shifting hard - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 99 Grand shifting hard

End of Summer Sale, 20% OFF!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRough Country Jeep Suspension Deals at Rockridge 4WD!

Reply
Unread 05-04-2010, 07:21 PM   #1
srode
Registered User
2008 XK Commander 
 
Join Date: Dec 2005
Location: Iowa City - Iowa
Posts: 77
99 Grand shifting hard

have a 99 grand Cherokee, Quadra Drive, runs fine but it shifts later than normal and then very hard into second. Trying to pull it down to first manually it won't do it even going slow. Getting up to highway speed it slowly shifts into OD then when down shifting on the exit ramp again it down shifts very hard to second. Just got done changing the fluid and filter (thought maybe that was the problem) and still did the same thing. Fluid didn't look too bad and the pan didn't have any debris in it. 150,000 miles on it. Any ideas?

__________________
2008 XK Commander Limited 4.7 Quadra Trak II
1999 Jeep Grand Cherokee 4x4 Quadra Drive 4.7 L 163,000 miles(sold)
2004 GMC SLT Crew Cab 4x4 Duramax Diesel
1969 Camaro Pace Car
1969 Camaro Hard top
91 Cherokee - sold at 188,000 miles, still runing great at 250k last report
srode is offline   Reply With Quote
Unread 05-04-2010, 08:18 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,444
Did you use ATF +4 ?

Sounds like more than a throttle valve cable adjustment...
ZeeJay1997 is offline   Reply With Quote
Unread 05-04-2010, 11:15 PM   #3
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 679
go to napa...buy some friction modifier...dump it in and enjoy!
bigb229 is offline   Reply With Quote
Unread 05-05-2010, 03:32 AM   #4
GRAND_WJ
Registered User
2001 WJ 
 
Join Date: Aug 2009
Location: victoria
Posts: 311
Quote:
Originally Posted by srode View Post
have a 99 grand Cherokee, Quadra Drive, runs fine but it shifts later than normal and then very hard into second. Trying to pull it down to first manually it won't do it even going slow. Getting up to highway speed it slowly shifts into OD then when down shifting on the exit ramp again it down shifts very hard to second. Just got done changing the fluid and filter (thought maybe that was the problem) and still did the same thing. Fluid didn't look too bad and the pan didn't have any debris in it. 150,000 miles on it. Any ideas?


change your transmission sensors (i think from memory there are 2, one at front and one at rear).... they tell the transmission when to change gear.

Cheers GRAND_WJ
GRAND_WJ is offline   Reply With Quote
Unread 05-05-2010, 04:46 AM   #5
srode
Registered User
2008 XK Commander 
 
Join Date: Dec 2005
Location: Iowa City - Iowa
Posts: 77
Yes, I used ATF +4 for the fluid. I was thinking TPS was going bad but I found this morning there's an 0700 code also so thinking it might be the input / output sensor bad on the transmission like Grand WJ mentioned. Are these dealer only or can I get one from NAPA etc. Any tricks to resetting the codes, I don't think a generic scan code reader will reset the ETX since it can't read the codes. Read somewhere that disconnecting the battery for 30 minutes would reset it, anybody have experience with this?

PS, speedometer works fine, but I would guess the speed sensor is in the transfer case not the transmission, right?
__________________
2008 XK Commander Limited 4.7 Quadra Trak II
1999 Jeep Grand Cherokee 4x4 Quadra Drive 4.7 L 163,000 miles(sold)
2004 GMC SLT Crew Cab 4x4 Duramax Diesel
1969 Camaro Pace Car
1969 Camaro Hard top
91 Cherokee - sold at 188,000 miles, still runing great at 250k last report
srode is offline   Reply With Quote
Unread 05-05-2010, 09:19 AM   #6
Wheelin98TJ
JEEP FREAK
 
Wheelin98TJ's Avatar
1998 TJ Wrangler 
 
Join Date: Apr 2004
Location: , Southeast MI
Posts: 24,399
There is no speed sensor on the WJ t-case like there is with many other Jeeps.

There are 2 speed sensors on the side of the tranny.

The P0700 code is telling you there is a more specific tranny code stored. A code reader that is capable of pulling tranny codes would be helpful.
Wheelin98TJ is offline   Reply With Quote
Unread 05-05-2010, 08:10 PM   #7
srode
Registered User
2008 XK Commander 
 
Join Date: Dec 2005
Location: Iowa City - Iowa
Posts: 77
Today I changed the input speed sensor, left the output speed sensor unchanged since the speedometer is working fine. Disconnected the battery for an hour to try to clear any codes and took it out for a test drive, no change - still shifts hard first to second gear. Took it out on the highway, it will finally shift to 3rd at between 65 and 70mph, around 3200 rpms, and will then go into OD. When speed drops to around 60 it will down shift hard to 2nd gear again and doesn't shift to first until going about 2mph. If I take it out of OD it won't downshift hard to 2nd when the speed drops below 60. Also, tested down shift function under a load and it will down shift out of OD under moderatly heavy throttle from 70, and will down shift to 2nd under full throttle from 70mph. After letting off it shifts back up normally. Still have the same P0700 code. I know a scan with the transmission code is needed to really get to the problem, will probably take it by a transmission shop tomorrow afternoon to see what they think / find pulling codes - They have a good reputation, built my 500hp TH350 for my Camaro and did a good job with it. Right now I am at a loss, guessing maybe it's a torque converter problem, but really pretty much lost from here without codes to work with.
__________________
2008 XK Commander Limited 4.7 Quadra Trak II
1999 Jeep Grand Cherokee 4x4 Quadra Drive 4.7 L 163,000 miles(sold)
2004 GMC SLT Crew Cab 4x4 Duramax Diesel
1969 Camaro Pace Car
1969 Camaro Hard top
91 Cherokee - sold at 188,000 miles, still runing great at 250k last report
srode is offline   Reply With Quote
Unread 05-10-2010, 04:44 PM   #8
srode
Registered User
2008 XK Commander 
 
Join Date: Dec 2005
Location: Iowa City - Iowa
Posts: 77
It was the ouput sensor - the Service manager at the Jeep deeler waa wrong apparently on the speedometer running off the output sensor - the transmission shop said they thought it ran off the ABS not the output sensor on the transmission. So now I have an extra sensor for the next time one goes out, but with both being new, and 154,000 miles, I don't think I will need another one in the life of the Jeep.
__________________
2008 XK Commander Limited 4.7 Quadra Trak II
1999 Jeep Grand Cherokee 4x4 Quadra Drive 4.7 L 163,000 miles(sold)
2004 GMC SLT Crew Cab 4x4 Duramax Diesel
1969 Camaro Pace Car
1969 Camaro Hard top
91 Cherokee - sold at 188,000 miles, still runing great at 250k last report
srode is offline   Reply With Quote
Unread 11-17-2010, 12:12 PM   #9
BrentSP
Registered User
1999 WJ 
 
Join Date: May 2006
Posts: 11
I changed out the rear sensor and it did not fix anything on mine. I then took that old rear sensor and replaced the front sensor with it and its still shifting hard. Do both sensors normally go out? I've had this same problem for a couple of years and it has not gotten any worse just have gotten used to the hard shifting.

I have so many problems with my 99 GC. It only has 96k miles. I've had it for 6 years now. Radiator replaced 3 times now............still can't keep coolant levels up for nothing........have to refill it every month or so and I can't find the leak. At idle AC will not cool cab. Had it recharged and that didn't work. Passenger side will not heat or cool but blower works. This summer my wife and I was going on a weekend trip and noticed the heater core was leaking so I had a mechanic take a look at it and he ended up just by passing the heater core and said to come back this fall and he'll replace the core. I looked into the labor that is involved to change out the heater core and its ridiculous. Removing the dash, steering column!? Why in the hell did he not just change the core out when he had all it apart? More money for him?
BrentSP is offline   Reply With Quote
Unread 11-17-2010, 01:37 PM   #10
jemrey81
Registered User
 
Join Date: Nov 2010
Location: Roseville, CA
Posts: 351
Sounds like you need to remove the dash and replace the heater core, the blend doors and the ac evaporator (this might not be you ac issue, but if the dash is out you might as well replace it).... the blend doors can be done without dash removal, but not the other 2, so you might as well hit all 3 at one time.
jemrey81 is offline   Reply With Quote
Unread 11-17-2010, 01:42 PM   #11
5point1
Registered User
2003 WJ 
 
Join Date: Nov 2010
Location: Phoenix, AZ
Posts: 63
Quote:
Originally Posted by BrentSP View Post
I changed out the rear sensor and it did not fix anything on mine. I then took that old rear sensor and replaced the front sensor with it and its still shifting hard. Do both sensors normally go out? I've had this same problem for a couple of years and it has not gotten any worse just have gotten used to the hard shifting.

I have so many problems with my 99 GC. It only has 96k miles. I've had it for 6 years now. Radiator replaced 3 times now............still can't keep coolant levels up for nothing........have to refill it every month or so and I can't find the leak. At idle AC will not cool cab. Had it recharged and that didn't work. Passenger side will not heat or cool but blower works. This summer my wife and I was going on a weekend trip and noticed the heater core was leaking so I had a mechanic take a look at it and he ended up just by passing the heater core and said to come back this fall and he'll replace the core. I looked into the labor that is involved to change out the heater core and its ridiculous. Removing the dash, steering column!? Why in the hell did he not just change the core out when he had all it apart? More money for him?
Next time, make your own thread about your unrelated problems. K. THanks...
__________________
2001 SVT Cobra, 785rwhp weekend warrior
1999 Grand Cherokee Laredo, 4.7 4x4- SOLD
2003 Grand Cherokee Overland 4.7 HO 4x4- Current
5point1 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.