7 codes on abs - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 7 codes on abs

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-30-2013, 11:57 AM   #1
toates89
Registered User
1989 XJ Cherokee 
 
Join Date: Jan 2006
Location: long island, new york
Posts: 2,190
7 codes on abs

I had my engine replaced about 6 months ago. about two weeks after the abs light came on.

I just recently jacked it up onto all four and tester the speedo on each speed sensor and replaced the front right sensor.

light didnt go off.

had the codes pulled and here they are.

abs 28

right front speed

left rear speed

right read speed

hydraulic pump circuit

abs power feed

and bus comm failure.


Any ideas?

side note i pulled the fuse panel under the hood and there was no fuse in the spot so i replaced it. didnt affect the light.

inspection is up tmrw.

toates89 is offline   Reply With Quote
Unread 06-30-2013, 12:06 PM   #2
doityourselfMM
Senior Member
 
doityourselfMM's Avatar
1999 WJ 
 
Join Date: Dec 2010
Location: manassas, va
Posts: 666
Looks like 'global' ABS terror! Is the large connector seated and locked onto the CAB (Controller-Antilock-Brakes)?

Was a DRBII used to pull the codes, or a DRBIII?
doityourselfMM is offline   Reply With Quote
Unread 06-30-2013, 07:17 PM   #3
toates89
Registered User
1989 XJ Cherokee 
 
Join Date: Jan 2006
Location: long island, new york
Posts: 2,190
Quote:
Originally Posted by doityourselfMM View Post
Looks like 'global' ABS terror! Is the large connector seated and locked onto the CAB (Controller-Antilock-Brakes)?

Was a DRBII used to pull the codes, or a DRBIII?

not sure advance pulled the codes
toates89 is offline   Reply With Quote
Unread 07-01-2013, 09:29 AM   #4
pinky2252s
Registered User
2001 WJ 
 
Join Date: Oct 2011
Location: Broomfield, Colorado
Posts: 1,824
Quote:
Originally Posted by toates89 View Post
not sure advance pulled the codes
Then they most likely were not read with a DRB3 scan tool. It needs to be read with a DRB3 to get the proper codes.
__________________
Is it broken?

Colorado Jeep Club Member #2252
2001 Laredo, 2004 Special Edition
pinky2252s is offline   Reply With Quote
Unread 07-01-2013, 12:16 PM   #5
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati, Ohio
Posts: 2,476
Quote:
Originally Posted by pinky2252s View Post

Then they most likely were not read with a DRB3 scan tool. It needs to be read with a DRB3 to get the proper codes.
Most likely an OBDII reader. That's what these places use and mostly to get CEL codes.

Sent from my iPad using Forum Runner
rdkendrick is offline   Reply With Quote
Unread 07-18-2013, 09:12 AM   #6
toates89
Registered User
1989 XJ Cherokee 
 
Join Date: Jan 2006
Location: long island, new york
Posts: 2,190
After 100 or so miles my light went off. i guess the sensor did the trick.
toates89 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.