Is the 42RE Transmission as bad as I've heard? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > Is the 42RE Transmission as bad as I've heard?

Black Friday- Cyber Monday Deals at jeepHutBlack Friday Deals !JcrOffroad Black Friday Sale!

Reply
Unread 11-04-2014, 11:22 AM   #1
YJTim89
Registered User
1989 YJ Wrangler 
 
Join Date: Jul 2014
Location: Wayne, NJ
Posts: 62
Is the 42RE Transmission as bad as I've heard?

Everything I've read about the 42RE says that it has a less than stellar reputation for reliability. Is the 42RE as bad as they say it is? If so what are some options for fixing/replacing it? It seems to me that the biggest obstacle in outright replacing it would be getting the computer to play nice with a new transmission.

__________________
My Build Project WhYJ?

http://goo.gl/C2vCQD
YJTim89 is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 11:32 AM   #2
Acc0919mc
Registered User
2000 WJ 
 
Join Date: Jan 2013
Location: East Palestine, Ohio
Posts: 514
I have never had a problem with mine, my friends had 250K when he sent it to the junk yard and the transmission was still fine. I have 150K
__________________
Mine 00' WJ Laredo-4.0
Mom's 06' WK Limited-5.7
Dad's 01' WJ Limited-4.7
Acc0919mc is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 11:38 AM   #3
biffs
Registered User
2000 WJ 
 
Join Date: Feb 2014
Location: Ottawa, ON
Posts: 145
300,000km here, started getting a code in the winter for a bad governor or something like that. Gonna have to do this http://www.jeepforum.com/forum/f310/...te-up-1182260/
__________________
Build thread: http://www.jeepforum.com/forum/f197/biffs-build-thread-2000-wj-2102889/
(Not sure why I can't make that a real link)
biffs is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 12:35 PM   #4
wj4play
Web Wheeler
 
wj4play's Avatar
1999 WJ 
 
Join Date: Apr 2010
Location: Des Moines, Iowa
Posts: 1,282
195k here never one once of trouble
__________________
99 Grand, 37" and mostly factory - Raised tank and trimmed fenders etc
wj4play is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 01:19 PM   #5
offroading.net
Senior Member
 
offroading.net's Avatar
2000 WJ 
 
Join Date: Jul 2004
Location: Malpas, Cheshire, UK
Posts: 544
250k miles and no issues apart from a rear speed sensor which is a 5 minute fix
__________________
Steve Wright

1999 4litre WG Limited, 4"f-4.5"r IRO springs, IRO front long arms, IRO adjustable rear a-arm & LCAs, IRO adjustable RHD trackbar, XJ 242 transfer case, 3.91 Diesel Quadradrive axles, 235-85-16 Grabber AT2's Build thread

2003 2.8CRD KJ Limited

Previous Jeeps - 8 XJs, an MJ, a WJ, a TJ & a KJ

steve@offroading.net
www.offroading.net
www.rcmodelflying.com
www.oldchadscider.co.uk
offroading.net is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 02:08 PM   #6
cNagy
Registered User
1999 WJ 
 
Join Date: Oct 2014
Location: Bowling Green, Kentucky
Posts: 48
350k on my previous wj, sold it because the 4.0 engine was going out. Yeah the 4.0 engine went out before the 42re tranny, you dont hear that everyday. Take care of it and it will take care of you. You might have to replace the governor sensor and solenoid a few times during, but it can be a good transmission.
cNagy is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 02:31 PM   #7
losttech
Senior Member
 
losttech's Avatar
2000 WJ 
 
Join Date: Jun 2013
Location: , NV
Posts: 726
I thinks its like anything on the jeep take care of it don't thrash it and it will last.
Mine is still nice and smooth at 140k don't think its had any major service besides fluid changes and filter.
__________________
2000 Jeep grand Cherokee
I6, selectrac, dana 30 front 44a rear
Stock not lifted.
losttech is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 02:41 PM   #8
YJTim89
Registered User
1989 YJ Wrangler 
 
Join Date: Jul 2014
Location: Wayne, NJ
Posts: 62
That's interesting. I was getting worried when I was reading all the bad stuff about the 42re online. Why do people hate on it so much?
__________________
My Build Project WhYJ?

http://goo.gl/C2vCQD
YJTim89 is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 02:50 PM   #9
wj4play
Web Wheeler
 
wj4play's Avatar
1999 WJ 
 
Join Date: Apr 2010
Location: Des Moines, Iowa
Posts: 1,282
Quote:
Originally Posted by YJTim89 View Post
That's interesting. I was getting worried when I was reading all the bad stuff about the 42re online. Why do people hate on it so much?
Because its not a th400 or a 4l80e or a 545re etc...

Anything will break if you thrash on it but also anything will live a long life if taken care of. First thing I did was install a tranny cooler on mine
__________________
99 Grand, 37" and mostly factory - Raised tank and trimmed fenders etc
wj4play is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 02:54 PM   #10
JohnnyV
Registered User
2002 WJ 
 
Join Date: Dec 2006
Location: Jersey Shore
Posts: 198
Quote:
Originally Posted by wj4play View Post
Because its not a th400 or a 4l80e or a 545re etc...

Anything will break if you thrash on it but also anything will live a long life if taken care of. First thing I did was install a tranny cooler on mine
Yep... I also installed a tranny cooler on mine. The tranny is at 23x,000 miles... not one problem.
__________________
2002 WJ Limited 4.7L
1995 ZJ Laredo 4.0L
1989 XJ Laredo 4.0L - Sold
JohnnyV is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 03:14 PM   #11
biffs
Registered User
2000 WJ 
 
Join Date: Feb 2014
Location: Ottawa, ON
Posts: 145
Quote:
Originally Posted by JohnnyV View Post
Yep... I also installed a tranny cooler on mine. The tranny is at 23x,000 miles... not one problem.
Tranny cooler on mine as part of the Tow Prep package as well
__________________
Build thread: http://www.jeepforum.com/forum/f197/biffs-build-thread-2000-wj-2102889/
(Not sure why I can't make that a real link)
biffs is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 04:40 PM   #12
Jaspah
Registered User
2002 WJ 
 
Join Date: Oct 2012
Location: Hamilton, NY
Posts: 249
Quote:
Originally Posted by YJTim89 View Post
That's interesting. I was getting worried when I was reading all the bad stuff about the 42re online. Why do people hate on it so much?
Negativity bias.
Jaspah is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 07:03 PM   #13
Acc0919mc
Registered User
2000 WJ 
 
Join Date: Jan 2013
Location: East Palestine, Ohio
Posts: 514
Im very hard on my 42RE and has no issues *knock on wood*
__________________
Mine 00' WJ Laredo-4.0
Mom's 06' WK Limited-5.7
Dad's 01' WJ Limited-4.7
Acc0919mc is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 07:50 PM   #14
dlundblad
Registered User
2003 WJ 
 
Join Date: Jun 2009
Location: Indiana
Posts: 279
Out of all the high mileage 42re guys, who has adjusted the bands?


160k on mine. No band adjustment yet.. The only thing I have done to it is 3 fluid drain and fills.


Quote:
Originally Posted by JohnnyV View Post
Yep... I also installed a tranny cooler on mine. The tranny is at 23x,000 miles... not one problem.

Did you install the extra cooler before or after the factory cooler?
__________________
David_Silver WJ Laredo 4.0
2"BB with Monroe Reflex shocks on 245/75/16 Goodyear Duratracs
OME SS_IPF series 868 lights
Plus a few other junkyard goodies...
dlundblad is offline   Reply With Quote Quick reply to this message
Unread 11-04-2014, 07:59 PM   #15
jay-h
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2006
Location: , NJ
Posts: 4,494
The thing is, people with working ones don't typically post just to say 'all is well'
__________________
My toys
'89 Wrangler YJ
'47 CJ2-A

wife's toys
97 Grand Cherokee (ZJ)
87 MB 560SL roadster
jay-h is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.